Devices not showing in my account

I recently purchased a subscription (BItdefender Total Security--for Mac) for 5 devices (for home, not office). I have installed Bitdefender on 4 family laptops (using links sent to each laptop on emails from Bitdefender), but only 2 of the laptops show in my Bitdefender Central dashboard. The installation has been successful on the other 2 laptops, so how can I prompt them to appear?

Answers

  • Follow up...just found a topic in support (first part pasted below), which I guess explains it (this suggests that 3 of my family laptops share the same MAC address, and all appear as if a single device in my Bitdefender Central). So, follow up question: does this impact how Bitdefender works? I.e. does it matter? (I really don't want to have to follow the convoluted directions for uninstalling/reinstalling etc.) Thanks for any advice. Jen

    My devices are replacing each other in Central

    Situations in which devices are replacing each other in Bitdefender Central (i.e they are not displayed simultaneously) appear when two or more systems share the same MAC address. This is only a glitch in the way Bitdefender Central displays them, with no impact on the security of the devices.

    Currently, if two or more computers share the same MAC address on any network (physical or virtual), Bitdefender Central identifies them as the same device and shows only one at a time in My Devices. This is common with,virtualization software (e.g. VMware, VirtualBox, Parallels, Bootcamp, etc.) and VPN software, as they generate the same MAC address on all the devices. However, it is not restricted to this types of software.

  • I am having the exact same issue. I installed onto two different devices (two different Mac addresses), and both show as the same device :( is it actively working on both devices?

  • Sign in to your Microsoft account on an Xbox or PC. Download an app or game from the Microsoft Store. Go to account.microsoft.com/devices, select Don't see your device?, then follow the instructions. On an iOS device: Download Microsoft Edge from the Apple App Store and sign in with your Microsoft account.

  • I am having the same problem with 2 of my devices (iMac and MacBook Pro). I added the iMac first and a day later I added the MacBook. The MacBook doesn't show in central, although changes I make on it (uninstalling the VPN etc) reflect in the dashboard as if i was doing the action on the iMac. It's almost like both devices are sharing the same device ID.

    As a network engineer, im very familiar with MAC Addresses and based on another post I found having similar issues, checked both devices and confirmed they had different MAC Addresses (on both Wifi and LAN interfaces) and none of the interfaces were virtual.

    Seems to be a pretty big issue this does, and lots of people struggling with it. It's frustrating as on my MacBook it found an infected file (false positive) and it told me the file was actually on the iMac! I got very confused when I followed the file path, only to find the folder/directory didn't exist... no wonder, it was on a completely different computer than it was reporting it to be on!

    I hope they sort this soon, as it's one of the reasons I invested in a 20 licence package, so i can add all devices for the family and manage them from a central dashboard... which it seems now I cannot until they fix it.