Bitdefender 2020 NO LONGER WORKS on two Win7 HTPC's with Ceton TV Tuner cards

I now have an additional FATAL PROBLEM with Bitdefender 2020: IT NO LONGER WILL INITIATE on both of these Win7 HTPC machines, both of which have a Ceton TV tuner card in it. This is a NEW ISSUE and I have already opened a support ticket today, 1007470964, and already uploaded all of the support tool files plus additional screenshots to provide diagnostic information.

So we are now going on 3 years since my original encounter with this Bitdefender Central problem of being unable to distinguish these two separate HTPC machines as far as unique licensing and "device details". Because the MAC address is the same for the two Ceton TV Tuner Cards (which appears as a "network adapter" in Device Manager) in each of the two machines, it probably appears that I have tried to install Bitdefender on TWO SEPARATE MACHINES using the same license code??

Or maybe a recent change to Bitdefender Central (in response to my 2019 ticket, finally now 3 years later) to try and distinguish what's going on here doesn't actually work as the developers thought it would?? Certainly nobody from Bitdefender has ever contacted me about this in the past 3 years, so I honestly don't believe there is yet a fix available.

Anyway, something NEW is definitely going on somewhere as of quite recently, and it has TOTALLY DISABLED the boot-time successful initiation of the full set of Bitdefender Services. And as each of my two Win7 HTPC machines containing their Ceton cards was rebooted in the past few days, the Bitdefender normally red icon in the System Tray is now GRAY, with an error message about "Bitdefender services are not responding". They actually do appear active (per task manager, and per SERVICES.MSC) but the Bitdefender icon is gray and not red.

Right after booting the icon is initially red, as I guess the product runs through its boot-time initialization and license verification. Apparently something then goes wrong, and the icon turns gray. And the product is NOT WORKING. And this happens on BOTH of my Win7 HTPC machines with the Ceton TV tuner cards.

Again, note that the supposedly unique network adapter in each PC that Bitdefender Central uses as its "device details" is INCORRECT for both of these machines, since the Ceton card is seen as the FIRST NETWORK ADAPTER in Device Manager on both machines, and the MAC address in these cards is DUPLICATE. It is the second network adapter in each machine (i.e. the Intel LAN adapter) which SHOULD BE USED (as its MAC address IS UNIQUE), but this is not being done.

I am quite sure this is at the heart of this brand new issue that just started within the past few days, and which has now caused Bitdefender TO NO LONGER WORK on both of my Win7 HTPC machines each of which has a Ceton TV tuner card in it.

In contrast, my other 20 machines (all Win10) using Bitdefender all continue to work properly. But none of those other machines have Ceton TV cards (with duplicate MAC address) in any of them.

NOTE: For some reason I am unable to post the screenshot images I'd like to, in order to clarify my comments. The forum says "you need to be around a bit longer to post links". I am simply trying to insert an image, and I have been a forum member for over 3 years!!!

I will keep trying. Rest assured I really do want to include pictures. I only have 4 hours to "edit" this first post. So if necessary I may need to post my screenshots as a "reply".


  • Gjoksi
    Gjoksi DEFENDER OF THE YEAR 2022 ✭✭✭✭✭

    @Alexandru_BD and @Mike_BD, please take a look here and check the ticket's status. Regards.

  • DSperber
    DSperber ✭✭✭


    Thank you.

    On a related question, is there some reason that my forum userid is unable to insert an "image"? This is not even an external URL link to a picture-hosting site where the image might be. It is simply using the "upload image" button at the bottom of the "leave a comment" composition window (e.g. that I am using right now to reply to your reply).

    Whenever I push the "insert image" button it is properly handled. The image is inserted correctly into the composition window perfectly placed and rendered. Everything is perfect. I can insert multiple images, to support my text.

    However when I then push the "post comment" button it fails to complete. Instead, at the top of the composition window I get a RED ERROR MESSAGE that says:


    Well, I've been a forum member here for about 3 years. I've got quite a number of posts and replies already posted in this and other threads. I'm not even posting a "link" but rather just "insert image" which is being handled correctly to your local attachment database (apparently, per what is present in the composition window). It is only that you are either totally suppressing images or my forum user id is somehow being restricted.

    Can you please UN-RESTRICT my userid, so that I can post images?


  • Gjoksi
    Gjoksi DEFENDER OF THE YEAR 2022 ✭✭✭✭✭


    Only @Alexandru_BD and @Mike_BD (both are admins of this forum) can answer your question and un-restrict your profile.

  • DSperber
    DSperber ✭✭✭
    edited June 2022

    Well, this is getting unproductive.

    (1) I did receive an email notifying me of the reply by @Gjoksi advising me that I had been "mentioned" in his post, i.e. in his reply just above. And that reply advised me that either of two admins for the forum could look into my difficulty inserting an image in my posts... which totally was prevented, as I said previously. The email also included a URL link for "check it out", which actually did take me directly to that reply on the forum discussion. Excellent.

    (2) I also got a second email notifying me that @mrmirakhur had also "mentioned" me in his own post (presumably following up on his investigation) post ON THIS DISCUSSION. Well, there is no such post on this discussion. The email also contained a URL link for 'check it out", but in this case I get a "COMMENT NOT FOUND; the page you were looking for could not be found". And sure enough, as you can see above, the very last reply on this discussion if from Gjoksi, not from mrmirakhur.

    (3) The message quoted in that second email from mrmirakhur said: "As checked, there is currently no issue with your account. Kindly, drag and drop the image in the post. See if it works." Well, I have been trying it for several days now, all unsuccessfully. And it is STILL UNSUCCESSFUL!! Doesn't matter if I actually do a "drag and drop" from source to target (in the composition window), or if I push the "insert image" button below the composition window. In both cases the image is inserted perfectly! There is no problem inserting the picture using all methods possible. However when I push the "post comment" button, as I have stated previously my post is REJECTED with a red error message that says "YOU HAVE TO BE AROUND FOR A LITTLE WHILE LONGER BEFORE YOU CAN POST LINKS".

    ==> Once again. apparently I am only allowed to post TEXT. I CANNOT POST IMAGES!!

    Also... what happened to your post which was linked-to in the email I received? It is not on this discussion.

  • Flexx
    Flexx Defender of the month mod

    (2) I also got a second email notifying me that @mrmirakhur had also "mentioned" me in his own post (presumably following up on his investigation) post ON THIS DISCUSSION. Well, there is no such post on this discussion. The email also contained a URL link for 'check it out", but in this case I get a "COMMENT NOT FOUND; the page you were looking for could not be found". And sure enough, as you can see above, the very last reply on this discussion if from Gjoksi, not from mrmirakhur.

    Regarding point (2), I deleted my comment after I posted it, that is why you got the notification but the comment was not there.

    Regarding your query, as @Gjoksi said, you will get a reply back from the bitdefender staff members, @Alexandru_BD, @Mike_BD


    OMEN Laptop 15-en1037AX (Bitdefender Total Security) & Samsung Galaxy S22 Ultra (Bitdefender Mobile Security)

  • Hello @DSperber, good to have you back in the community!

    I have asked my colleagues from the Technical Support teams to prioritize your request and they will reply as soon as possible.

    In regards to the permission to add pictures, this is tied to the rank and as soon as a member reaches Level 2 **, the feature is automatically unlocked. For Level 2 to be achieved, there are two criteria: reach the 50 points mark and post at least 5 times. As you've been with us since 2019, I have now upgraded your rank and you may now add pictures and attachments to your posts.


  • DSperber
    DSperber ✭✭✭
    edited June 2022

    Thank you addressing my "rank", thus now allowing me to post images.

    (1) This is "the symptom". The BD icon begins as red following a reboot, but then goes gray. And when the mouse is hovered over the gray icon the flyout message says "Bitdefender services not responding". This only occurs on my two Win7 HTPC machines (with my other three Win10 laptops continuing to work fine, with red icon).

    This only just started a few days ago, as each of the two machines got rebooted. Up to the reboot they both still had a red icon. It was only when each machine was rebooted that the red icon changed to gray (still leaving red icon on the other machine that had not yet been rebooted). And then when the second machine got rebooted it too now showed the red->gray icon symptom.

    There was NO CHANGE OF ANY KIND to either machine regarding the Win7 system setup, or to Bitdefender as installed on that machine... or any of the other Win10 laptops on my LAN, for that matter. It was only the reboot in the past few days which triggered the symptom. I am convinced it has to do with something you must have changed in Bitdefender Central regarding licensing, or MAC authorization, or something, and which is now confused by the DUPLICATE MAC values presented from both of these machines because you are looking at the wrong network adapter, i.e. the Ceton TV tuner card rather than the Intel LAN adapter.

    (2) As I first reported back in 2019 (and which was acknowledged back then as a problem which was being turned over to development for resolution), both of these problem Win7 HTPC machines have a Ceton TV tuner card in it which communicates using TCPIP. And each card has a duplicate MAC address, not the expected unique MAC address which would be in any real internet-enabled device. The Ceton cards do not communicate over the external internet, but rather only internally over the home LAN.

    (3) Bitdefender Central is mistakenly examining the FIRST network adapter (never expecting the Ceton TV card) and expecting it to have a unique MAC address, as ALL internet-enabled devices do. In the case of the Ceton cards, they do not communicate over the internet but only over the LAN (or even more privately and locally on just a machine), so their imbedded MAC address is a CONSTANT (and not unique) 00:22:2C:FF:FF:FF.

    (4) As you can see from what I was forced to do to keep this straight, whichever machine is INSTALLED SECOND gets to update Bitdefender Central's one-and-only "device", since it is the MAC address which is used to define a device. It was never expected to be a duplicate, but rather always expected that MAC address would be guaranteed unique.

  • DSperber
    DSperber ✭✭✭

    NOTE: my five machines on my home LAN are externally seen by an external IP address (returned from WHOAMI) associated with my modem and external IP address assigned by my ISP.

    And of course eachj machine's Intel network adapter (connecting to the modem and out to the internet through my router) has a unique MAC address.

    Presumably Bitdefender Central knows not only the [supposedly unique] MAC address of [supposedly[ my Intel network adapter as well as the "machine name" (i.e. "device name"), but also the external IP address through which Bitdefender running on my machines is seen as when communicating to Bitdefender Central for licensing and authorization purposes when the services initiate on my machines at boot time.

    So, if Bidefender Central expects to see what is supposedly the MAC address of my network adapter as 00:22:2C:FF:FF:FF for verification and authentication purposes at Windows boot and services initiation time , and attempts to confirm that MAC address... well there's going to be a problem. That MAC address is "fake", artificially installed in my Ceton TV tuner cards (one in each of the two machines exhibiting the problem) and is NOT involved in any external internet communication.

    It should be the MAC address of my Intel network adapter which is detected by Bitdefender running on my machines, and used for identification/verification purposes by Bitdefender Centeral at Windows boot time. But is is not. It is instead 00:22:2C:FF:FF:FF, mistakenly.

    Surely this is something that should be considered as a "root cause" of the sudden "gray icon" symptom, just this week after three years of "running acceptably" on these same two machines. Something must have changed this week at Bitdefender Central that no longer authorizes Bitdefender running on these two machines to operate properly.

    Surely this all must be relevant. No?

  • DSperber
    DSperber ✭✭✭
    edited June 2022

    Still no reply or further contact from Support on my open ticket 1007470964.

    I am still without Bitdefender protection on both of these Win7 HTPC machines.

    I am willing to provide any additional diagnostic information you ask me to produce or deliver. If you have a special debug-version of the product which will gather lots of internal clues that might help you get to the bottom of why "Bitdefender services are not responding" I would be glad to install it.

    But I need some CUSTOMER SUPPORT HERE!! Surely you have engineers who have the skill level to debug problems and resolve them, no??

  • @DSperber we're on it, I've asked one of the technical supervisors to prioritize your inquiry. You should expect a response by the end of the day. It is my understanding that a remote session might be required. But my colleagues will get back to you with further details.

    Thank you for your patience and understanding.

    Best regards

  • DSperber
    DSperber ✭✭✭

    Well, BAD NEWS I'm afraid.

    Early this morning I had a remote session with your engineer Tudor C. He used Team Viewer (which I already had installed on my machine, not needing to install it specially for this session), and just arbitrarily changed my own "personal password" to his own. This allowed him to reconnect after rebooting without needing me to provide the random passcode normally produced each time Team Viewer starts. He never asked me if I saw what he was doing, and did I have a note of my personal password so that I could reinstall it after he left. (thankfully, I do know what my personal password was, although Tudor simply ended his session by erasing his password... never reminding me that I would have to reinstall my own password).

    So after looking around at my system, he performed a TOTAL UNINSTALL of my previously installed Bitdefender environment. He didn't bother to ask me if I had notes regarding any customizations I might have applied, like Firewall rules, etc., but just blasted away my previous install totally. (thankfully, I happen to have notes about my customizations, so in theory I could reapply things... if Bitdefender actually was brought back to "red icon" normal operation).

    Then he cleaned things up, deleting all Bitdefender-related program and programdata folders, as well as all Bitdefender-related Registry keys. Total cleanse.

    Then he performed a normal brand new from-scratch reinstall of Bitdefender. Upon initial installation of the automatically downloaded version, the initial icon was red. So Tudor now believed "he had solved my problem", not caring to really confirm things were going to stay red and not revert to gray.

    While he was still connected, before he departed, I showed him my real problem regarding the presence of the Ceton TV tuner cards, which are present on both of my two Win7 HTPC machines and cause Bitdefender Central to registere both of my machines using the same MAC address (artificial 00:2C:22"FF:FF:FF). Tudor had little interest, and said there's nothing he could do. He said he would report this (but it already had been reported to development back in 2019 when I first observed the issue).

    Anyway, Tudor then said "have a nice day" and quickly disconnected from my machine... thinking (wrongly as it turns out) that he had magically solved the problem through the total uninstall/cleanse/reinstall.

    Well, it turns out he did NOT FIX ANYTHING!!! Yes, the icon remained red until the subsequent product updates were automatically applied, and Bitdefender VPN installed, and a restart was requested. And sure enough as soon as I rebooted for the first time after these product updates got applied, well once again the red icon changed to gray.

    ==>> NO FIX BY TUDOR!! A total uninstall/cleanse/reinstall DOES NOT FIX THE PROBLEM.

    And I hadn't even yet had a chance to reapply my Firewall rules, so that isn't a suspect as to what might be going on. And I hadn't even had a chance to uninstall Bitdefender VPN (which I always do), so that can't be a suspect either. In fact I've done nothing, except watch Tudor do the uninstall/cleanse/reinstall and then depart... with the icon still red at that time, because "updates" had not yet gotten applied.

    I'm afraid this ticket cannot yet be closed. I think a different engineer needs to get involved, one who might think of something else to look at or try, outside of just a product reinstall. It is the UPDATES which triggered the red icon to go gray, so that should be a giant clue.

  • Hi @DSperber and thank you for sharing the outcome of the investigation with us.

    The technical teams have expressed their regrets for this inconvenience. We're sorry that we changed your teamviewer password without informing you, it's an action the engineers take as standard in remote sessions, to make sure we don't bother customers too much by asking them for a new password several times during the call. They usually take it out in the end, it was a human error from what I understand.

    During the remote session, they tried to eliminate the most basic problems and possible root causes, but came to the conclusion that the issue of services not responding is caused by the presence of several network cards with different MAC addresses that can confuse the communication system with the Bitdefender subscription. It's a well known bug we've been working on for a while and unfortunately we don't have a workaround yet.

    A MAC address is a unique hardware identifier of a network card. Bitdefender is using the MAC address as a unique identifier, which normally would make sense as this should be unique. However, some third-party programs add the same MAC address on each device and this is where the problems start to appear.

    Currently, your ticket has been escalated to Tier 3 Technical Support, which means that this situation may take longer to resolve, as it requires special attention and further investigation. As soon as updates become available, our technical engineers will get back to you on the open case.

    I am truly sorry for the inconvenience caused to you.

    Best regards

  • DSperber
    DSperber ✭✭✭

    I have to remark that I don't think you're pursuing the right cause of the problem. I don't think that the issue is that there is more than one network adapter and therefore multiple MAC addresses, which may or may not be "unique" (in the universe) or non-unique (which perhaps confuses Bitdefender Central).

    I think the problem is that the particular network adapter you have settled on in order to identify my device in Bitdefender Central (and perhaps also to communicate properly with Bitdefender Services running on my machine), and which thus causes the icon to be red or gray, is that YOU HAVE PICKED THE WRONG (or just unacceptable) network adapter!!!

    You probably assumed that ALL (or the first) network adapters "talk to the internet) which perhaps figures into how you authorize licensing with Bitdefender Central or communicate with services on my machine.

    Well, I suggest that all you need to do is IGNORE any network adapter whose MAC address is 00:2C:22:FF:FF:FF!!!

    Just ignore it! Sure, you may want your developers to really solve the problem, and figure out a true solution. But in the meantime... JUST IGNORE THE CETON CARD, when you see its MAC address!! Just skip it. Make believe it was never there!!!

    To prove my point, on the same Z170 machine I dual-boot either to Win7 or Win10. In Win7 the Ceton TV Tuner card is supported by Ceton drivers, allowing its use in Windows Media Center. But in Win10 there are no drivers for the card. So in Win10 the device shows up as "other devices', i.e. an unnamed multimedia device. In contrast in Win7 the device shows up as a "network adapter, in front of the Intel LAN adapter(s) that actually talk to the internet.

    So, here is Device Manager for Win7 on my Z170 (which happens to have TWO Intel LAN network adapters, one of which I actually use and have connected, and the other of which I have "disabled"). Note that the Ceton card is first, followed by the two Intel network adapters. But only ONE IS ACTUALLY CONNECTED TO THE INTERNET... which is the [first] network adapter YOU SHOULD LOOK FOR!!! There might be multiple network adapters actually connected to the internet, and ANY OF THEM are "real" and have a "unique MAC address". So this is what your criteria should be for scanning "network adapters" and picking one to use to identify my device. It should NEVER BE THE CETON CARD!!

    Now in contrast, here is the same Z170 machine but booted to Win10, and its Device Manager. As I mentioned above, note that the Ceton card is not in "network adapters" because there is no Win10 driver for it. But there still are multiple network adapters (including the same two Intel adapters), but again only one of which is "connected to internet". So again... THIS IS THE ADAPTER YOU SHOULD PICK, i.e. the one which talks to the internet. It MUST have a unique MAC address, since it's a true real internet-enabled piece of hardware.

    I note that while Bitdefender DOES NOT WORK ANY LONGER ON MY WIN7 MACHINE (because of some recent "update" as we now know, since it was a red icon until post-install "updates" were applied and the machine rebooted) it DOES WORK IN WIN10!!!

    And the only difference really is that the Win7 machine has the Ceton card (with its non-internet phony MAC address) in "network adapters" and you picked it for use, vs. the Win10 machine which does NOT have the Ceton card so that you picked the Intel LAN adapter which is talking to the internet.

    ==> IN THE SHORT TERM, just put a patch it that ignores the Ceton card with its non-internet MAC address of 00:2C:22:FF:FF:FF and grab the NEXT adapter (which is actually connected to the internet). I would like to see Bitdefender working again on my two Win7 machines.

    In the meantime I have temporarily installed Malwarebytes Premium in order to have at least some protection on these two machines.

    NOTE: these two machines have been successfully protected by Bitdefender for the past 3 years... until last week, which obviously some update that you pushed out has now destroyed the product on these machines. They both have had their Ceton cards in them for these past 3 years, and it was no problem for Bitdefender... until last week. So something new that you pushed out in "updates" (and which requires me to reboot) is what is totally responsible for this new "gray icon" symptom.

    Surely your engineers are smart enough to figure out what they changed just in the past week which is causing this, and BACK IT OUT if only temporarily until you can really fix everything you wanted to fix without breaking Bitdefender on my Win7 HTPC machines with the Ceton cards. Or, just IGNORE 00:2C:22:FF:FF:FF if you see it as a MAC address, and go on to the next adapter. Or, simply look for the [first[ adapter which is connected to the internet.

  • DSperber
    DSperber ✭✭✭

    One more thought, to possibly assist your developers find exactly what they changed in the updates pushed out over the past week that are obviously causing this problem (since the exact same Win7 machine with the exact same Ceton card has been running Bitdefender perfectly for the past 3 years... until just last week).

    After I reboot Win7, the icon is red. And it remains red for 30-45 seconds. And then it changes to gray. So obviously things are going on during those 30-45 seconds, which eventually triggers a "services not responding" situation that causes the red icon to turn gray.

    Why don't you ship me a special debug version of Bitdefender, which has a "verbose trace log" output generated during its post-boot initialization activities. You could stop generating log output when the icon goes gray. Then everything you produce on the trace log up to that point must clearly be relevant in determining exactly what is "new in the past week" and which is now resulting in the gray icon.

    Again, for the past 3 years the icon wasn't gray. It was red. And Bitdefender performed normally, in the very same machine that has always has the Ceton card in it. This gray icon symptom is just in the past week, so you must have pushed out some change in "updates" which is responsible for the now broken behavior. Ask your developers to build a special "debug version" with "verbose trace log output" during initialization. Let the program itself find the "culprit" logic responsible for this new bug.

  • DSperber
    DSperber ✭✭✭
    edited June 2022

    Just to reiterate one more time some "giant clues" here.

    (1) These two machines (both of which are Win7 HTPC machines with Ceton TV tuner cards inside) have had no hardware or software change for the past 3 years. They have both been running Bitdefender normally (i.e. with the red icon) for these past 3 years... until last week. In other words for the past 3 years the Bitdefender has been red, and only in the past week has something changed so that the red icon (right after reboot) changes to gray within 30-45 seconds.

    (2) I am 100% certain that the problem relates to having the Ceton tuner card appear first in Device Manager as a network adapter, and in the Win7 world (where Ceton drivers exist) Bitdefender is picking up this first network adapter in order to identify my machine for "device details" given to Bitdefender Central. So it is the Ceton MAC address (i.e. 00:2C:22:FF:FF:FF) which is shown in "device details", and this is clearly not a good thing. This network adapter IS NOT CONNECTED TO THE INTERNET. But there is another network adapter (i.e. Intel, with a true real and unique MAC address) WHICH IS CONNECTED TO THE INTERNET. It is this Intel network adapter which is connected to the internet that should be picked up to identify my machine, not just the "first network adapter".

    In contrast, when I boot the Z170 machine to Win10 (this particular machine is dual-boot, both Win7 and Win10) where there is no Win10 version of the Ceton driver, the Ceton tuner card DOES NOT APPEAR as a network adapter. In this case the first network adapter (which is a genuine internet-capable and internet-connected Intel network adapter) gets picked up by Bitdefender. Everything is now normal, and the icon is red and remains red.

    (3) Attempting a complete uninstall/cleanse/reinstall of Bitdefender, using the very latest download installer file (bitdefender_windows_43de093f-7a12-4313-a097-938d15ada3bf.exe) initially produces a red icon which remains red, leading one to believe everything is normal now. But in fact, things are only "normal" using whatever code is in this particular installer.

    However once the product is installed, an automatic first-update takes place. I would assume there are anti-virus updates that get applied during this first-update, along with "engine updates", and also Bitdefender VPN. I would think the latest installer file would have everything already pre-packaged into it, but apparently not. And apparently Bitdefender VPN doesn't get installed with the installer package, but only after that first-update. So there is always this first-update that gets run after a brand new install.

    And then following that first-update a reboot is required. And once the machine is rebooted, with all of whatever updates just got installed, well now the red icon appears for about 30-45 seconds after reboot but then changes to gray. Again, I point out that this NEVER HAPPENED BEFORE THIS PAST WEEK!!! The exact same scenario was performed on both of these machines 3 years ago when I first adopted Bitdefender as my anti-virus product. On occasion I have had to uninstall/reinstall, but again never saw this red->gray icon problem until this past week!!!

    This convinces me that there is something really "brand new", just pushed out in those first-updates now applied for an install done in this past week, which is responsible for the red-> gray icon problem. I don't think it is Bitdefender VPN (which gets installed with this first-update), although it might be. But I normally uninstall Bitdefender VPN anyway, so it's not ever truly present (and never has been for the past 3 years). And yet even with Bitdefender VPN getting uninstalled after having just getting installed, I still now see the red->gray icon problem.

    (4) With no hardware changes to either machine, there must be a Bitdefender change that occurred in just this past week which is totally responsible for the brand new red->gray icon problem. It was never present in the past 3 years, until this past week

    And obviously it is directly connected to the Ceton TV Tuner card and its fictitious MAC address, and the fact that this "network adapter" (in Win7 only, not in Win10) isn't actually connected to the internet.

    How much more precise does the description of symptom and likely cause need to be, for your developers to zero in on exactly what change they made in just the past week which is now being impacted negatively by the presence of the Ceton phony-MAC network adapter when it never was a problem in the past??

    (5) Again, the problem NEVER EXISTED BEFORE THIS PAST WEEK!!!

    And it doesn't exist with the freshly installed product. It only starts when the first-update gets applied (and the last week's engine changes get installed) and then the machine is rebooted. The icon remains red directly after the actual running of the EXE installer. But once the reboot after first-update is done, the new engine changes (from this past week) now triggers the red->gray icon symptom.

    I am awaiting contact from you STAR DEVELOPER ENGINEER 3rd-tier support. Hopefully we can get to the bottom of this so that I can return to using Bitdefender (instead of Malwarebytes Premium) on these two Win7 machines with the Ceton TV tuner card in both of them.

    I've been using Bitdefender on these two machines for 3 years. It's only in the past week that this problem has appeared. How hard could it be to look at what engine changes got pushed out in the past week that are obviously causing this new symptom???

  • DSperber
    DSperber ✭✭✭

    And one more "giant clue":

    I first encountered the red->gray icon issue last week, when I happened to have noticed the popup message after the background Bitdefender "updates" had completed on my first Win7 HTPC machine with the Ceton TV Tuner card inside. At that moment, before rebooting, the icon was still red. And after rebooting, and the boot-time initialization activity that Bitdefender goes through, after about 30-45 seconds the red icon now changed to gray. I saw it, I noticed it, I was puzzled by it, and Bitdefender tray icon was now no longer "communicating with services" operating properly. Right-click on the gray icon did NOT produce a popup menu to allow launching the product dashboard.

    So although the updates themselves had just been installed, it was not until the reboot which clearly then "activated" the just-installed program updates that whatever new and harmful functionality code was now present could take effect.

    => Obvious proof that it was last week's product updates rollout which caused this brand new problem. For 3 years this machine has run just fine... WITH THE CETON CARD INSIDE!! Same machine, same hardware, same Win7 HTPC, same Device Manager with Ceton card first in "network adapters". No change at all with anything, and the Bitdefender product had been running just fine for 3 years with a red icon. Until last week, and last week's "updates require reboot", and I rebooted. And now I have a gray icon and problems with Bitdefender tray icon talking to Bitdefender services.

    At this same time I had not yet had a chance to reboot my second Win7 HTPC machines (which also has its own Ceton TV tuner card inside). This second machine is my "production DVR" so I had to be more selective about finding a good opportunity to do the reboot which had also been requested by the Bitdefender application of last week's product updates. Bitdefender tray icon is still red. But when I finally found the opportunity to reboot, and did so, well now sure enough after reboot and 30-45 seconds of initialization activity during which the Bitdefender tray icon was red, now the tray icon changes to gray.

    ==> ABSOLUTE PROOF that it is something in last week's "updates" that got pushed out and installed and then activated via reboot, which is 100% responsible for the new problem. No problem for 3 years, until last week after reboot following "updates"... on both of these machines.

    You need to assign the proper 3rd-level tech engineers who developed this newly rolled-out code that appeared last week, to re-examine what they've done, THEY BROKE THINGS, and they are the ones who need to chase it down and fix it.

    I will be glad to lend my "spare" machine to them via remote connection for their "development lab use", letting them have COMPLETE CONTROL for as long as they required, in order to diagnose and resolve this issue. You obviously don't have any Win7 machine yourself that has a Ceton card inside it, but I have two such machines... one of which is a total "spare" and available for you to use remotely. I have my own nightly image backups taken, so I don't care what you do on the machine. No need to worry about "system restore points" or any such concerns.

    Just assign the internal engineers to the problem, and you can have my "spare" machine in remote connection mode at your complete disposal for as long as you'd like, until you can fix the problem. My machine is totally yours. No need for them to speculate or theorize what the problem might be. Just assign the right people to the task, and I will make the machine 100% theirs remotely for as long as they need, 24/7 as if it were their own.

  • DSperber
    DSperber ✭✭✭

    Still waiting for next step in this problem resolution to occur.

    I am available for remote connection at any time. Also, as I offered, I can "let you have my PC" for 24/7 remote connection if your developers want to use it as a lab machine in order to perfect any code changes relevant to a machine that contains the problematic Ceton TV tuner card in it.

    Any ETA on when I might be contacted by 3rd-level support?

  • @DSperber the engineers do have all the necessary information to help them solve the problem and it's just a matter of time. I have recently discussed with them and a technical representative will get back to you on the open case to schedule a remote session asap.


  • DSperber
    DSperber ✭✭✭

    Well, this is now completely unacceptable.

    I just received ANOTHER ROBOT-GENERATED BOILERPLATE EMAIL on my current still-open ticket 1007470964. This email insults my intelligence by including the following text:

    "Thank you for your patience please accept my apologies for the frustration that we might have caused.

    I have looked into the case and it seems that the situation is caused by an issue that has already been acknowledged by our development team. We are currently working on a fix that will be done by means of an automatic update and won't require any additional action on your end.

    I will get back to you with an update regarding the fix as soon as we have one.

    Thank you once again and have a nice day ahead!

    Kind Regards, Andrei M. Senior Customer Support Engineer"

    The insult to me here is that this is an EXACT DUPLICATE of the reply I received more than 3 years ago back on March 25, 2019, to my original ticket (Integrated Support 2019032221420003) submitted on this identical topic and when I was at the time using Bitdefender 2019 (rather than Bitdefender 2020/2021 which is what I'm using now).

    Here is the exact text I received on March 25, 2019 (note the "familiarity"):

    "Hello Darryl,

    Thank you for your patience throughout this entire process and please accept my apologies for the frustration that we might have caused.

    I have looked into the case and it seems that the situation is caused by an issue which has already been acknowledged by our development team. We are currently working on a fix which will be done by means of automatic update and won't require any additional action on your end.

    We will get back to you with an update regarding the fix as soon as we have one.

    Thank you once again and have a nice day ahead!

    Best regards, Stefan Ionascu Technical Support Engineer"

    So, it has now been almost 3 1/2 years since I first reported the problem, and that you acknowledged it WAS a problem, and that your engineers WERE WORKING ON A FIX, and that the fix WOULD BE PUSHED OUT WHEN COMPLETED AS A NORMAL PRODUCT UPDATE.

    Well, here it is June 23 2022, almost 3 1/2 years after this started, and apparently your engineers are incapable of fixing it at all!!! Or, you are lying to me for the past 3 1/2 years and NOTHING IS ACTUALLY BEING DONE!

    Up until 3 weeks ago this problem was non-critical and non-fatal. Just an annoyance. But because of something very recently pushed out as a separate product update 3 weeks ago, something new is now going on on these HTPC machines with the Ceton cards in them that has TOTALLY BROKEN BITDEFENDER so that it no longer works at all!!!

    Are you seriously capable of debugging your own code, and fixing a bug, or not??

  • Gjoksi
    Gjoksi DEFENDER OF THE YEAR 2022 ✭✭✭✭✭
    edited June 2022


    @Alexandru_BD This should be forwarded to Tier 3 support.


  • Hi,

    I hereby confirm the ticket is with the Tier 3 Technical Support Teams with the highest priority available.

    The automated message is indeed a template and it has kept its form over the years, since we're trying to keep all of our customers updated when we have made progress on a fix, or when we want to let them know that we're still working on it. This usually applies to more complex issues or situations that require further development and more time to resolve.


  • DSperber
    DSperber ✭✭✭


    Thank you for confirming that the ticket is with Tier 3. That is comforting. I assure you I'm trying to remain patient.

    But I cannot help remarking again that this is just where I stood 3 1/2 YEARS AGO, when the very same issue was first reported during the era of Bitdefender 2019. At that time the issue was also described as "acknowledged, and in the hands of development who were coming up with a fix". That was MARCH 2019!!

    In fact it was so long ago that it was still reported through one of your earlier ticket tracking systems, as  Bitdefender Integrated Support 2019032221420003. The very last correspondence I ever received on this STILL UNSOLVED ORIGINAL TICKET was again, an automated robot-generated followup email dated May 6, 2019, stating the following:

    "Dear customer,

    Thank you for your patience in this situation.

    This is a follow-up email regarding the bug report that you have sent us. We would like to inform you that our development team is still working on fixing the situation and it’s taking a bit more than usual. As previously mentioned, the fix will be automatically released through Bitdefender product updates, with no other actions requested from your side.

    Please let us know if you would still like to receive updates about this case in the future.

    Have a nice day ahead!


    Georgiana CIURESCU

    Senior Technical Support Engineer"

    I never received any further communication on that original ticket, from 3 1/2 years ago. Nor was it ever resolved (obviously) and the same exact problem supposedly being worked on back in 2019 clearly remains the same problem to this day.

    I appreciate that there are very few machines out there still running Win7 as HTPC using Windows Media Center, and even fewer which still have Ceton TV tuner cards with the "artificial MAC address" that because it appears first as a network adapter in Device Manager happens to cause problems for Bitdefender which apparently expects all network adapters to have UNIQUE MAC addresses, and/or that all network adapters are expected to be able to actually talk to the internet (which the Ceton card DOES NOT).

    If you have such a clear understanding of the underlying issues, and knew that back in March 2019 when I first reported it and you first acknowledged it, why has it taken all this time for it to remain unresolved???

    Again, until whatever very recent change was made to Bitdefender 3 weeks ago, that finally caused the product to NO LONGER WORK ON THESE TWO MACHINES, Bitdefender was working just fine! I was OK with remaining passive and quiet and forever patient, assuming that some day you would get this fixed. As far as I was concerned the only issue is that my two machines (DFW and Z170) both shows as one "device" up in your Bitdefender Central enumeration of the devices on my license.

    But whatever you pushed out just as recently as 3 weeks ago, that BROKE the product for me!! Now it appears to be INCOMPATIBLE to have a Ceton TV Tuner card in a PC, which shows up as a network adapter first in Device Manager, and which ONLY NOW... in the past 3 weeks because of whatever very recent change you made just 3 weeks ago... now the product no longer works at all!!!

    Honestly, how hard could it be for engineers qualified to be called "Tier 3" (i.e. authors / developers) to look at what they pushed out 3 weeks ago that has now broken the product, and at least reconsider perhaps backing out just that particular change... at least until they can figure out why it impacted my two machines with that Ceton TV Tuner card with artificial MAC situation? Or, perhaps just put a QUICK FIX PATCH in to override that change for my two machines? Or, perhaps just put a QUICK FIX PATCH in to IGNORE ANY NETWORK ADAPTER WITH MAC ADDRESS 00:2C:22:FF:FF:FF, and simply go on to pick up the NEXT network adapter in Device Manager?

    That's what I would consider doing, if I were in charge of resolving this issue that's remained unresolved for 3 1/2 years now. Somebody's not addressing the issue.

  • DSperber
    DSperber ✭✭✭

    Well, very strange.

    Did you change something? Push out a new product/engine update this morning?

    I happened to have needed to reboot one of my two Win7 HTPC machines (both with Ceton card inside) today (DFW). Astonishingly, after the reboot the Bitdefender icon remained red!!! It did not go gray!

    I figured maybe you actually did push through some emergency change of some type to at least temporarily get me back in business. So just to be sure it wasn't an anomaly I rebooted again. And sure enough, the icon remained red. I rebooted numerous times, and the icon remained red.

    Now believing you must have done something I then rebooted my second Win7 HTPC machine (Z170), fully expecting the Bitdefender icon on that machine to also remain red. But NO... it changed to gray!!! Huh??

    Just to be sure I rebooted again, and several more times as well. And sure enough the icon exhibited the behavior it has over the past 3 weeks, namely starting off as red at reboot and about 45 seconds later going to gray (indicating a problem preventing communicating with Services).

    So now I'm in a very strange new situation. I am assuming the '"change" from how things have been for the past 3 weeks (with BOTH machines showing gray icon) must almost certainly be something you changed just this morning and which got reflected on my DFW machine upon reboot. So what is it that now makes my two machines behave differently? Why is DFW now showing red and yet Z170 still shows gray???

    I have no real idea, but my guess is that it may have to do with the fact that according to Bitdefender Central I only have ONE DEVICE "protected", which is Z170 (with the still-gray icon). And the MAC address for device details is the Ceton MAC address. But my second machine (DFW) which also has Bitdefender installed but which since 9AM this morning has remained red, is not shown uniquely on Bitdefender Central as a second separate protected device. Even though Bitdefender is installed on BOTH machines, because of the issue involving the apparent common non-unique MAC address (for the Ceton card in both machines) there is only ONE "device" on my license, and that is the MOST RECENTLY INSTALLED system... which was Z170. This has been the story for 3 1/2 years, but since 9AM this morning it now is behaving differently than it has for the past 3 weeks.

    There must be a reason.

    So, to summarize:

    (a) Bitdefender Central still shows only ONE device, as it always has for the past 3 1/2 years, namely my most recently installed of the two Win7 HTPC machines, which is Z170. But I have Bitdefender installed on both machines.

    (b) Until 3 weeks ago, this non-unique situation was not a problem. Bitdefender was "red" and operating normally on both machines, even though there was only the one Z170 device (with the common Ceton MAC address) showing on my account.

    (c) Then 3 weeks ago something changed, and both machines went gray. And they've both been gray until 9AM this morning.

    (d) Since the reboot at 9AM this morning my DFW machine (which IS NOT the one shown on Bitdefender Central) has now gone back to "red"! No longer gray as it was for the past 3 weeks. This machine has a Ceton card in it with the non-unique common MAC address, just as it has for the past 3 1/2 years.

    (e) Despite multiple reboots since 9AM this morning my other Z170 machine (which IS the one shown on Bitdefender Central) remains gray! Again, this machine has a Ceton card in it with the non-unique common MAC address, as it too has had for the past 3 1/2 years.

    (f) Something changed this morning in Bitdefender somewhere, either locally in the installed software on my two machines, or up in your cloud Bitdefender Central. Whatever was changed, now one of my machines is red and the other machine is gray. The one which is red (DFW) is NOT the device named on Bitdefender Central (Z170) which remains gray, although the MAC address of the Ceton card in both machines is identical and almost certainly still at the heart of the entire problem story.

    What did you do this morning, that changed things in some way?? Any attempt at pushing out a solution?

    Whatever you did, it "fixed" one of the machines (DFW) so that the icon is red again, which is NOT the machine named on Bitdefender Central. The other machine (Z170), which IS the machine named on Bitdefender Central, that is the machine which remains gray and where Bitdefender is still not working (as it has not for the past 3 weeks).

  • DSperber
    DSperber ✭✭✭
    edited June 2022

    Icon remains gray on Z170. Action Center shows problem with "missing anti-virus protection", as I don't have Windows Defender installed instead, which DOES of course work on this machine as an alternative. Also, I've temporarily deactivated Malwarebytes Premium which I've installed temporarily and am also using in lieu of the non-functioning Bitdefender on Z170.

    In contrast, for some magic reason, on my DFW machine Bitdefender has for some reason come back to life with no problem communicating with Services as had previously been the case for the past 3 weeks. I can assure you that NOTHING THAT I HAVE CONTROL OVER HAS CHANGED on this machine to cause this sudden change early on Thursday morning when after a reboot it started staying red. It can only be due to something you've changed in software or cloud, somewhere, early Thursday morning, that is responsible.

    So now I've uninstalled Malwarebytes Premium on DFW, as it appears Bitdefender "is back in business" and operating normally again, if only on this one machine. Z170 remains gray.

    Note that up on Bitdefender Central only the Z170 (still gray) machine shows in "My Devices". Since it was the most recent "duplicate MAC" machine installed, second after first installing Bitdefender on DFW (now red). After the first install on DFW it was only DFW that appeared in My Devices. but after then installing to Z170 second the one DFW entry was replaced by one Z170 entry... since the MAC address of the second Z170 machine was a duplicate of the MAC address of the first DFW machine and that's how you organize My Devices, i.e. by MAC address. Hence only one of these two machines will appear at any one time, like right now with only Z170 (still gray) showing and DFW (now red) not showing.

    Sorry for restating again what I know I've stated previously. But this problem has existed still unfixed for 3 1/2 years now. And 3 weeks ago something changed (in your software, clearly) that caused both icons to go gray and Bitdefender to stop working on both of my machines. And then just yesterday Thursday morning something (in your sofware, clearly) changed yet again, and now Z170 remains gray but DFW has returned to red and working properly!

    I'm just trying to present "giant clues" that might be helpful to your 3rd tier developers, in the event they would like to actually see the results on my two machines of whatever they are working on back in Romania. I've offered to let them have Z170 as a "lab rat" via Team Viewer, if they want to "develop in real time" with my machine that actually has the Ceton card inside. But so far no response from you to take me up on my offer.

  • Hello @DSperber and thank you for the detailed information.

    An update was recently released - and this could explain the different behavior encountered on the machines (if the update indeed fixes the issue), but since it is being rolled out, it's quite possible that it didn't reach the second machine where the icon is still grayed out.

    My recommendation would be to keep in touch with the Support engineers, as they are the ones that can remotely connect to your devices upon request and further advise on the next steps. Having all the information in one place is also helpful, as they can keep better track of the inquiry.

    Best regards and thank you once again for taking the time to provide us with so much insight here.

  • DSperber
    DSperber ✭✭✭


    You are correct. The DFW (now red again) machine does have an ABOUT which shows that was applied on 6/23 at 6:33AM. This would explain why the change reflected when I just happened to reboot at around 9AM.

    In contrast, the Z170 (still gray) machine has an ABOUT which shows it is still which was applied on 6/15. I have rebooted this machine several times since yesterday, but it still remains at So maybe it's just a matter of time before it appears on its own. Based on your tip I suppose it would seem likely that at that time the Z170 machine will also see the return to a red icon, with Bitdefender now once again working properly.

    Externally this still does not seem to address the non-unique MAC address caused by selecting the Ceton card in network adapters for Bitdefender Central registration of My Devices. But then it is still the "gray" back-level Z170 which was the most recently installed machine. So maybe that's why Bitdefender Central still looks the way it does.

    Just to see if anything has changed regarding this issue with the appearance of, I will uninstall Bitdefender on DFW and then reinstall it. This will make it the second/latest most recent install, and presumably would then make DFW appear in Bitdefender Central. I will then also uninstall/reinstall Bitdefender on Z170, hopefully now picking up in the process. And I will see if I end up with two unique machines in My Devices, or if I still end up with only one there... i.e. the most recently installed machine with that non-unique MAC address.

    We shall see.

  • DSperber
    DSperber ✭✭✭

    Indeed. After the uninstall/reinstall (from scratch, deleting everything during uninstall) on Z170 the newly installed Bitdefender show dated 6/22. Apparently this earlier date was when it first became available. It must have been applied separately to DFW on 6/24 in the normal course of rollout.

    In any case, as predicted, the icon has also returned to red on Z170, indicating that whatever was very recently changed has in fact solved this particular problem of a problem connecting to services. Things do now appear to be back to normal (and "red") on both DFW as well as Z170.

    Now looking again at Bitdefender Central, the just reinstalled Z170 device is there, and the Ceton card's 00:22:2C:FF:FF:FF non-unique MAC address is still there. Nothing has been changed regarding ignoring this network adapter and picking up the "real" Intel network adapter instead... which would have been a unique MAC address.

    So there's no reason for me to uninstall/reinstall Bitdefender on DFW, as it would only just result in DFW being the one device up there, replacing Z170. I'd still have only one device in My Devices even though I have the product on two machines, so I'm not going to waste time doing that.

    Bottom line: both machines have returned to "red". Malwarebytes Premium has been uninstalled from both machines. Bitdefender is once again working properly on both of these machines. The non-unique MAC address of the Ceton card shown in My Devices is still NOT addressed.

    Thank you.

  • Just want to tell you i have the exact same problem. Bitdefender services are not responding... I reinstalled Bitdefender today but still the same issue.