Kindly be advised we cannot cancel subscriptions or issue refunds on the forum.
You may cancel your Bitdefender subscription from Bitdefender Central or by contacting Customer Support at: https://www.bitdefender.com/consumer/support/help/

Thank you for your understanding.

Problem With Photoshop Elements 5.02

Options

I am a registered user of Bit Defender Internet Security 2009. About two weeks ago I began having an issue opening the editor to Adobe Photoshop Elements 5.02. I simply would get an error message stating 'Attempt to Access Invalid Address' and the program would not open...strangely, the organizer portion of Elements worked just fine. After some extensive research, I discovered others were also having some problems with this issue and removing the Google Chrome browser fixed the problem: see Adobe forum discussion. Unfortunately, this solution did not work for me. This morning, I decided to turn off the Bit Defender firewall and turn on Windows Firewall. Once I did this, the Adobe program loaded just fine. Is this conflict with Adobe a known issue caused by a recent update? Are there plans to fix the problem on BD's end so I can continue using the firewall?

Comments

  • Alex Stanciu
    Options

    Hello jack,


    Open BitDefender, go to the Advanced View button in the upper menu and click on Firewall . Click on the current "Network Type", pull down the drop-down menu and select "Trusted Local", Stealth to "No" and Generic to "Yes" . Also, go to the Rules menu , click on the Advanced button and look for an entry for the Adobe Photoshop Elements 5.02 application .Check in order to see if it is set to Deny. If that is the case please double click on the entry and set it to Allow. Now test in order to see if you have the same issues .


    If this is not working please go to the next location:C:\Program Files\BitDefender\BitDefender 2009\Firewall and look after a file called "rules.xml". Please post your reply with this file attached.


    Thank you .

  • Hello jack,


    Open BitDefender, go to the Advanced View button in the upper menu and click on Firewall . Click on the current "Network Type", pull down the drop-down menu and select "Trusted Local", Stealth to "No" and Generic to "Yes" . Also, go to the Rules menu , click on the Advanced button and look for an entry for the Adobe Photoshop Elements 5.02 application .Check in order to see if it is set to Deny. If that is the case please double click on the entry and set it to Allow. Now test in order to see if you have the same issues .


    If this is not working please go to the next location:C:\Program Files\BitDefender\BitDefender 2009\Firewall and look after a file called "rules.xml". Please post your reply with this file attached.


    Thank you .


    Alex,


    Thank you for your assistance. I have everything as you stated in the first part. I enabled the BD firewall (turned-off Windows firewall) and the application failed again. If I turn off BD, then restart windows firewall all works just fine...


    I don't understand what you would like me to do with the rules.xml file.... Here is the section on Adobe in that file:


    <path><![CDATA[c:\program files\adobe\photoshop elements 5.0\photoshopelementsorganizer.exe]]></path>


    <cmdLine><![CDATA[]]></cmdLine>


    <local_network address="0000:0000:0000:0000:0000:0000:0000:0000" mask="0" />


    <remote_networks>


    </remote_networks>


    <local_ports>


    </local_ports>


    <remote_ports>


    </remote_ports>


    </rule>


    <rule index="126" action="0" l3Protocol="3" l4Protocol="6" direction="3" directPath="0" adapterTrust="63" trafficType="3" checkCmdLine="0" md5="B202D32C55AB828E3364109875F210F0" parentsHash="0000000000000000">


    Jack

  • Just wondering if anyone had a chance to look into this issue or if there was a planned fix... I would like to renew my subscription to BitDefender, but it would be hard to justify if I can't use one of the major elements...


    Thanks...

  • Alex Stanciu
    Options

    Hello Jack,


    You should open BitDefender, go to Advanced View, click on the Firewall button and then click on the Advanced Settings button. Here please uncheck the option called "Block Port Scans" then click on Ok. After that, please go to the next location from your system C:\Program Files\BitDefender\BitDefender 2009\Firewall and look after a file called "rules.xml". Please upload it here then send me a personal message with the download link .


    Thank you .

  • Hello Jack,


    You should open BitDefender, go to Advanced View, click on the Firewall button and then click on the Advanced Settings button. Here please uncheck the option called "Block Port Scans" then click on Ok. After that, please go to the next location from your system C:\Program Files\BitDefender\BitDefender 2009\Firewall and look after a file called "rules.xml". Please upload it here then send me a personal message with the download link .


    Thank you .


    Hello Alex,


    Thanks for taking the time to look into this...I have sent you a message with the link and I have blocked port scans...


    Jack

  • Ken Meardon
    edited September 2009
    Options
    Hello Alex,


    Thanks for taking the time to look into this...I have sent you a message with the link and I have blocked port scans...


    Jack


    I am using Windows XP with BitDefender 2010 Internet Security installed, Google Chrome, Adobe PhotoShop Elements 5.0 (I don't think it is 5.0.2). I tried opening PSE 5 this morning and go the same error message described. I looked at other posts and thought removing Google Chrome would work. It did not. But what did work for me was to go into BitDefender to the Active Antivirus Control through the Advanced Setting tab in Antivirus. I disabled Active Antivirus Control and PSE would open OK. Then I realized that I could put PSE 5.0 and other PSE exe files under Exclusions and keep Active Antivirus Control enabled. This allowed me to open PSE 5.0. I then reinstalled Google Chrome and am still able to open PSE 5.0. So, for my setup, the only change that I had to make is to add PSE 5.0 to the Exclusions under Active Antivirus Control Settings. I still have Bitdefender firewall activated as well as everything else in BitDefender. Sorry for the length of this post (my first), but I wanted to try to be comprehensive. Hope this helps others.

  • I am using Windows XP with BitDefender 10 Internet Security installed, Google Chrome, Adobe PhotoShop Elements 5.0 (I don't think it is 5.0.2). I tried opening PSE 5 this morning and go the same error message described. I looked at other posts and thought removing Google Chrome would work. It did not. But what did work for me was to go into BitDefender to the Active Antivirus Control through the Advanced Setting tab in Antivirus. I disabled Active Antivirus Control and PSE would open OK. Then I realized that I could put PSE 5.0 and other PSE exe files under Exclusions and keep Active Antivirus Control enabled. This allowed me to open PSE 5.0. I then reinstalled Google Chrome and am still able to open PSE 5.0. So, for my setup, the only change that I had to make is to add PSE 5.0 to the Exclusions under Active Antivirus Control Settings. I still have Bitdefender firewall activated as well as everything else in BitDefender. Sorry for the length of this post (my first), but I wanted to try to be comprehensive. Hope this helps others.


    Thanks for the post and information... What finally worked for me (thanks Alex) is unchecking the "Enable Intrusion Detection System (IDS)" box under Advanced Settings in the Firewall module. Although the solution works, I am still a bit apprehensive to re-new my subscription to BD for 2010 because I don't like paying for a full solution and not being able to have all of the elements work for me...

  • Ken Meardon
    edited September 2009
    Options
    Thanks for the post and information... What finally worked for me (thanks Alex) is unchecking the "Enable Intrusion Detection System (IDS)" box under Advanced Settings in the Firewall module. Although the solution works, I am still a bit apprehensive to re-new my subscription to BD for 2010 because I don't like paying for a full solution and not being able to have all of the elements work for me...


    Hello Jack:


    Not sure if it came across in my first repy/post on this issue, but I just wanted to make clear that "my solution" to this issue resulted in using BitDefender 2010 Internet Security with all of the "elements" enabled/working, with just exceptions for PSE in the Active Virus Scan Settings. I am curious as to whether what worked for me would work for you so that you did not have to disable the "Enable Intrusion Detection System (IDS)" box. If so, then I think you would have all of the elements working for you.


    With regard to purchasing BitDefender 2010, you could try downloading Bitdefender 2010 in the 30-day trial mode for your set up and see how that works. I started with the 30-day trial and was happy enough with the product to buy it (have it now on two computers). Also, while probably not the best way to deal with a situation, I know that based on their website BitDefender does offer a 30-day money back guarantee if one is not happy with the purchase. Having said that, I know there are other security systems one can use and I am not really trying to "push or sell" BitDefender, but I am overall very happy with using it.

  • Hello Jack:


    Not sure if it came across in my first repy/post on this issue, but I just wanted to make clear that "my solution" to this issue resulted in using BitDefender 10 Internet Security with all of the "elements" enabled/working, with just exceptions for PSE in the Active Virus Scan Settings. I am curious as to whether what worked for me would work for you so that you did not have to disable the "Enable Intrusion Detection System (IDS)" box. If so, then I think you would have all of the elements working for you.


    With regard to purchasing BitDefender 10, you could try downloading Bitdefender 10 in the 30-day trial mode for your set up and see how that works. I started with the 30-day trial and was happy enough with the product to buy it (have it now on two computers). Also, while probably not the best way to deal with a situation, I know that based on their website BitDefender does offer a 30-day money back guarantee if one is not happy with the purchase. Having said that, I know there are other security systems one can use and I am not really trying to "push or sell" BitDefender, but I am overall very happy with using it.


    Thanks...your message did come through, but I am not sure how to do an exception in BD2009...I'll have to investigate this a bit more... As for BD...I have been using the product for three years, upgrading each year, and I have been pretty satisfied. The firewall in 2009, though, creates occasional problems with access and performance (using XP SP2) and that is frustrating. The anti-virus and anti-spam products work very well...

  • I am using Windows XP with BitDefender 2010 Internet Security installed, Google Chrome, Adobe PhotoShop Elements 5.0 (I don't think it is 5.0.2). I tried opening PSE 5 this morning and go the same error message described. I looked at other posts and thought removing Google Chrome would work. It did not. But what did work for me was to go into BitDefender to the Active Antivirus Control through the Advanced Setting tab in Antivirus. I disabled Active Antivirus Control and PSE would open OK. Then I realized that I could put PSE 5.0 and other PSE exe files under Exclusions and keep Active Antivirus Control enabled. This allowed me to open PSE 5.0. I then reinstalled Google Chrome and am still able to open PSE 5.0. So, for my setup, the only change that I had to make is to add PSE 5.0 to the Exclusions under Active Antivirus Control Settings. I still have Bitdefender firewall activated as well as everything else in BitDefender. Sorry for the length of this post (my first), but I wanted to try to be comprehensive. Hope this helps others.


    I started having the issue in the past week on Win7 Pro x64. PSE worked after install, and I haven't installed Google Chrome, so I was very surprised to see PSE not work today. Compatibility mode and "run as administrator" did not fix the problem. Fortunately, rtpken's advice to specify the PSE editor as an exception to the advanced virus scanner worked like a charm. Thanks!

  • I am using Windows XP with BitDefender 2010 Internet Security installed, Google Chrome, Adobe PhotoShop Elements 5.0 (I don't think it is 5.0.2). I tried opening PSE 5 this morning and go the same error message described. I looked at other posts and thought removing Google Chrome would work. It did not. But what did work for me was to go into BitDefender to the Active Antivirus Control through the Advanced Setting tab in Antivirus. I disabled Active Antivirus Control and PSE would open OK. Then I realized that I could put PSE 5.0 and other PSE exe files under Exclusions and keep Active Antivirus Control enabled. This allowed me to open PSE 5.0. I then reinstalled Google Chrome and am still able to open PSE 5.0. So, for my setup, the only change that I had to make is to add PSE 5.0 to the Exclusions under Active Antivirus Control Settings. I still have Bitdefender firewall activated as well as everything else in BitDefender. Sorry for the length of this post (my first), but I wanted to try to be comprehensive. Hope this helps others.


    rtpken,


    Thank you for your post. I use Windows XP and had this exact problem with Adobe PhotoShop Elements 4.0. So I disabled Active Antivirus Control and PSE worked again. I tried the Exclusions only, but for some reason that did not work on it's own. But again, your first suggestion worked for me. Thanks. Peter

  • rrpawluk
    Options

    I added the Photoshop Elements 5 program folder to exclusions under Antivirus > Exclusions tab for Bitdfender Antivirus 2010 but that did not solve the 'access invalid address' error message and the blocking of PE editor opening up. However, in BD 2010 you don't need to disable Active Virus Control (other less desirable option mentioned) just go to Shield > Advanced Settings and do an exclusion there as well. I did the .exe files for both Photoshop Elements and for the PEeditor .exe files... and whalla... Elements opens fine. I don't know if this helps but noone mentioned you can do it in both places... so wanted to make that clear...


    I would go back and delete the exclusions under the Exclusions tab since that didn't seem to solve the problem, but the delete option on a right-click of the listed exclusion does nothing... so I left it. I scanned the folder before excluding it.