Kindly be advised we cannot cancel subscriptions or issue refunds on the forum.
You may cancel your Bitdefender subscription from Bitdefender Central or by contacting Customer Support at: https://www.bitdefender.com/consumer/support/help/

Thank you for your understanding.

Ftpes Connections Timing Out

liltechdude
edited June 2011 in Firewall

Hello.


Lately I've been having problems holding FTPES (FTP over Explicit TLS) connections. When I have the firewall enabled, The commands/responses take absolutely forever and LIST commands, etc. time the connection out.


When I change over to Plain FTP mode, the connections are fine and run at the speed they should.


When I disable the firewall, the FTPES connections are fine and run at the speed they should.


I double checked my firewall settings and FileZilla is allowed Any IP/Port/Protocol, etc.


I'm connecting to my FTP server on port 29393 (If this might have anything to do with the problem)


I'd appreciate it if someone could hint me as to what the problem might be.


Thank You.


Here's the FTP log


Status:	Connecting to *censored*:29393...
Status: Connection established, waiting for welcome message...
Response: 220 *censored*.
Command: AUTH TLS
Response: 234 Proceed with negotiation.
Status: Initializing TLS...
Status: Verifying certificate...
Command: USER *censored*
Status: TLS/SSL connection established.
Response: 331 Please specify the password.
Command: PASS ********
Response: 230 Login successful.
Command: OPTS UTF8 ON
Response: 200 Always in UTF8 mode.
Command: PBSZ 0
Response: 200 PBSZ set to 0.
Command: PROT P
Response: 200 PROT now Private.
Status: Connected
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/"
Status: Directory listing successful
Status: Retrieving directory listing...
Command: CWD /data
Response: 250 Directory successfully changed.
Command: TYPE I
Response: 200 Switching to Binary mode.
Command: PASV
Response: 227 Entering Passive Mode (*****,191,59)
Command: LIST
Response: 150 Here comes the directory listing.
Error: Connection timed out
Error: Failed to retrieve directory listing

Comments

  • Unknown
    edited June 2011

    Hello,


    Please go to the Firewall module having BitDefender in Expert View and tell me the settings you are currently using under the Network sub-menu.


    Also I would recommend you to add the port 29393 as an exception into BitDefender Firewall by following the steps below:


    - open BitDefender Security Center


    - switch to "Expert View" from the "Options" button


    - go to "Firewall" tab


    - go to "Programs" tab


    - click on the "Add Rule" button


    - in the new window select under "Basic" tab the following:


    a) Apply rule to all programs


    B) Program Parameters: Any


    c) Protocol: Any


    d) Events: Listen, Traffic, Connect


    e) Network Type: Trusted (Allow All), Home/Office, Public


    f) Permission: Allow


    - go to the "Advanced" tab and set:


    a) Direction: Both


    B) IP Version: Any


    c) Local address: IP -> Any


    Port(s) -> 29393


    d) Remote Address: IP -> Any


    e) Port(s) -> 29393


    Note that you need to un-check the box next to each Port field to be able to add the port you wish to allow.


    Please let me know if the issue still persist.


    Looking forward to your answer!

  • Hello,


    Please go to the Firewall module having BitDefender in Expert View and tell me the settings you are currently using under the Network sub-menu.


    Also I would recommend you to add the port 29393 as an exception into BitDefender Firewall by following the steps below:


    - open BitDefender Security Center


    - switch to "Expert View" from the "Options" button


    - go to "Firewall" tab


    - go to "Programs" tab


    - click on the "Add Rule" button


    - in the new window select under "Basic" tab the following:


    a) Apply rule to all programs


    B) Program Parameters: Any


    c) Protocol: Any


    d) Events: Listen, Traffic, Connect


    e) Network Type: Trusted (Allow All), Home/Office, Public


    f) Permission: Allow


    - go to the "Advanced" tab and set:


    a) Direction: Both


    B) IP Version: Any


    c) Local address: IP -> Any


    Port(s) -> 29393


    d) Remote Address: IP -> Any


    e) Port(s) -> 29393


    Note that you need to un-check the box next to each Port field to be able to add the port you wish to allow.


    Please let me know if the issue still persist.


    Looking forward to your answer!


    Yes I am still having the problem.


    The connection is going through but it's extremely slow and times out.

  • Hello,


    Please follow the article below and let me know if the issue persist:


    http://kb.bitdefender.com/site/KnowledgeBase/article/794/


    Kind regards,