Browser Slow Down

I've had Bitdefender 2014 for a year and was very pleased with it .


I recently bought Total Internet Security 2015 and have found that it doesn't seem to like any of my browsers . It acts very slow and particularly on Firefox where it hangs to the point where I have to use Task Manager to shut the browser down .


I'm tempted to uninstall and install 2014 . Is this just me

Comments

  • garioch7
    garioch7 Defender of the month ✭✭✭✭

    gilles27:


    Welcome to the 2015 Bitdefender Forum. I have BD 2015 TS installed on both of my computers. Neither runs Firefox, but I do have both IE11 and Chrome installed on both of them, running Windows 7 x64.


    I also had 2014 BD TS installed on both. I have noticed no difference in browser performance. I have no indication that BD TS is slowing browsing. Of course, being in a rural part of country, my Internet speeds


    are not that good anyways.


    Hope this is of some help. Have a great day.


    Regards,


    -Phil

    Former Bleeping Computer Malware Response Instructor

  • Hiya guys,


    I am using Firefox as my default browser on all my machines and have no problems with slowdowns, although like Phil I have to take a terrible internet speed. :)


    It would be a good idea to run a repair on bitdefender first just in case something was corrupted during the download (Control Panel>Programs and Features>Bitdefender 2015> Uninstall but choose Repair. Allow it to complete and reboot your computer.


    Ro.

  • Hi Gilles. I would double check first if the browser is slow or the internet. If it's a browser, you might want to disable the browser add ons one by one until you will notice a difference. Then you could I guess decide what next steps to take. 1.gif

  • Hi Gilles. I would double check first if the browser is slow or the internet.


    Considering he has already said in his first post that he was not having the problems previously and that it effects multiple browsers there is something in BD causing the problem.

  • I've had Bitdefender 2014 for a year and was very pleased with it .


    I recently bought Total Internet Security 2015 and have found that it doesn't seem to like any of my browsers . It acts very slow and particularly on Firefox where it hangs to the point where I have to use Task Manager to shut the browser down .


    I'm tempted to uninstall and install 2014 . Is this just me


    I also experience the same problem. This temporary fix works for me:


    1. go into safemode, open Bitdefender folder, change the name of the file 'bdtl.dll' to 'bdtl.dl_'


    2. edit the file 'update_components.xml' by changing <Product enabled="1" to <Product enabled="0"


    3. restart and see if this works


    I'm quite disappointed in Bitdefender. This bug has been around for ages, but they haven't released an official fix yet. Please do not let us wait any longer. We need an official fix!

  • Nesivos
    edited November 2014
    I've had Bitdefender 2014 for a year and was very pleased with it .


    I recently bought Total Internet Security 2015 and have found that it doesn't seem to like any of my browsers . It acts very slow and particularly on Firefox where it hangs to the point where I have to use Task Manager to shut the browser down .


    I'm tempted to uninstall and install 2014 . Is this just me


    I run multi-layered security which means I use Bitdefender plus Malwarebytes plus etc. Eight real-time security apps in total not counting Firefox addons like NoScript etc. I have found in the past that certain spyware software used in conjunction with Bitdefender slows down browsing. I have also found that Traffic Light in the past also slowed down browsing. Many secondary security programs like Malwarebytes have Malicious Website Protection. These can conflict with BD and slow down browsing. Add Blockers like Adblock Plus will also slow down browsing especiallly if a user has added additional lists to their default list.


    Webpages with heavy graphics will also slow down browsing.


    Bottom line is everyone has to determine for themselves what they consider acceptible webpage rendering speeds. Remember though that webpage rendering speeds vary inversely to web security. If you want more speed you will get less security. If you want more security you will get less speed.

  • I also experience the same problem. This temporary fix works for me:


    1. go into safemode, open Bitdefender folder, change the name of the file 'bdtl.dll' to 'bdtl.dl_'


    2. edit the file 'update_components.xml' by changing <Product enabled="1" to <Product enabled="0"


    3. restart and see if this works


    I'm quite disappointed in Bitdefender. This bug has been around for ages, but they haven't released an official fix yet. Please do not let us wait any longer. We need an official fix!


    thanks for that fix.it really works.do you know if that lessons security?