[fixed in 19.2.0.151] Firewall Is Blocking Windows 10 Mail App

edited July 2015 in Firewall

Firewall is blocking Windows 10 Mail app and not allowing the app to sync. When the firewall is off the app works fine, and I'm not sure where the directory is to manually allow it.

«1

Comments

  • Change firewall adapter settings from Home/Office to Trusted! Mail app will start syncing.

  • Thank you so much for this, I was having the same trouble and that worked a treat :)

  • Yup that worked, thanks.

  • Also worked for me, I am however wondering if it is safe to keep the setting on "Trusted" on a home network connection.

  • I am however wondering if it is safe to keep the setting on "Trusted" on a home network connection.


    Hi,


    Hopefully you can trust your home network, at least until Bitdefender has time to sort things out. :)


    Ro.

  • GeorgiaGeorgia ✭✭
    edited August 2015

    Hello,


    Thank you for reporting this issue.


    Before going any further with the investigation could you please confirm if the mail app from Windows 10 works with these settings?


    1. Open the Bitdefender program > Protection > click on Firewall > make sure the Firewall is turned ON


    2. Go to the Adapters tab > at "Network Type" select "Home/Office" > at "Stealth Mode" select "Off" > at "Generic" select "On"


    Please post back with your results. Thank you.

  • OK Georgia, Firewall is definitely on otherwise the program screams FOUL! :P


    At present Firewall adapters are set to "Trusted" > at "Stealth Mode" "Remote" > "Generic" select "Off". The mail app is working.


    Changed Adapters as you suggest - "Home/Office" > at "Stealth Mode" select "Off" > at "Generic" select "On" Sent myself an email, Mail App not working.


    Returned to the first settings, all worked an emails came through.

  • Change firewall adapter settings from Home/Office to Trusted! Mail app will start syncing.


    I feel like an idiot but for the life of me I cant figure out how to do this. Where do I find the firewall adapter settings?

  • I feel like an idiot but for the life of me I cant figure out how to do this. Where do I find the firewall adapter settings?


    Hello mrshroomfish,


    Open your GUI by double clicking the BD icon in the system tray, click the "Protection" window, click the gear icon for "Firewall", click the "Adapters" tab. There you can change the settings from the drop-downs.


    Ro.

  • Hello mrshroomfish,


    Open your GUI by double clicking the BD icon in the system tray, click the "Protection" window, click the gear icon for "Firewall", click the "Adapters" tab. There you can change the settings from the drop-downs.


    Ro.


    Thank you that did it! I appreciate it!

  • Thank you that did it! I appreciate it!


    Good, now you have your Mail App. Not one I actually use, I prefer Web mail from my browser. :)


    Ro.

  • I have the same problem. Be careful when setting up the Home Connection to "Trusted", I think this allow all your PC traffic to go through to the internet... basically you are disabling the "two-way firewall" and making it into a "one-way firewall". I had a program installed that I did not want it to communicate with the internet. Flipping this trusted switch this program immediately began transmitting all my data...


    I think this is a bug & should be reported as such. Anybody managed to trace the EXE of this app & what it's running container is? I came up with c:\program files\windowsapps\microsoft.windowscommunicationsapps_17.6020.42011.0_x64__8wekyb3d8bbwe\hxmail.exe however I think the data communications is being hid behind some other kind of container/service :(


    I'm thinking about changing firewalls/products for this. I can't put the firewall comms as Trusted & I can't use my email program if it is set to anything else :(

  • I think this is a bug & should be reported as such.


    Hiya, this has been reported and Bitdefender are aware (see post #7 from Georgia) we can only wait for the solution.

  • @dejjem Do NOT set Network Type to Trusted, but to "Home/Office", then leave Stealth Mode "Off" and Generic "On".


    Also, if anyone from this thread can still replicate the issue with Windows 10 Mail app please run this diagnostic tool while the issue occurs (Check the box 'Try to reproduce the issue before submitting' to enable additional logs):


    www.bitdefender.com/diagnostic


    Upload the BDSP_* archive resulted on your Desktop to a file transfer site (e.g. www.sendspace.com) and then post back the download link.


    Or send us an email at [email protected]


    Thank you in advance for your help.

  • edited August 2015

    @dejjem Do NOT set Network Type to Trusted, but to "Home/Office", then leave Stealth Mode "Off" and Generic "On".


    Also, if anyone from this thread can still replicate the issue with Windows 10 Mail app please run this diagnostic tool while the issue occurs (Check the box 'Try to reproduce the issue before submitting' to enable additional logs):


    www.bitdefender.com/diagnostic


    Upload the BDSP_* archive resulted on your Desktop to a file transfer site (e.g. www.sendspace.com) and then post back the download link.


    Or send us an email at [email protected]


    Thank you in advance for your help.


    @Georgia, Home/Office, Stealth Off & Generic On does not work - as indicated previously in the thread. Mail app is still blocked. I just re-tried it to be sure. I have uploaded the diagnostic logs from a test machine, as indicated in the instructions above & sent an email to @bitsy. If I had to guess what the problem is, I think it's because I've linked my google account with the Microsoft Mail app thus it needs google TLS access which Bitdefender is getting confused over. Maybe other people with this problem can chime in? Guys, have any of you linked EXTERNAL, non-@outlook accounts to the Windows Mail app?


    Please let us know when this is solved (by posting here if possible as I have subscribed to this thread).

  • @Georgia,


    Sent email with support tool file attached. The mail app still does not work with your suggested settings. :(


    Ro.

  • Same issue.


    I've used the support tool, tried to download and send a message in Windows 10 with the mail app... with no luck. I can also confirm that the suggested setting do not work. I need to deactivate the firewall.


    I have sent the results to [email protected]

  • Same issue.


    I've used the support tool, tried to download and send a message in Windows 10 with the mail app... with no luck. I can also confirm that the suggested setting do not work. I need to deactivate the firewall.


    I have sent the results to [email protected]


    Hiya,


    Have you tried setting the Firewall adapter settings (better than turning the firewall off)as I suggested earlier in the thread - the Mail App works for me.


    At present Firewall adapters are set to "Trusted" > at "Stealth Mode" "Remote" > "Generic" select "Off". The mail app is working.


    Ro.

  • Hi Rohugh


    Thanks for the info, but as per post #15 by Bitdefender Technical Support, they state to NOT set the adapter to trusted. Potentially for reasons dejjem noted in post #13. I'm sure that there will be other reasons too.


    I'll just use Thunderbird until the issue is fixed.

  • Hello,


    Thank you so much for helping us with this.


    I have received the e-mails from dejjem, rdorian and Rohugh on bitsy mail list and have opened a case with the Bitdefender Testing team.


    I will post back when I have news from them. Thank you for your patience.

  • To add to this, further checking this morning I note that this is only effecting my Gmail, Outlook.com updated normally. I have settings as recommended by Georgia "Home/Office", Stealth Mode "Off" and Generic "On"


    Ro.


    post-175392-1438860992_thumb.jpg

  • Any news on when this issue is going to be fixed or an ETA on how long this could take to fix? Also, I wouldn't set your network adapter to trusted, as it basically disables the firewall, leaving your computer vulnerable.

  • edited August 2015

    Looking at this it seems bitdefender is blocking IMAP connections, outlook is working on SSL, however GMAIL connection is configured as IMAP, connection to GMAIL succeeds with Bitdefender off. you dont seem to be able to add a rule for the port, unless you know the exe, which i cannot locate.


    We just need in my opinion a built in rule like the ones present for DNS etc.

  • GeorgiaGeorgia ✭✭
    edited August 2015

    Hello all,


    This issue is already fixed on our developers side. It is due to be released by product update.


    I will post back as soon as I have an ETA.


    *later edit: we make efforts to push the fix by update this Friday, August 14th. Otherwise, it should be available in +/- 1 week.


    Thank you all so much for your help and patience.

  • Thank you all so much for your help and patience.


    ..... and thank you Georgia for keeping us up to date. :)


    Ro.

  • What should the ideal settings for Firewall be after the fix is pushed?

  • Hello all,


    This issue is already fixed on our developers side. It is due to be released by product update.


    I will post back as soon as I have an ETA.


    *later edit: we make efforts to push the fix by update this Friday, August 14th. Otherwise, it should be available in +/- 1 week.


    Thank you all so much for your help and patience.


    New Product Update ---> 19.2.0.151 didnt solve the issue


    I still cant get Metro mail app to sync with my gmail account unless I change network type to " Trusted"

  • edited August 2015

    Yeah, my Gmail Mail App isn't working yet either, guess we just have to sit it out for a while longer. :(


    Ro.

  • Hello,


    Please update your Bitdefender to the build 19.2.0.151, restart Windows then go to Events section and make sure the update event requesting to reboot the computer is no longer in the list. If it's still there, click on it then click the button Restart Now that appears at the bottom.


    After the computer restarts open Bitdefender and go to Firewall > Rules tab > click on Reset Rules.


    Now go to Adapters tab and change Network Type to Home/Office.


    Let me know if Windows 10 mail app can sync afterwards.

  • Hello,


    Please update your Bitdefender to the build 19.2.0.151, restart Windows then go to Events section and make sure the update event requesting to reboot the computer is no longer in the list. If it's still there, click on it then click the button Restart Now that appears at the bottom.


    After the computer restarts open Bitdefender and go to Firewall > Rules tab > click on Reset Rules.


    Now go to Adapters tab and change Network Type to Home/Office.


    Let me know if Windows 10 mail app can sync afterwards.


    I just tried to do this... and didn't found the current version of my bitdefender in the first run. After searching for a while i did find my version-number by right clicking on the small icon next to the clock and selected "Info about" (Text may vary as my version is in german and i just try to translate it "on the fly" with my crappy english i still remember) - but how do i manually force the client to update now? It's been quite a long time since Windows 10 got released .....

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.