Bd Firewall Keeps Turning On - Blocks Wifi Printers

edited September 2015 in Firewall

Hi Folks


A curious problem. After much searching and playing around after the installation of a new router, I succeeded in figuring out how to get round the problem of 2 of my WiFi computers not being able to print to any one of 3 WiFi printers - by turning off the BD firewall and enabling the Windows Firewall.


Problem sorted - or so I thought.


Last night couldn't print again. Usual trick of opening an elevated command prompt followed by net stop spooler/net start spooler and I could print again.


As this was a temproary solution until I discovered the "fix" mentioned above (namely turning the BD firewall off), I discovered that the BD firewall was back ON again (hence the reason why I couldn't print).


Anyone else having the BD firewall turn on on a computer restart - and if it does (or this is natural behaviour) is there any way to permanently turn off the BD firewall? This is very irritating to say the least.


Thanks in anticipation,


Zaph


PC is a desktop Core i5 running Win 7HP SP1 64-bit / Router ASUS-DSL68U

Comments

  • Hi Folks


    A curious problem. After much searching and playing around after the installation of a new router, I succeeded in figuring out how to get round the problem of 2 of my WiFi computers not being able to print to any one of 3 WiFi printers - by turning off the BD firewall and enabling the Windows Firewall.


    Problem sorted - or so I thought.


    Last night couldn't print again. Usual trick of opening an elevated command prompt followed by net stop spooler/net start spooler and I could print again.


    As this was a temproary solution until I discovered the "fix" mentioned above (namely turning the BD firewall off), I discovered that the BD firewall was back ON again (hence the reason why I couldn't print).


    Anyone else having the BD firewall turn on on a computer restart - and if it does (or this is natural behaviour) is there any way to permanently turn off the BD firewall? This is very irritating to say the least.


    Thanks in anticipation,


    Zaph


    PC is a desktop Core i5 running Win 7HP SP1 64-bit / Router ASUS-DSL68U

    Hi...Maybe switch to BD Antivirus Plus. It has no firewall.
  • Hi...Maybe switch to BD Antivirus Plus. It has no firewall.


    Hi Ozzie,


    Thanks for the suggestion but not really a fix.


    Anyone else have any other ideas?


    Zaph

  • I had a similar problem with my wife's wireless printer. The solution was to go to the Firewall Setttings, Adaptor, and make sure the network is set as "Home/Office" or "Trusted", "Stealth Mode=Off", and "Generic=On". Some folks report that "Trusted" works for them whereas "Home/Office" did not. I use "Home/Office" because I "suspect" that it might offer some protection whereas "Trusted" probably causes BD to totally ignore what is going on, on that network.


    Hope this helps. Have a great day.


    Regards,


    -Phil

  • edited September 2015

    I'll give that a try - thanks Phil.


    Settings are currently:


    WAN > Home/Office Stealth > 'Off' and Generic to 'Off'


    I don't hold out too much hope though. I'm also running BD IS 2015 on another Win 7HP SP1 64-bit machine and that keeps the firewall off and I can print.


    On the machine that can't print it is because BD IS 2015 keeps truning the firewall back on. If I use an elevated command promt and the commands net stop spooler followed by net start spooler, I can print just that one document (the next one I send to the printer won't print and I have to stop & start the spooler again whereupon it prints). However if I remember that BD has probably turned the firewall back on and I then turn it off, I can print every document I send to the printer with no problems until the next restart. Wierd eh?


    Will try your solution and report back.


    Going for WAN > Home/Office Stealth > 'Off' and Generic to 'On' and then turning the firewall off. I'll see what that does next restart!


    Cheers


    Zaph

  • Update 1


    Well the combination: WAN > Home/Office, Stealth > 'Off' and Generic to 'On' didn't work.


    The Firewall is back 'ON' again this morning.


    Going to try WAN > Trusted, Stealth > 'Off' and Generic to 'On' and see if that works on the next restart.


    Watch this space!


    Zaph

  • edited September 2015

    Update 2


    Well the combination: WAN > 'Trusted', Stealth > 'Off' and Generic to 'On' then turning the Firewall off doesn't work either!


    After a restart the BD IS 2015 Firewall is STILL set to 'ON'


    Going to try WAN > 'Trusted', Stealth > 'On' and Generic to 'On' and see what happens then after I turn the firewall off and restart the machine.


    Is there another setting somewhere in BD IS 2015 that is over-riding my turning the Firewall off?


    Come on BitDefender - someone step up to the plate and explain what is going on!


    Why does BD IS 2015 keep turning the da mned firewall back on after I turn it off and the machine restarts?


    Zaph

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.