Kindly be advised we cannot cancel subscriptions or issue refunds on the forum.
You may cancel your Bitdefender subscription from Bitdefender Central or by contacting Customer Support at: https://www.bitdefender.com/consumer/support/help/

Thank you for your understanding.

Firefox Reporting Bitdefender Certificate Sec_Error_Unknown_Issuer

Firefox is reporting that a site, whose certificate I have verified to be okay, is showing the above error and refuses to let me proceed to the site.

When looking at the certificate, I get the attached view. Somehow Firefox is not accepting the Bitdefender intermediate certificate as being from a legitimate issuer. Is this something I can fix at my end (I tried to put in an exception, but that doesn't seem to fix it) or at Bitdefender/Firefox's end?

post-200679-0-54493700-1459658480_thumb.png

Comments

  • Billy S
    edited June 2016

    Seems to be a common issue. Though I have not seen any replies from BitDefender, may have missed it though.

     


    Found this, it worked.

    QUOTE (Savoy @ November 4, 2015, 7:11 PM) /index.php?act=findpost&pid=245630" rel=""><{POST_SNAPBACK}>
    Rebonsoir, Well, after much wasted time on this problem, I think I found a solution! (It would be good in future Firefox -portable- working with BitDefender ...) If it serve other people, I indicate here the process I followed: 1) for Windows 7: Start / certmgr.msc / Authorities certification trusted root / Certificates right click the BitDefender certificate / All tasks / Export / Next / Next / (choose a location and name the file) 2) Under Firefox Portable:Options / Advanced / View certificates / Import / (change the previously exported file and tick three boxes) Everything works flawlessly, as before . I'm proud of myself ;-))) Jerome, Savoie.

  • ^ That worked for me too. One extra note, though: After clicking Certificates > View Certificates, you have to select the Authorities tab. You're adding the BD certificates as an authority.

  • I found this thread after searching for hours. This solution may work in Windows 7 - but does it work in Windows 10, too? I've followed your description to test it and when I try to export the bitdefender certificat I can choose about three formats ( DER-coded, Base 64-coded or PKCS #7) - which format is the right one?

    Has anybody tried this in Windows 10? What an idiocy to offer ssl scan - that does not really work!

  • ridevries
    edited June 2016

    I had the same problem in a non-portable Firefox, and solved it with exporting the Bitdefender certificate from Seamonkey and importing it with Firefox. No Problem with Chrome or Internet Explorer, but in Waterfox and Palemoon ssl-scanning doesn't work at all, Bitdefender certificates are there, but the original ones are used.

    Why no reaction from Bitdefender to this issue, isn't it important?

    I reported the problem with Firefox to Bitdefender Customer Care, but no response til now, except for the auto-response reply.

  • ridevries
    edited June 2016

    Part of the answer from Bitdefender Support, translated from Dutch:

    'The SSL scan is meant to scan certificates from certain websites. Some browsers have different certificate-readers, that's why they don't work. You can turn SSL scan off, it will not have an influence on the security of your PC'

    ?????

    First, I don't fully understand part of their answer, not even in Dutch, I thought SSL scan is meant to scan content (not certificates) of https websites, because they too can be a source of malware, and their content apparently cannot be scanned in an other way. Why SSL scan, if it doesn't provide extra security? The way it is done, is already controversial, because it also possibly compromises security and privacy.

    Some browsers cannot read the bitdefender certificate, Chrome, IE and Seamonkey can, Firefox is incapable, apparently, but that's not true, some users in this thread already manually added the Bitdefender certificate to Firefox and it works perfectly, access to https websites is restored.

    I also have a problem with the firewall, but I think I already know the solution... ;-)

    Original answer in Dutch:

    "Beste de Vries,

    Bedankt dat u ons heeft gecontacteerd over uw bezorgdheid.

    Eerst en vooral willen we onze verontschuldigingen aanbieden voor de situatie die is ontstaan en voor de vertraging van ons antwoord.

    De SSL scan is om de certificaten te scannen van bepaalde websites.

    Sommige browsers hebben verschillende lezers van de certificaten en daarom werken ze niet.

    U kan de SSL scan geruist uitzetten, het zal de veiligheid van uw PC niet beïnvloeden.

    De Vries, zijn er nog andere vragen, aarzel dan niet om ons te contacteren.

    Ik wens u een fijne dag!

    Met vriendelijke groet,

    Denis Muftarovski

    Bitdefender Support Team"

  • weary
    edited June 2016

    I said this solution worked for me, but that turned out not to be completely true. It works temporarily, but at some point, Firefox somehow forgets the Bitdefender certificate again. It may happen as soon as Firefox is closed; I don't know. I have switched to Chrome for other reasons, and use Firefox only very occasionally.

    I do think this may be a Firefox issue more than anything, since the problem is that the stupid browser doesn't pay attention to the certificates stored right on the Windows machine, where all other browsers check.

    I do love the answer from Bitdefender "support." Sure, just turn that security feature off. It doesn't affect security.



  • Quote



    QUOTE (Savoy @ November 4, 2015, 7:11 PM) /index.php?act=findpost&pid=245630" rel="" style="color:rgb(60,105,148);text-decoration:underline;background-color:transparent;"><{POST_SNAPBACK}>
    Rebonsoir, Well, after much wasted time on this problem, I think I found a solution! (It would be good in future Firefox -portable- working with BitDefender ...) If it serve other people, I indicate here the process I followed: 1) for Windows 7: Start / certmgr.msc / Authorities certification trusted root / Certificates right click the BitDefender certificate / All tasks / Export / Next / Next / (choose a location and name the file) 2) Under Firefox Portable:Options / Advanced / View certificates / Import / (change the previously exported file and tick three boxes) Everything works flawlessly, as before . I'm proud of myself ;-))) Jerome, Savoie.



    Sorry for bumping a old post, but just wanted to say thank you very much!


     


    This worked perfectly for me with the latest version of Windows 10 and BitDefender. Was the only issue I had with using BitDefender, glad to have it taken care of.