new rescue-CD does not work on Win10-64bit,version 1803

Benny Hest
edited February 2022 in The Archive

The lastest rescue-cd, downloaded 17-dec-2018, size=832MB (sorry, I dont see any versionnumber) did not work in win10-64bit.

But an older version, from around October-November,size=667 MB did work.(Since this worked, I could see it was version AVCORE v2.1... 9, 2017))

I formated the pen with fat32 in both cases. After I had the version v2.1... up and running, i tried again with the new version, but nope, it does not work.

The new version loads until the language selection(only english, and troubleshooting) Then it outputs this error:

!!/dev/loop0 is an invalid root device

!!could not find the root block device in .

!!please specify another value or:

-press Enter for the same

-type shell for a shell

-type q to skip


A novice, like me had to figure out a couple of things, that I might as well share:

-For a new system with UEFIbios, its necessary to enable (I am talking about a Lenovo-bios, its proberly similar names for other bios´) CSM(compatibility Module Support) and disable "secure boot". For me, when enabling CSM, the bios automatically disabled "secure boot". And the other way around, enabling "secure boot" again, would disable CSM. But it has to be in the right order, disabling "secure boot" first is NOT enough, CSM must be manuel enabled. For me the paths where:


-Security\secure boot

I also disabled Devices\Network Setup\Boot agent(PXE startup), because that dosent sound right, that a home-pc can boot from the networkcard.



  • I tried that but I still get the message of invalid boot device. please help. the bios of the computer i was trying to scan doesnt have the CSM option but i disabled the secure boot and still get the message. 

  • JavierV8

    The way I interpret the interdependency between the "secure boot"-setting and the "CSM"-setting, is like this:

    The "secure boot" functions like an umbrella/parent/global -setting, where the "CSM"-setting is just a child-object. This way, if you see the "secure boot" is enabled, you know all its child-objects are also on tight security. But if you disable "secure boot", it will not loosen security on all its child-objects. That would be too radical I guess.

    So you have to find the relevant child-object, and relax its security. I suspect its name would be something like CSM/compatibility boot/legacy boot/legacy support/insecure boot/or something similar. If you do this, the "secure boot" will automatically become disabled, as it can no longer garantee the full security level, and the "secure boot" dont wont to make false announcement.

    Boot security like this, is not particular important for my own home-pc, because I dont expect people who come to my home will be trying to boot my pc on an independent boot operating system. But I could see this as relevant in a business enviroment, where you dont want a random person booting on an usb-pen.

    Remember, this is just my own interpretation, from what I experienced on my own Lenovo-bios. I could be wrong, or things could be different on other Bios´.

    Good luck.


  • Hello,

    We've discontinued our rescue CD software and no longer support it, however, it's functions have been baked into our classic line of products. You can read more about the new Rescue Environment in our user guide below:

    Thank you.

This discussion has been closed.