How To Block By Folder In Firewall?

Options

I have several programs that are trying to constantly connect to the internet and they keep giving me update notices. I've tried blocking these .exe files directly but that does not seem to work. This leads me to believe that I'm not blocking the proper area.


Is there a way to block all activity within a folder using the Firewall so nothing inside it can connect to the internet?

Comments

  • columbo
    columbo
    edited October 2012
    Options

    Hi sjurassic :)


    Try seeing if that program looking for the outbound connection is listed in your Applications, and deny its Permission(s) If it isn't there, try creating a permission for it, then settings to deny it. The Firewall setting flow chart can be found here: http://forum.bitdefender.com/index.php?showtopic=36066 You have to click on the Applications Plus sign + of the one you want to edit, to expand it to show the Network icon and its settings, you can then double click that, or click it and now the "lighted" Edit Rule settings, to be able to edit. Just a helpful tip :)


    Kind regards,


    Columbo

  • Yeah, I was thinking that. That was the first thing I tried. It was as simple as just finding where the rule was created and click "Deny." For some reason that's not blocking it.


    Any idea why it's getting past the firewall and connection? I know that when I disconnect from the internet it prevents this.

  • coolcool1227
    Options

    you have to block application's executables as well as their processes. And as far as I know there is no way to block the folder using Bitdefender.

  • you have to block application's executables as well as their processes.


    Can you expand on this a bit? When the rule is created, I go into the rules settings and I can see that the "Apply To" path is set to the programs .exe. I don't see any other options I can set regarding the application. I leave everything else set for all directions/networks and click "Deny."


    Am I missing something?

  • coolcool1227
    Options

    I mean when a software is installed and executed some services and processes are also started alongwith the main application. So in order to complete block the software you should have to block application as well as its processes.

  • I think I may be doing the opposite. I am easily able to directly block the .exe files but I think some of the processes are still active and connecting and thats causing the issue.


    How can I narrow down all these and make sure they are blocked?

  • columbo
    Options

    As ONT mentioned, you cannot block a folder per say, but the .exe and processes. To confirm you have all the process blocked for a program, you can check for the software's running process name using Process Explorer, which I find easier and more in depth to use than Task Manager, for this feature.

  • As ONT mentioned, you cannot block a folder per say, but the .exe and processes. To confirm you have all the process blocked for a program, you can check for the software's running process name using Process Explorer, which I find easier and more in depth to use than Task Manager, for this feature.


    Thanks for the reply. However, my issue is it that it seems for some reason BitDefender it failing to put a wall between the program that's connecting and the internet.


    Here you can see in this screen shot that I set everything properly for the app itself (at least I believe it to be correct) and deny it the connection. Yet, somehow it's getting around it. Please look at this screen shot and tell me if there's something I'm doing wrong that's still allowing it to connect:


    bitdef02.jpg

  • rootkit
    Options

    Hello :)


    This discussion will continue over here:


    http://forum.bitdefender.com/index.php?sho...c=38609&hl=


    Thank you!

This discussion has been closed.