Remote Desktop Not Working

Options

Hi,


Ever since I installed BitDefender 2015 I cannot logon to my home PC using remote desktop from the Internet. I tried everything. Trusted Ethernet, allowing RDP, etc...


Anyone else have this issue?


Thanks,

Comments

  • Have you tried allowing TCP port 3389 yet? Or is it using a non standard one? Just a tiny possibility, try to disable real time protection too and see if that module is causing it. 1.gif

  • Have you tried allowing TCP port 3389 yet? Or is it using a non standard one? Just a tiny possibility, try to disable real time protection too and see if that module is causing it. 1.gif


    How?


    I just allowed mstsc.exe, will test at work.

  • Firestart
    edited November 2014
    Options
    Hi,


    Ever since I installed BitDefender 2015 I cannot logon to my home PC using remote desktop from the Internet. I tried everything. Trusted Ethernet, allowing RDP, etc...


    Anyone else have this issue?


    Thanks,


    You should choose home network in order to let remote desktop to work.In public profile this service is blocked as far as I know.Disable stealth mode to let your pc to be discoverd.Choose generic "yes" to save this settings and restart

  • You should choose home network in order to let remote desktop to work.In public profile this service is blocked as far as I know.Disable stealth mode to let your pc to be discoverd.Choose generic "yes" to save this settings and restart


    Here is what I did.


    Removed Autopilot


    Removed Block Internet Sharing and port scan thing.


    Put my adapter in Trusted and Generic on.


    What is Generic anyways?

  • Rohugh
    Options
    What is Generic anyways?


    From the user manual -




    Whether generic rules are applied to this connection.


    If the IP address of a network adapter is changed, Bitdefender modifies the network type accordingly. If you want to keep the same type, select Yes from the corresponding drop-down menu.

  • Nesivos
    Options
    From the user manual -




    There are numerous remote code execution security vulnerabilites in Windows. November's patch Tuesday will offer numerous fixes


    Microsoft Security Bulletin Advance Notification for November 2014

  • Here is what I did.


    Removed Autopilot


    Removed Block Internet Sharing and port scan thing.


    Put my adapter in Trusted and Generic on.


    What is Generic anyways?


    you should let port scanning on..make sure u are on "Home network" profile in windows and in bitdefender.Generic is when you make a setting for network and you wanna save it so you will not have to change it everytime u restart pc or change internet from wired to wireless or from broadband to lan..your setting will be applied

  • Georgia
    Georgia ✭✭✭
    edited November 2014
    Options

    You can control via Bitdefender firewall whether RDP is allowed or not this way:


    - bring up Bitdefender and go to Protection


    - click the Firewall panel


    - click Rules tab -> check Show General Rules


    - set to Allow "Incoming Remote Desktop Connections", then click 'Close'


    If the issue persists, tell us if you have set a custom port for Remote Desktop Connections, other than the default one 3389.