[fixed in 19.2.0.151] Firewall Is Blocking Windows 10 Mail App

killerway
edited July 2015 in Firewall

Firewall is blocking Windows 10 Mail app and not allowing the app to sync. When the firewall is off the app works fine, and I'm not sure where the directory is to manually allow it.

Comments

  • Change firewall adapter settings from Home/Office to Trusted! Mail app will start syncing.

  • Thank you so much for this, I was having the same trouble and that worked a treat :)

  • Yup that worked, thanks.

  • Also worked for me, I am however wondering if it is safe to keep the setting on "Trusted" on a home network connection.

  • I am however wondering if it is safe to keep the setting on "Trusted" on a home network connection.


    Hi,


    Hopefully you can trust your home network, at least until Bitdefender has time to sort things out. :)


    Ro.

  • Georgia
    Georgia ✭✭✭
    edited August 2015

    Hello,


    Thank you for reporting this issue.


    Before going any further with the investigation could you please confirm if the mail app from Windows 10 works with these settings?


    1. Open the Bitdefender program > Protection > click on Firewall > make sure the Firewall is turned ON


    2. Go to the Adapters tab > at "Network Type" select "Home/Office" > at "Stealth Mode" select "Off" > at "Generic" select "On"


    Please post back with your results. Thank you.

  • OK Georgia, Firewall is definitely on otherwise the program screams FOUL! :P


    At present Firewall adapters are set to "Trusted" > at "Stealth Mode" "Remote" > "Generic" select "Off". The mail app is working.


    Changed Adapters as you suggest - "Home/Office" > at "Stealth Mode" select "Off" > at "Generic" select "On" Sent myself an email, Mail App not working.


    Returned to the first settings, all worked an emails came through.

  • Change firewall adapter settings from Home/Office to Trusted! Mail app will start syncing.


    I feel like an idiot but for the life of me I cant figure out how to do this. Where do I find the firewall adapter settings?

  • I feel like an idiot but for the life of me I cant figure out how to do this. Where do I find the firewall adapter settings?


    Hello mrshroomfish,


    Open your GUI by double clicking the BD icon in the system tray, click the "Protection" window, click the gear icon for "Firewall", click the "Adapters" tab. There you can change the settings from the drop-downs.


    Ro.

  • Hello mrshroomfish,


    Open your GUI by double clicking the BD icon in the system tray, click the "Protection" window, click the gear icon for "Firewall", click the "Adapters" tab. There you can change the settings from the drop-downs.


    Ro.


    Thank you that did it! I appreciate it!

  • Thank you that did it! I appreciate it!


    Good, now you have your Mail App. Not one I actually use, I prefer Web mail from my browser. :)


    Ro.

  • I have the same problem. Be careful when setting up the Home Connection to "Trusted", I think this allow all your PC traffic to go through to the internet... basically you are disabling the "two-way firewall" and making it into a "one-way firewall". I had a program installed that I did not want it to communicate with the internet. Flipping this trusted switch this program immediately began transmitting all my data...


    I think this is a bug & should be reported as such. Anybody managed to trace the EXE of this app & what it's running container is? I came up with c:\program files\windowsapps\microsoft.windowscommunicationsapps_17.6020.42011.0_x64__8wekyb3d8bbwe\hxmail.exe however I think the data communications is being hid behind some other kind of container/service :(


    I'm thinking about changing firewalls/products for this. I can't put the firewall comms as Trusted & I can't use my email program if it is set to anything else :(

  • I think this is a bug & should be reported as such.


    Hiya, this has been reported and Bitdefender are aware (see post #7 from Georgia) we can only wait for the solution.

  • Georgia
    Georgia ✭✭✭

    @dejjem Do NOT set Network Type to Trusted, but to "Home/Office", then leave Stealth Mode "Off" and Generic "On".


    Also, if anyone from this thread can still replicate the issue with Windows 10 Mail app please run this diagnostic tool while the issue occurs (Check the box 'Try to reproduce the issue before submitting' to enable additional logs):


    www.bitdefender.com/diagnostic


    Upload the BDSP_* archive resulted on your Desktop to a file transfer site (e.g. www.sendspace.com) and then post back the download link.


    Or send us an email at [email protected]m


    Thank you in advance for your help.

  • dejjem
    edited August 2015

    @dejjem Do NOT set Network Type to Trusted, but to "Home/Office", then leave Stealth Mode "Off" and Generic "On".


    Also, if anyone from this thread can still replicate the issue with Windows 10 Mail app please run this diagnostic tool while the issue occurs (Check the box 'Try to reproduce the issue before submitting' to enable additional logs):


    www.bitdefender.com/diagnostic


    Upload the BDSP_* archive resulted on your Desktop to a file transfer site (e.g. www.sendspace.com) and then post back the download link.


    Or send us an email at [email protected]


    Thank you in advance for your help.


    @Georgia, Home/Office, Stealth Off & Generic On does not work - as indicated previously in the thread. Mail app is still blocked. I just re-tried it to be sure. I have uploaded the diagnostic logs from a test machine, as indicated in the instructions above & sent an email to @bitsy. If I had to guess what the problem is, I think it's because I've linked my google account with the Microsoft Mail app thus it needs google TLS access which Bitdefender is getting confused over. Maybe other people with this problem can chime in? Guys, have any of you linked EXTERNAL, non-@outlook accounts to the Windows Mail app?


    Please let us know when this is solved (by posting here if possible as I have subscribed to this thread).

  • @Georgia,


    Sent email with support tool file attached. The mail app still does not work with your suggested settings. :(


    Ro.

  • Same issue.


    I've used the support tool, tried to download and send a message in Windows 10 with the mail app... with no luck. I can also confirm that the suggested setting do not work. I need to deactivate the firewall.


    I have sent the results to [email protected]

  • Same issue.


    I've used the support tool, tried to download and send a message in Windows 10 with the mail app... with no luck. I can also confirm that the suggested setting do not work. I need to deactivate the firewall.


    I have sent the results to [email protected]


    Hiya,


    Have you tried setting the Firewall adapter settings (better than turning the firewall off)as I suggested earlier in the thread - the Mail App works for me.


    At present Firewall adapters are set to "Trusted" > at "Stealth Mode" "Remote" > "Generic" select "Off". The mail app is working.


    Ro.

  • Hi Rohugh


    Thanks for the info, but as per post #15 by Bitdefender Technical Support, they state to NOT set the adapter to trusted. Potentially for reasons dejjem noted in post #13. I'm sure that there will be other reasons too.


    I'll just use Thunderbird until the issue is fixed.

  • Georgia
    Georgia ✭✭✭

    Hello,


    Thank you so much for helping us with this.


    I have received the e-mails from dejjem, rdorian and Rohugh on bitsy mail list and have opened a case with the Bitdefender Testing team.


    I will post back when I have news from them. Thank you for your patience.

  • To add to this, further checking this morning I note that this is only effecting my Gmail, Outlook.com updated normally. I have settings as recommended by Georgia "Home/Office", Stealth Mode "Off" and Generic "On"


    Ro.


    post-175392-1438860992_thumb.jpg

  • Any news on when this issue is going to be fixed or an ETA on how long this could take to fix? Also, I wouldn't set your network adapter to trusted, as it basically disables the firewall, leaving your computer vulnerable.

  • turbo_d
    edited August 2015

    Looking at this it seems bitdefender is blocking IMAP connections, outlook is working on SSL, however GMAIL connection is configured as IMAP, connection to GMAIL succeeds with Bitdefender off. you dont seem to be able to add a rule for the port, unless you know the exe, which i cannot locate.


    We just need in my opinion a built in rule like the ones present for DNS etc.

  • Georgia
    Georgia ✭✭✭
    edited August 2015

    Hello all,


    This issue is already fixed on our developers side. It is due to be released by product update.


    I will post back as soon as I have an ETA.


    *later edit: we make efforts to push the fix by update this Friday, August 14th. Otherwise, it should be available in +/- 1 week.


    Thank you all so much for your help and patience.

  • Thank you all so much for your help and patience.


    ..... and thank you Georgia for keeping us up to date. :)


    Ro.

  • What should the ideal settings for Firewall be after the fix is pushed?

  • Hello all,


    This issue is already fixed on our developers side. It is due to be released by product update.


    I will post back as soon as I have an ETA.


    *later edit: we make efforts to push the fix by update this Friday, August 14th. Otherwise, it should be available in +/- 1 week.


    Thank you all so much for your help and patience.


    New Product Update ---> 19.2.0.151 didnt solve the issue


    I still cant get Metro mail app to sync with my gmail account unless I change network type to " Trusted"

  • Rohugh
    Rohugh ✭✭
    edited August 2015

    Yeah, my Gmail Mail App isn't working yet either, guess we just have to sit it out for a while longer. :(


    Ro.

  • Georgia
    Georgia ✭✭✭

    Hello,


    Please update your Bitdefender to the build 19.2.0.151, restart Windows then go to Events section and make sure the update event requesting to reboot the computer is no longer in the list. If it's still there, click on it then click the button Restart Now that appears at the bottom.


    After the computer restarts open Bitdefender and go to Firewall > Rules tab > click on Reset Rules.


    Now go to Adapters tab and change Network Type to Home/Office.


    Let me know if Windows 10 mail app can sync afterwards.

  • Hello,


    Please update your Bitdefender to the build 19.2.0.151, restart Windows then go to Events section and make sure the update event requesting to reboot the computer is no longer in the list. If it's still there, click on it then click the button Restart Now that appears at the bottom.


    After the computer restarts open Bitdefender and go to Firewall > Rules tab > click on Reset Rules.


    Now go to Adapters tab and change Network Type to Home/Office.


    Let me know if Windows 10 mail app can sync afterwards.


    I just tried to do this... and didn't found the current version of my bitdefender in the first run. After searching for a while i did find my version-number by right clicking on the small icon next to the clock and selected "Info about" (Text may vary as my version is in german and i just try to translate it "on the fly" with my crappy english i still remember) - but how do i manually force the client to update now? It's been quite a long time since Windows 10 got released .....

  • Georgia
    Georgia ✭✭✭

    To trigger an update you need click the Update panel on the main GUI. However, this product update is currently available only for Bitdefender in English.

  • To trigger an update you need click the Update panel on the main GUI. However, this product update is currently available only for Bitdefender in English.


    Well. i just realized that after redownloading/reinstalling your product. :( The version is still 19.1.0.115. That was very surprising as it told me that i was trying to install a different version as the current one running on this computer. So, how long till localized versions are available then?

  • Let me know if Windows 10 mail app can sync afterwards.


    Yes, working for Gmail now. Thank you. :)


    Ro.

  • Georgia
    Georgia ✭✭✭

    Hi, I don't have an ETA yet. If you want you can install Bitdefender in English for now. The kits are here:


    Bitdefender Total Security 2015 - Windows 10 compatible


    http://download.bitdefender.com/windows/de...r_tsecurity.exe


    Bitdefender Internet Security 2015 - Windows 10 compatible


    http://download.bitdefender.com/windows/de...r_isecurity.exe


    Bitdefender Antivirus Plus 2015 - Windows 10 compatible


    http://download.bitdefender.com/windows/de...r_antivirus.exe

  • jitzy
    jitzy ✭✭
    edited August 2015
    Hello,


    Please update your Bitdefender to the build 19.2.0.151, restart Windows then go to Events section and make sure the update event requesting to reboot the computer is no longer in the list. If it's still there, click on it then click the button Restart Now that appears at the bottom.


    After the computer restarts open Bitdefender and go to Firewall > Rules tab > click on Reset Rules.


    Now go to Adapters tab and change Network Type to Home/Office.


    Let me know if Windows 10 mail app can sync afterwards.


    I can confirm the metro mail app is now syncing gmail account with no problem after following this^^ procedure


    Also the invisible button at the bottom of main interface is fixed now


    TY Georgia :)

  • GSpike
    edited August 2015
    Hello,


    Please update your Bitdefender to the build 19.2.0.151, restart Windows then go to Events section and make sure the update event requesting to reboot the computer is no longer in the list. If it's still there, click on it then click the button Restart Now that appears at the bottom.


    After the computer restarts open Bitdefender and go to Firewall > Rules tab > click on Reset Rules.


    Now go to Adapters tab and change Network Type to Home/Office.


    Let me know if Windows 10 mail app can sync afterwards.


    I have BD Total Security 2016, beta build 20.0.16.893. Until this was posted I assumed this thread pertained to that program. I'm having the same issue and no fix yet. When will the fix come to the beta?

  • I have BD Total Security 2016, beta build 20.0.16.893. Until this was posted I assumed this thread pertained to that program. I'm having the same issue and no fix yet. When will the fix come to the beta?


    Nevermind, I went back to TS 2015. Still having an issue though with this new version and Comcast emails.

  • Regarding the incident synchronization BD TS 15 for Windows 10. After several hours of research I could solve the problem with my mail accounts in iCloud and Gmail. According to the indications given by Georgina, however I like to express my opinion, asking the question: Why the update to version 19.2.0.151 not come through the regular channel in the Update option? As Georgina suggested in one of his post. In my case I had to download the bitdefernder security.exe Kit to upgrade to that version.


    On the other hand I thank Georgina support and guidance to resolve the issue. :rolleyes:

  • Hi, I don't have an ETA yet. If you want you can install Bitdefender in English for now. The kits are here:


    Bitdefender Total Security 2015 - Windows 10 compatible


    http://download.bitdefender.com/windows/de...r_tsecurity.exe


    Bitdefender Internet Security 2015 - Windows 10 compatible


    http://download.bitdefender.com/windows/de...r_isecurity.exe


    Bitdefender Antivirus Plus 2015 - Windows 10 compatible


    http://download.bitdefender.com/windows/de...r_antivirus.exe


    Yes. it syncs now. now i just need to wait for the localized version of it...

  • Today I tried to use MS Mail App on Windows 10 for the first time. I have three accounts, one MSN and two gmail accounts. The MSN account syncs fine. Neither gmail account will sync.


    I have BD build 19.2.0.151 installed.


    Is there a setting somewhere I need to flip?


    A search of this issue (syncing not being just a BD issue) shows that disabling the firewall for many is the workaround. While this may be a bug in the Mail App, with BD saying this is fixed in build 19.2.0.151, what should those of us that already have that build do?

  • Hiya,


    Did you reset the rules in your firewall? There is a post from Georgia here, something I had to do to get it to work with Gmail.


    http://forum.bitdefender.com/index.php?s=&...st&p=234545


    Ro.

  • Hiya,


    Did you reset the rules in your firewall? There is a post from Georgia here, something I had to do to get it to work with Gmail.


    http://forum.bitdefender.com/index.php?s=&...st&p=234545


    Ro.


    THANKS! I'll give that a try.


    FYI: This is the Windows Mail sync error - Error 0x80072726

  • All three accounts in MS Mail is syncing perfectly after resetting the firewall rules. THANKS!!!!

  • Rohugh
    Rohugh ✭✭
    edited August 2015
    All three accounts in MS Mail is syncing perfectly after resetting the firewall rules. THANKS!!!!


    Glad it is working, I was only the "messenger", Georgia provided the solution. ;)


    Ro.

  • Hiya,


    Did you reset the rules in your firewall? There is a post from Georgia here, something I had to do to get it to work with Gmail.


    http://forum.bitdefender.com/index.php?s=&...st&p=234545


    Ro.


    I did, and it's still not working with Comcast's IMAP email system. Has anyone gotten it to work with Comcast?

  • Hellblazer
    edited August 2015
    Hiya,


    Did you reset the rules in your firewall? There is a post from Georgia here, something I had to do to get it to work with Gmail.


    http://forum.bitdefender.com/index.php?s=&...st&p=234545


    Ro.


    DO NOT work for me too (Mail and Calendar app). Bitdefender 19.2.0.151. Windows 10 Home. Attach screenshots... For me, not working even when "Trusted" selected. <_<


    post-188979-1440794358_thumb.pngpost-188979-1440794371_thumb.png

  • Hiya Hellblazer,


    Georgia posted earlier in the topic that the update was only available for Bitdefender in English.. I assume that has not been made available yet for your version.


    Ro.

  • mirage22
    edited September 2015

    Hi, I have the same problem


    However I observe that my BD Total Security 2015 is stuck on build 18.23.0.1604. And there is no way to download Gmail emails to the Windows 10 mail app unless i turn the network adapter to Trusted mode.


    I have tried updating BDTS 2015 and restarting the PC couple of times. Have also checked events and there is no request to reboot the system (anywhere)in there. I also filtered the results by "critical" and didn't find such a request. BDTS 2015 does report that the program signatures are up to date.


    So since am at that, what version is anti-malware for all of you? I am at 7.62314 and signature count is 5802690.


    Please advice.

  • Hello mirage22,


    BD v.18 was never released officially for Windows 10. I suggest you follow the instructions here -


    http://www.bitdefender.com/support/-1452.html


    First run the un-install program and then download TS v.19.


    Ro.

  • Hello mirage22,


    BD v.18 was never released officially for Windows 10. I suggest you follow the instructions here -


    http://www.bitdefender.com/support/-1452.html


    First run the un-install program and then download TS v.19.


    Ro.


    Thank you Rohugh,


    After having made the post, I scrolled through the topic to see if other users had similar issues and came across a post by Gloria which stated that Win10 had its own builds. So I downloaded and ran a full uninstall-install process.


    Now things on the IMAP email front are fine