Unable To Do Ftp

Hi,


I am unable to do FTP on Windows 7 and 8.1 if BD Firewall is enabled!!


How can I be able to transfer files from and to my PCs while BD Firewall is enabled?


post-182575-1406193589_thumb.jpg

Comments

  • Hello,


    We recommend these steps:


    - open Bitdefender and click Protection -> Firewall


    - check the box 'Show General Rules' (at the bottom of Rules tab)


    - set to 'Allow' Windows Explorer traffic on FTP


    Restart Windows and check how is everything going.

  • Hello,


    We recommend these steps:


    - open Bitdefender and click Protection -> Firewall


    - check the box 'Show General Rules' (at the bottom of Rules tab)


    - set to 'Allow' Windows Explorer traffic on FTP


    Restart Windows and check how is everything going.


    Sorry, I already tried that before I posted here. Unfortunately my friend, didn't work.

  • Any other suggestions please?

  • FTP has a default tcp port of 21. Are you using other ports than that? Some of them uses port 22. Try to add the port instead. 1.gif

  • FTP has a default tcp port of 21. Are you using other ports than that? Some of them uses port 22. Try to add the port instead. 1.gif


    I already tried that as well but with no luck!!


    Thanks for ur suggestion

  • Hello,


    By default in all Bitdefender products FTP and HTTP traffic via explorer.exe is blocked for security reasons (malware can inject in the process to connect into the Internet).


    An additional rule must be added in order to allow FTP access via Windows Explorer. The reason is simple: the default FTP allow rule is for ports 20 and 21 (normal behavior). However, when a connection is attempted, explorer tries to establish another connection on a random port. Allowing all remote ports for any connection, for explorer.exe, is a huge security breach.


    Our recommendation is to use dedicated software for this, like FileZilla, Total commander or others.

  • Hello,


    By default in all Bitdefender products FTP and HTTP traffic via explorer.exe is blocked for security reasons (malware can inject in the process to connect into the Internet).


    An additional rule must be added in order to allow FTP access via Windows Explorer. The reason is simple: the default FTP allow rule is for ports 20 and 21 (normal behavior). However, when a connection is attempted, explorer tries to establish another connection on a random port. Allowing all remote ports for any connection, for explorer.exe, is a huge security breach.


    Our recommendation is to use dedicated software for this, like FileZilla, Total commander or others.


    I need to access the FTP server through the Windows Explorer - Is there really no way to make this happen?


    When I try to add a rule for explorer.exe it just disappears!

  • I need to access the FTP server through the Windows Explorer - Is there really no way to make this happen?


    When I try to add a rule for explorer.exe it just disappears!


    Found that if I put the IP adress of the FTP server in the "Network exceptions" under "Adapter" - I can access the server without any problems.


    Don't know if this is a bad idea? I trust the IP address.

  • Thanks Dan, had this issue to after moving to BD. Pretty pathetic situation - I have a good mind to demand a complete refund and go back to my old AV.

  • I have found a solution to this problem that works for me:

    As explained by Bitdefender here, the issue seems to be that Windows Explorer by default uses a different port every time to connect to FTP servers ("passive" FTP). So they would have to allow all ports for Explorer, but that isn't a good idea from a security perspective because malware could inject itself into the Explorer process and use it for undetected communications.

    The solution therefore is to force Explorer to only use the traditional standard FTP ports (so-called "active" FTP). This is done as follows:

    1. Open Internet Explorer (yes, Internet Explorer - Windows Explorer uses those settings under the hood)

    2. Go to Tools - Internet Settings - Advanced

    3. Locate the setting called "Use passive FTP" and uncheck it

    4. Click OK and close IE

    After I did this, FTP access from Windows Explorer worked perfectly (provided that the "Windows Explorer traffic on FTP" rule in Bitdefender is set to Allow).

    NB: There may still be issues if your network environment is configured in a way that does not allow active FTP, for example, due to hardware firewall settings. In that case, please contact your network admin, my knowledge on that is far too limited so I won't be able to help you.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.