[Fixed] Safepay Won't Turn Off In Latest Update

Options

Since the latest update to Bitdefender Antivirus Plus 2016, I am constantly barraged with SafePay notices. I have repeatedly disabled this so-called "feature", and added PayPal, eBay, etc. to the "do not ask" list. Yet Bitdefender refuses to honor my settings. How do I fix this?

Comments

  • Unknown
    Options

    repeatedly disabled this so-called "feature"

    By that do you mean selecting "Do not recommend me to use Safepay" in Safepay General Settings?

    http://www.bitdefender.com/media/materials/user-guide/en-US/InternetSecurity/current/html/safepay.settings.html

  • rassilon
    edited May 2016
    Options

    That is correct, Dallas7. I chose the poorly worded "Do not recommend me to use Safepay" option in Safepay's settings, and yet it appears every time I log in to eBay, PayPal, or any other financial services. There is no such option in General Settings. Perhaps you're referring to an old version of Bitdefender.

  • I have the same problem - no way to turn Safepay off - the dialog box keeps popping up even when I say turn off for all sites.

  • Unknown
    Options

    Perhaps you're referring to an old version of Bitdefender.

    No.

    I just needed to make sure by disabled you meant that do not recommend setting. Poorly worded or not, words have meaning and only you know exactly what you meant.

    There's also the Never use Bitdefender Safepay™ when visiting a page from the domain in a regular browser setting, but I'm sure you've got that covered, no matter what you're calling it. ;)

    FWIW, I'm running BDIS in Windows 7 x64 and not having that issue.

    If I were, I'd run a repair and if that didn't handle it, open a ticket with support.

    Cheers.

  • kellycraven
    Options

    The prompt to open a banking page in Safepay will not accept NO for an answer. I have clicked the remember for this page and the remember for all bank sites and clicked NO, yet it continues to pop up - like 5 to 15 times - before it finally stays closed. This happens every time I return to the bank site.

    Do not recommend to use Safepay is enabled for all bank sites I visit in the BD setting, and for overall. (Open Safepay, go to settings)

    It seems as if Safepay is simply not paying attention to its own settings.

    This is new as of a few weeks ago.

  • It seemed that it's a bug. There is onotehr one topic with this problem /index.php?showtopic=69436" rel="">https://forum.bitdefender.com/index.php?showtopic=69436

  • kellycraven
    Options

    It seemed that it's a bug. There is onotehr one topic with this problem /index.php?showtopic=69436" rel="">https://forum.bitdefender.com/index.php?showtopic=69436

    THANKS!

  • SysLogs
    Options

    I'm on -

    Build: 20.0.27.1467

    Engine: 7.65408

    Tested this using goole chrome, opened a banking site (Paypal) and I had the safepay pop up,

    clicked no and remember for this site and had the same issue, it doesn't remember.

    Pretty sure this will be patched in an update shortly.

  • [Deleted User]
    [Deleted User] ✭✭✭✭✭
    Options

    I am a victim of the same bug. It started after the major update last week. Most annoying that Safepay won't take "No" for an answer for all sites. I tried to pay an invoice this morning by Paypal and the darned thing popped up three times during one transaction.

    Have a great day, ... despite Safepay. :)

    Regards,

    -Phil

  • colagada
    Options

    I'm having the same problem. No matter what is done, it keeps prompting on every banking site.

  • gotogordon
    Options

    Same thing here on IS 2016. Very annoying!! For me it only seems to happen on certain sites. It seems to remember on wells fargo but on paypal I get multiple popups just like the post above.

  • gotogordon
    Options

    Same issue here on IS 2016.

  • Sorin G.
    Options

    Hello everybody,

    Thank you for reporting this issue, we are aware of it and a fix will be released via automatic update.

    We will notify you as soon as he fix is available.

    Thank you for you patience.

  • jjsawx
    edited May 2016
    Options

    Hello, I have a workaround, that has worked for me. When the Safepay box pops up, turn on Safepay each time your asked. When you're finished with what your doing Click on the Safepay button on the main Bitdefender Screen. Select Settings from the drop down Settings list. Scroll through the domain list and for each one you want to turn off Safepay for, select "Do not recommend me to use Safepay" from the drop down list under the "Use Bitdefender Safepay" column. It's a pain, but it has worked for me. Oh, by the way. I'm using Bitdefender Total Security 2016 on Windows 10.

  • colagada
    Options

    That seemed to work when I put in the first bank, turned on Safepay, then turned it back off for all banks. It's usable until the fix comes out.

  • jwriddle
    Options

    Agreed - that work around by John256 works in the interim.

  • gotogordon
    Options

    Getting worse here! If I simply type "pa" into chrome search safepay thinks I'm typing paypal and the popup appears. I have verified that chrome is not auto filling paypal but yet safepay thinks so. For example I just searched for parted magic and the pop up came up thinking it was paypal.

    Work around does not work for me.

  • lpsvkzm
    Options

    I am annoyed by Safepay trying to start every single time when I visit my bank online account or ebay or paypal. The problem is this Safepay even cannot start properly, it crashes every single time every so often. Not sure when this problem started, may be 1-2 months ago. So I want to disable Safepay. I am trying to open the Safepay from the Bitdefender dashboard and it immediately crashes with all rubbish messages that this needs to be reported / restarted bla-bla-bla. The problem is it is not yet fixed, no answer in the internet search or on this forum can be found. I run Total Bitdefender 2016 package.

    Bitdefender team - please fix it in the form of an update and either disable Safepay completely or make sure I can open it and disable from within

    Or please contact me and explain what I need to do to fix the problem, if it is my single problem. attached is the message I get every single time Safepay crashes when it is trying to start.

    post-201496-0-02534200-1462636276_thumb.jpg

  • Sorin G.
    Options

    Hello,

    Firstly please make sure you post in the proper forum, since you are running the 2016 version of the program the 2015 forum is not a good place to post.

    Secondly there is a thread already with this situation /index.php?showtopic=69436" rel="">https://forum.bitdefender.com/index.php?showtopic=69436 and it will be updated once a fix is released.

    Topic closed

  • Safepay is useless and I do not want it interfering with every site I go to. I keep telling it NO, DO NOT RECOMMEND ON THIS SITE OR ANY OTHER SITE.! I select NO I DO NOT WANT YOU TO RECOMMEND, and it still does it. I go to the Safepay SETTINGS and set it to DO NOT RECOMMEND AND IT STILL DOES IT. HOW CAN I JUST DISABLE IT????? :ph34r::(

  • Sorin G.
    Options

    Please search the forum before opening a new topic.

    There is already a topic regarding this situation, keep a eye on the topic bellow for further information as it will be updated the second a fix is released.

    /index.php?showtopic=69436" rel="">https://forum.bitdefender.com/index.php?showtopic=69436

  • I checked the options to not use SafePay for the current site, or for any banking websites - yet it still constantly prompts for various sites. If I follow the instructions to fully disable it and launch Safepay and go into the settings, its set to "Do not recommend me to use Safepay" globally, and for several sites. Yet it still pops up when encountering a new "banking" website.

    p.s. I tried to send a support ticket using the built in 'submit a ticket' feature, but it just hangs on "Executing tools" for hours until I canceled it..

  • Sorin G.
    Options

    Hello,

    There is already a topic opened regarding this situation, it is a known issue and will be resolved as fast as possible.

    /index.php?showtopic=69436" rel="">https://forum.bitdefender.com/index.php?showtopic=69436

  • Using BitDefender Internet Security 2016. I am encountering the same issue - cannot disable Safepay or prevent the popup warnings throughout my online banking sessions. Annoying as heck!

  • Sorin G.
    Options

    We understand how frustrating this must be, our devs are working hard to bring a fix for this situation.

    Thank you for your understanding and patience

  • Georgia
    Georgia ✭✭✭
    edited May 2016
    Options

    Hello,

    The Safepay issue reported in this topic was fixed in the latest Bitdefender build version released today.

    Please bring up Bitdefender and click Update. Wait until the update process completes, then click the top right menu and select Events in the drop-down menu. Locate in the list of Update events the event asking to reboot the computer. Click on it and then click Restart Now button in the displayed details. If you don't see the notification to reboot the computer in Events simply restart Windows.

    After the computer reboots, make sure you have the latest build: right click on the Bitdefender icon from the system tray (the area near Windows clock), choose About and look at the Product Information number. It should be 20.0.28.1477.

    I now declare this topic closed. Thank you!

This discussion has been closed.