Firewall Causing Youtube Html5 Videos To Load Very Slowly With Chrome

So to make a little more sense out of the title.


After installing bit defender i realized that youtube will not work on google chrome.


worked fine before installing bit defender. youtube still works fine on internet explorer but i prefer using chrome.


any ideas?

Comments

  • I recently purchased and installed Bitdefender Internet Security 2015 on my Windows 8.1 machine.


    I use Chrome as my default browser. Almost immediately I noticed a problem with YouTube. All HTML5 Videos (YouTube's new default) are extremely slow to load and buffer. Each video takes 8-10 seconds to initially load, then it plays for about 3 seconds, then stops for another 8-10 seconds to load/buffer the next 3 seconds. Video quality/resolution does not seem to make a difference.


    The same videos are working fine in IE and Firefox. They even work in Chrome's Incognito mode. Disabling all Chrome extensions, though, does not fix it in normal. I even downloaded an extension that forces YouTube to use Flash instead of HTML5 and that works.


    The only was I am able to get HTML5 videos to load/buffer normally in Chrome is to disable the Firewall portion of Bitdefender. As soon as I did that they started working normally. I re-enable the firewall and it goes back to super slow load times.


    Fireswall Settings are Home, Stealth Off, and Generic On.

  • Hello,


    Please go to chrome://flags/#disable-direct-write


    Click Enable on Disable DirectWrite Windows, then restart Google Chrome.


    Please reply with your results.

  • This sometimes work but, but still html 5 videos in youtube in chrome don't load fast. In all other browser I have no issue, but I like Chrome just for youtube.

  • Welcome to the Bitdefender forums, Bert_vh!


    It would help to test if the issue persists on your end when making these changes in Bitdefender firewall:


    1. Open the Bitdefender program > Protection > click on Firewall > make sure the Firewall is turned ON


    2. Go to the Adapters tab > at "Network Type" select "Home/Office" > at "Stealth Mode" select "Off" > at "Generic" select "On"


    3. Now open Google Chrome and try to watch a video on YouTube.


    4. If the issue persists we would need a traffic capture made with Microsoft Network Monitor, available for download here:


    http://www.microsoft.com/en-us/download/details.aspx?id=4865


    Make sure to replicate the connectivity issue when running this tool. Save it then attach it to your reply here.


    Thank you, looking forward to your results!

  • edited August 2015

    This worked before I installed Windows 10 pro from a windows 8.1 on a 64bit computer. I have now clean installed Windows 10 completely. Used the offline Windows 10 offline update from Bitdefender Total 2015. I have also a 100Mbps line.


    Everything works very fine in explorer and edge, no problem at all on youtube. But there is some delay in gmail connections for Explorer, but not as much as in Firefox and Chrome. Microsoft Edge seems fine on both Youtube and Gmail.


    But in Chrome and Firefox when using Google, logged in on Google account, and Youtube html5 video go so slow that it's stops several times. Switched to flash, and it play fine. So I could use flash if that was the only case. But when even in Google Gmail thing loads very slow, it's unbearable to live with.


    I turned off Bitdefender firewall and everything runs smooth again as it should. So this is a Bitdefender firewall thing and about Google services in Chrome and Firefox.


    I have tried to uninstall with the uninstall tool from Bitdefender web page, clean reinstalled the Bitdefender Total 2015. Reinstalled Firefox and Chrome at no succeed.


    So I need a solution or I just change antivirus to F-Secure or Kaspersky. It's somehow to bad, because I liked Bitdefender and it was not slow at all on the performances on web, as it also was a good antivirus and firewall.

  • @PowerShot please try the steps from this post and let me know if they help:


    http://forum.bitdefender.com/index.php?sho...st&p=234545


  • @PowerShot please try the steps from this post and let me know if they help:


    http://forum.bitdefender.com/index.php?sho...st&p=234545


    I did the recommendation in the link you gave, and not a dumb idea to try.


    Well, this is when I watch YouTube HTML5 on Firefox, it's very slow, it barely streams and stops up several times in it's streaming. I watch etch 2,3,4,5 seconds and it stops up, this just continue some few second and stops again. This happens true the hole video


    I shut down firewall and Firefox stream as it should be doing, fast and good. I managed to change Google Chrome for YouTube. But only because I close down the Firefox browser, and run Chrome by it self. Then Chrome stream as it should do with HTML5 on YouTube. If not, Chrome also streams in the same slow matter.


    So Firefox and firewall on Bitdefender do something to hinder the effectually streams of HTML5 video on YouTube, but also Gmail is a little slower to start in the browsers.


    Just to say. Firefox can be up and running at the same time I run Explorer or/and edge and Explorer and Edge streams HTML5 video on YouTube very well and fast. It's strange that the Firewall interference cross this two web browsers when it up at the same time, Firefox and Chrome.


    I have reinstalled Firefox, Bitdefender, done you recommendations. I have even also started Firefox in safe mode, reseted Firefox, and still the same slow result. The only way to get Firefox to stream well on YouTube is to force Flash Player to play instead of HTML5, then it stream as it should be. Or I have to turn off Firewall in Bitdefender Total Security 2015 for it to stream as it should do, fast without a break.


    We talking about a 100Mbps line and a high end computer. And it had no such problems in Windows 8.1. Just to say, I also clean installed Windows 10 Pro 64bit after the upgrade from Windows 8.1.


    I must say it's a bit frustrating, since I use YouTube that much, and like to use Firefox <_<

  • I got the exact same problem, Win10, Firefox and Bitdefender.


    I notice https://mail.google.com loads very slowly, in fact it often offers me to switch to HTML mode for slow connections. This happens on two different computers also and with different network connections.


    The only way to make Firefox work normally for this is to turn off the Bitdefender Firewall.


    I have submitted a recreation of the problem to support.


    I switched to Windows 10 and started using BitDefender at the same time. In the beginning I believed it was Windows 10 but now I am positive that Bitdefender is the problem.

  • I got the exact same problem, Win10, Firefox and Bitdefender.


    I notice https://mail.google.com loads very slowly, in fact it often offers me to switch to HTML mode for slow connections. This happens on two different computers also and with different network connections.


    The only way to make Firefox work normally for this is to turn off the Bitdefender Firewall.


    I have submitted a recreation of the problem to support.


    I switched to Windows 10 and started using BitDefender at the same time. In the beginning I believed it was Windows 10 but now I am positive that Bitdefender is the problem.


    I have had this problem for a long time both in Windows7 and now Windows10. I sure hope the BitDefender Engineers resolve this soon. This occurs in Chrome, Firefox and Opera--all the latest versions.

  • youtube very slow, once the firewall disabled it works very well please make an update


    Thanks

  • How about you once again change your home&office/stealth/generic? Of course with rules reset, sure it's gonna work this time. Or maybe it's because you don't have English version #18.2102.120501.21025/001203? Oh you actually do, so... Well then, we're just not gonna reply. But without turning anything off or changing any stuff, connection runs silky smooth on Chrome with incognito mode. You lads are pathetic for not coming with a fix for so long, seriously. @Georgia please change your sig to "Slowed by Bitdefender".

  • Any reply from "Slowed by Bitdefender"?


  • It may results from the loaded browser cookies , cache and history, etc. You can clear those data and try playing YouTube videos again. Alternatively, you can check this method: http://www.videoconverterfactory.com/tips/youtube-not-responding.html


    Hope it works.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.