Firewall problem after update to 22.0.18.224. Can't map drive or use UNC path.


My computers just updated Bitdefender to build 22.0.18.224.  After this upgrade, I can no longer access other computers on my network.  I am unable to map drives or access my NAS backup server.  I don't see any notification by Bitdefender that it blocked anything.  I have two scenarios:  1) I have a Win 10 computer that I map to from another computer.  Both computers run Bitdefender.  The only way I can map drives is to turn off the firewall or set network adapter local area connection to Home/Office on the computer I'm mapping to.  2) I attempt to access my Synology NAS backup server by going to \\NAS\Backups\ folder.  It can't connect to it using UNC notation.  The only workaround I found was to disable the firewall on the computer I'm connection from.  The NAS is not running Bitdefender.  

This worked fine until the Bitdefender upgrade today.  How do I keep my firewall on and still map to the drives and access with UNC path.  If I set my local area connection to home network, will it automatically change it back to Dynamic if I take the computer and plug into a different network.  I'm hesitant to set it to Home/Office even though it's currently at my home.  Please help.  I'm hoping theres a rule I can add to fix it, or you can provide a software update.  Thanks.

Comments


  • I am in the same boat and cannot access my NAS either. It was suggested in an other forum topic to disable the SSL scanning and that seemed to help initially. Alas, this morning when I turned them all on, it was as before and my networked computers or NAS cannot be found from my pc running windows 10 pro. As my other pc is running the home edition of windows 10 and has no problems I wonder whether that could be an indication of where to start looking for a solution ? For now I am eagerly awaiting the e-mail from BD support with steps how to remedy this situation


  • I followed the instructions listed in this post, but it didn't help.


    https://www.bitdefender.com/consumer/support/answer/8908/


  • Same problem for me ... appeared January 30th, and also currently running build 22.0.18.224 on W7 Ultimate 64 bits.


    My daily backups cannot access my NAS anymore. Also no response to ping from Command Prompt, either by name or IP address.


    Only way out is to disable Firewall in BD TS 2018 ... which is a no go.


    I tried to add a network exception as specified in FAQ link referred to by DWK, but to no avail. Rule is well set but inoperative.


    I tried also to reinstall BD TS 2018. That worked for a short while. Immediately after the restart, I was able again to access my NAS, but since my BD is on hourly updates it quickly caught up with build 22.0.18.224 and here I am NAS blind again ...


    Please Bitdefender Team, solve this bug asap. Thanks.


     


  • I found a workaround (sort of) which is acceptable for me at the moment, hope it works/is acceptable for you too.


    As my free version of an excellent backup program could not find my NAS anymore,  and I  wasn't prepared to fork out the money (Yeah, Yeah, I know, chea.p b*stard, I know ^_^) before I knew for certain that it would be fixed when buying a pro version,  I thought of switching to an other good and trusted backup program EaseUS ToDo backup of which I found the free version here: https://www.easeus.com/download/tbf-download.html 


    I am happy to say that my backups are now again being made and can be accessed too and though I use my NAS for more than just making backups I am as happy as a happy backupper can be at the moment.


     


     


     


     


  • Just found this turnaround solution posted by Sergiu (Bitdefender Tech), in the second thread on same issue recently opened by TiedCone. Worked so far, but only if going by IP address not by name). See below.



    8 minutes ago, jfg95 said:



    Hi Sergiu,


    Thanks a lot. This workaround with a specific rule created for explorer.exe seems to work, but only if going by IP address (not by domain name).


    Before I start modifying all my NAS backup profiles (there are quite some ...) would you have any other trick allowing full use of DNS ?


    And when do you think that this bug in build 22.0.18.224 will be corrected ?



     



    On 1/28/2018 at 11:18 PM, Sergiu C. said:



    Hi, 


     


    As a workaround you can set a rule that applies for all applications (or just explorer.exe from C:\Windows) and with the IP address of the network resource in the Custom Remote address field.


    For detailed steps, please read our support article:


    https://www.bitdefender.com/consumer/support/answer/2128/



     


  • Bitdefender Support got back to me and everything is working again.  In the firewall network adapter settings, I had to set ALL adapters to Home/Office.  I had a VirtualBox adapter for virtual machines and although I didn't think it would matter since I'm not running those virtual environments, it wouldn't work unless every adapter was set to Home/Office.  I also turned off Stealth Mode for all adapters.  Now I can map drives and NAS using UNC.


    Does anyone know what happens if I take my laptop and plug into a public network?  Are my settings always Home/Office or will it recognize it as a new network and chose Dynamic?  At the bottom of the Network Adapters settings, I've selected Dynamic Network.  I don't really understand how the settings on this screen works.



  • 2 hours ago, DWK said:



    Bitdefender Support got back to me and everything is working again.  In the firewall network adapter settings, I had to set ALL adapters to Home/Office.  I had a VirtualBox adapter for virtual machines and although I didn't think it would matter since I'm not running those virtual environments, it wouldn't work unless every adapter was set to Home/Office.  I also turned off Stealth Mode for all adapters.  Now I can map drives and NAS using UNC.



    SJEEZ, so simple and still very effective.Thanks DWK for sharing this info, it has solved my problem and I wish I had the answer for you on your question too, but alas I think we have to wait for the gurus. 


  • DWK and Support - Bingo! Testing now but same issue since BD updates from last week.  Has only been a recent issue for printers and non-windows devices connecting to my Win 7 PCs running through the BD firewall. I too have a VPN and stealth mode needs to be disabled on VPN adapter regardless of the VPN running or not. This indeed was not the issue before BD undates as I would run the VPN device in stealth mode.


    Seems like a glitch in recent BD updates. Hope they can fix it. I will post on other thread.


    Jeff


     


  • By the way, Support said you may have to reboot after making the changes.  If this doesn't work for you immediately, try rebooting.


    It definitely works differently than before.  I used to have adapters as Dynamic and Stealth Mode on.  I guess you could argue you should only be accessing these devices on a home/office network, so they may view it as a fix and not a glitch.  We'll have to wait and see if they change it again.


  • DWK, I confirmed and fixed firewall network problem. VPN adapter needs to have stealth mode turned off. Local adapter always had stealth mode turned off. Thanks for your assistance.


    I would still say it's a bug cause my VPN is connecting to a seperate network for a remote desktop session. There is no need to provide that network with any additional resources. That seems to be the point of stealth mode. Previous config was stealth mode on for the VPN adapter and stealth mode off for the local adapter.


    At least all the old local devices are communicating once again!


    Jeff 


  • I received a response from support saying the solution "is permanent and does not affect the security of your device".


  • I've been using Bitdefender for DECADES! and always liked it and enjoyed its superb protection and "easiness".


    What's more, due to my very busy work/home schedule, I would leave Bitdefender Total Security on AutoPilot - and that's it!


    This is the FIRST big mess that does not comply with high standards of Bitdefender - DO NOT HURT!


     


    Dear Bitdefender,


    You have a big problem. Please fix it.


    Otherwise, I will replace you forever with something else. I cannot function at work.


    Besides that red nasty sign on Bitdefender after I turn off Firewall, suddenly, my Windows 10 firewall turns on and creates another mess.


     


  • As of today, I can set my adapter settings back to Dynamic.  I guess they fixed it.  I also got a response from Support that said when the adapter was set to Dynamic, it then used the Windows network type you see in the control panel.  So if Windows is Home or Work, then Bitdefender treats it as Home/Office.  If Windows is Public, then Bitdefender is Public.  That's the first logical explanation I've seen on how this should work.  Interestingly, my Bitdefender is now set to Dynamic and Windows is Public, and I can map drives and access my NAS without any issues.


  • I can't confirm that anything has changed and are still awating a solution.


    I tried switching between "Dynamic" and "Home/Office" and that has no effect. I toggled the firewall off and on again which I have done numerus times during debugging and for some reason I was suddenly able to ping one of my non windows host's by hostname but not all. Mapping the host with UNC path is still not working.....


     


     



  • On 24/2/2018 at 3:28 PM, FB68 said:



    I can't confirm that anything has changed and are still awating a solution.


    I tried switching between "Dynamic" and "Home/Office" and that has no effect. I toggled the firewall off and on again which I have done numerus times during debugging and for some reason I was suddenly able to ping one of my non windows host's by hostname but not all. Mapping the host with UNC path is still not working.....


     


     



    The above succesfull ping was a one time event. Turned on computer and now it doesn't succeed anymore..


  • This software seems a heavy bug after every restart with the HDD.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.