BitDefender v10 schedule scans not working.

Options

I just noticed that my scheduled scans were not working. Geesh it was bad enough when the time was off or changed when you went in, but has it stopped scheduled runs completely. Anyone got any ideas?


Thank You


mcomo

Comments

  • Niels
    Niels
    edited May 2007
    Options

    Hi mcomo


    You can try this : open BitDefender go to antivirus,scanning,now press on the icon near quick scanning. Go to scheduler,see is every 1 day is selected and that the start date is correct. Confirm afterwards by pressing on ok. If your computer is in standby mode then the scans can't be executed. That is also the case when you logged out. Take also look that your system clock is correct.


    Regards


    Niels

  • pydon
    Options

    Same problem here. When my PC is idle (not hibernating), BD can't start a scheduled scan.


    This bug appeared about 1 week ago, but only when my PC is in idle mode (only the monitor goes idle), otherwise there is no problem with scheduling.

  • garyinri
    edited June 2007
    Options

    I have had scheduler issues for months. I started a thread on it in these forums back on 22 April, but never received a response. I also had an ongoing thread back on bitdforum.com. Again, no resolution.


    At least now my System Defined scans seem to be running via the scheduler without an issue. At one time I was having in issue with them running at their scheduled times, but they seem to have been running consistently via the scheduler for roughly the past month.


    It is my user-defined scans which do not seem to run, or will run on schedule a couple of times and then will inexplicably just stop running via the scheduler. I have re-installed multiple times with no change in its behavior.


    At one time, I had set up a test task to scan one folder. The task was scheduled to run every 15 minutes. It ran 5 times via the scheduler before it stopped running. I submitted it again and this time it ran 2 times before it stopped running.


    Perhaps with this topic being bumped back to the top, an answer may be forthcoming.

  • Niels
    Options

    Hi garyinri


    You can try this when your tasks fail than try this go to start,my computer,double click on the icon of your hard disc,documents and settings,your user name, then go to tools,folder options,display check then the option show/view hidden folders and files confirm by pressing on apply and ok normally than you will see a folder called application data,Bitdefender,Destkopt,Profiles there you will find a file called tasks.(xml) delete that the file and retry. Or if you know how you can edit it you can try that.


    Regards


    Niels

  • Niels,


    I have previously played around with the tasks.xml file more times than I can remember. I have even deleted it and started from scratch. I have done full uninstall/reinstalls of BD using the Uninstaller tool to be sure everything was cleaned up. While things might be okay for a day or two, after that they stop working again. At least now my system task (tasks_system.xml) seem to be running consistently via the scheduler without a problem. In the past those tasks sometimes had issues as well.


    Gary

  • Niels
    Options

    Hi Gary


    I don't have any other suggestions. That is the file that BD makes when you scheldule a task. Strange for me the tasks are executed on time. Are you sure that your system clock is correct and timezone?


    Regards


    Niels

  • pydon
    Options

    On my side, deleting task.xml fixed the issue. Thanks.

  • On my side, deleting task.xml fixed the issue. Thanks.


    Fixed permanently? Or has it just been for a day or so? I have deleted the XML file in the past and it will work for a few days then the problems will come up again.


    As a test, I have set a task which is supposed to run every 15 minutes. It scans one small folder on my machine. It runs as scheduled a few times and then just stops running. In the interim, nothing has happened on the PC. I set the task, watch it kick off once, and then go do something else for a few hours. When I check the scan logs, I can see that it has only run a few times and then has stopped initiating the scheduled task.


    If you'd like to try the same test I'd be interested in the results.


    I have two licenses for BD AV10 and this is happening on both machines. If it were only happening on one, I'd say it was possibly something to do with the machine configuration. But to have the same exact problem on two machines is a bit strange.


    I am the system and network admin for my company and, as I had mentioned back in the thread on bitdforum.com a few months back, the inconsistency in the scheduler is a major reason I can recommend the purchase of BD for our organization. When you're responsible for some 50+ workstation, you can't be expected to have to manually manage tasks which should be automated. For my personal use, it's an issue I can live with due to the other positive things that BD brings to the table as an AV tool. For our company, however, we've just had to stick with Symantec Corporate Edition for the time being.


    @Niels: Yes, the system clock and timezone are set properly.


    -Gary

  • pydon
    edited June 2007
    Options

    In fact, it doesn't work correctly. I have to delete this file each time before a scan is scheduled, otherwise the next scan will be forgotten.

  • I have the same problem with BD Antivirus 2008. I also had it with V. 10, and I was hoping the new version would correct this issue.


    I schedule a task, and the task runs once as expected and not again. No logs are generated, no disk activity, no scan window. I haven't tried deleting tasks.xml yet, but it sounds like that only "fixes" things for one run.


    As the other forum member said, It's not a deal breaker for personal use since I can run my weekly/daily scans manually, but it is annoying.


    Is there ANY plan to fix this issue?

  • For me it is a dealbreaker. I have too many personal machines to manage to have to mess with this. This has been a problem for me since version 10 and because of it when I needed an AV product for my other machines (I already had 2 2-year BD licenses) and for my wife's and daughter's machines I went to Kaspersky. Like others I was hoping that the upgrade to 2008 would fix things but in fact it has made things worse. While I used to have a problem with only 1 machine now both my BD equipped boxes are failing to perform their scheduled scans.

  • Followup:


    I tried deleting the xml file on both machines as suggested. One machine is working (for now) the other did not work. In fact the second machine is now worse off. It TRIES to run the scan, claims that it is running the scan, but nothing ever happens -- the scan does not actually run, the last scan date does not get updated, and the machine hangs after the attempt -- no untoward CPU or disk activity in task manager or performance monitor but the system slows tro a crawl and eventually requires a hard reboot. This on a machine with dual Xeon processors.


    :RANT ON:


    I'm sorry, but this is getting rediculous. I have used all sorts of other tools that require scheduled tasks to run such as other AV products, backup products, IP address updating tools, and NONE of these ever fail! This should be a well-understood task and should not be hard to accomplish reliably. If BitDefender is unable to get their scheduled tasks to run there is even a task scheduler (Scheduled Tasks) in Windows (which DOES work) that they could use to run their scans periodically.


    I guarnatee that if this is not fixed in the next month I will NOT renew my licenses when they expire and I will STRONGLY recommend to others that they stay away from BD.


    :RANT OFF:


    Thank you.