Firewall Is Disabled

Options

I installed BDTS 2010 today on my pc.


But firewall is disabled and while trying to enable it shows the error:


'Failed to communicate with the BitDefender Security service!'


Also it shows:


Computer IPs: no networks detected


Gateways: no gateways set


I had no firewall problems with BDTS 2009 a day ago !!

«13456

Comments

  • Alex Stanciu
    Options

    Hello kunalkoool,


    We have sent you a procedure that should help you re-enable the BitDefender firewall . Please reply to my email if you have any other questions .


    Thank you .

  • Hello kunalkoool,


    We have sent you a procedure that should help you re-enable the BitDefender firewall . Please reply to my email if you have any other questions .


    Thank you .


    Hi


    I have the same problems on my compueter. I would greatly appreciate if you could send me a copy of that procedure to re-enable the BitDefender firewall.


    Regards


    Marzy

  • Hi,


    I have the same problem. I installed BT 2010 and my internet connection stopped to work. I used BT 2008 before and everything was fine with it but I was at the end of my licence so I bought BT 2010 and now I had to uninstall it to connect and write this email.


    What is the solution. I tried to uninstall, clean the disk, check the disk re install but the firewall is still stopping me and I cannot stop it.


    Why is there no stop button on this version? To stop BT from running you have to uninstall it !!!


    Some help will be welcome :o

  • Hello,


    I just purchased Bit Defender Total Security 2010, upgrading from BD Antivirus 2009 - and have had a host of problems.


    First, I could not get updates to work. The only way I was able to fix this was to completely uninstall BDTS, and then re-install.


    Now upon reinstall, I cannot start the firewall. Whenever I attempt to start the firewall, the result simply says "failed" with no errors.


    I am running Windows 7 release version (from my MSDN subscription), 64-bit. I purposely upgraded to BDTS 2010 since it is sold as "Windows 7 Ready".. Perhaps not so much?

  • I am having the same issue...


    BD Support, could you perhaps post the procedure you sent to the original poster here to the forum?

  • Same problem/wish here.

  • I recently installed Bitdefender Internet Security 2010 but I can't enable the firewall as Iget this error "Failed to communicate with the Bitdefender Security service!"


    The product is registered but I haven't activate it yet


    can anyone tell me what to do ???

  • Alex Stanciu
    Options

    Hello all,


    Unfortuantely this procedure is a little complicated and that is why we avoid posting it. We have sent you an email with this workaround and we would like you to reply if you have any difficulties in running those steps.


    Thank you .

  • Procedure worked fine for me -- thanks!

  • Hi,


    I am still waiting for the technician to solve my problem. I am running Windows XP and had BT 2008 which worked fine.


    To connect on the internet I had to uninstall BT 2010 so what the point to get security? :o

  • Alex Stanciu
    Options

    Hello mmuriel,


    We have contacted you through the email . Please reply if you have any other questions .


    Thank you .

  • Hello. I am having the exact same issue with the bitdefender 2010 firewall. I am running Vista Business. What is the procedure to re-enable my firewall?

  • Thank you very much. The instructions in the email seemed to work with 100% efficiency.

  • I'm having the same issue. Please can you forward me the workaround so that I can sort it on my PC.


    Kind regards, Chris

  • After installing the program, I got a message that I had a problem file. When I chose to fix the problem I was directed to screen that stated the Firewall was disabled. After selecting the option to fix that issue I got a message that stated the attemped 'FAILED'.


    Then I went to the 'SETTINGS' screen and noticed the 'FIREWALL' able box wasn't checked off, so I put a check in it and selected 'APPLY'. At that point, the 'Apply' button went to GREY and just stayed that way, while the firewall box emptied itself of the check mark that I had just put there. Selecting 'OK' after the grey 'Apply' didn't have any affect on the change being accepted.


    HELP!!!

  • Hello


    I have the same problem with the firewall. Can you help me?


    Thank you

  • Good evening,


    I have exactly the same problem, not to activate my new activation key, no firewall, more updates!


    Dice-installation impossible, restoring files innefficaces ...


    The famous procedure interests me a lot! In French here will be great!


    In advance thank you ....

  • I am also having the exactly same problem. Please send me the direction for correct this problem. It is better to put this issue in your KB, please.

  • I'm having the same problem here... :(


    Please send me a copy of the procedure / solution, Thanks. ^_^

  • boon_016
    edited September 2009
    Options

    Thank you, Alex. The solution works... B)

  • Hi,


    You are lucky because for me nothing is working. I tried everything the assistance told me and BT 2010 doesn't allowed me to go on the internet as soon as it is installed.


    This is crazy !!!

  • I am have the same problem about trying to get the firewall enable.


    Can you please help me........

  • Hello


    I have the same problem with the firewall. Can you help me?


    Thank you


    Hello again,


    I'm still waiting for an answer. I'm running Vista Home Premium. Can you send me what do I have to do?


    Thank you

  • boon_016
    edited September 2009
    Options

    Unfortunately, :(


    The solution did work for me, :)


    but after another reboot, :o


    the problem will face up again and again... :blink:


    I need to keep doing that procedure to keep my firewall works. <_<


    How can I stop the problem? :unsure:

    post-15836-1252741483_thumb.png

  • In the end, I'm back to v2009. :wacko:


    Due to v2010:


    unstable, :huh:


    firewall problem, :(


    dragging pc performance, :blink:


    clash with several applications. :ph34r:


    Bitdefender provides strong protection, :wub:


    but the problem is, program not stable enough. :o


    Hope that Bitdefender will fix the issues and more improvements. Thanks. B)

  • Hello kunalkoool,


    We have sent you a procedure that should help you re-enable the BitDefender firewall . Please reply to my email if you have any other questions .


    Thank you .


    Hi Alex,


    I am experiencing an identical problem. Could you please send me the procedures?


    Thank you.

  • Hello, i'm also having this problem, and cannot enable the bitdefender 2010 firewall, can you send me the sollution? Thankyou!

  • hi trying to find solution to disabled firewall in fix issues, everytime i click to fix it says failed

  • Hi,


    Finally, BT 2010 is working. The french hotline found the solution for me. I just had to install SP3 and all the updates for windows XP. I was reluctant to do it because I had problems with SP3 few months ago but with the version I downloaded, it seems like everything is working fine.


    Thanks to everybody :rolleyes:

  • Alex Stanciu
    Options

    Hello all,


    In order to be able to reinstall the BitDefender Firewall, we recommend you to follow the steps from the next article:http://www.bitdefender.com/KB391 .


    Thank you .

  • Can i please have an email please i would like to fix the problem on my own vista home premium machine.


    Thank you


    ~Ryan

  • Hello all,


    In order to be able to reinstall the BitDefender Firewall, we recommend you to follow the steps from the next article:http://www.bitdefender.com/KB391 .


    Thank you .


    Hey this solution doesn't work for me :(


    Can you help me out??

  • I have recently purchase BitDefender 2010 Internet Security. I have having issues getting the firewall to work. When I attempt to enable it, it give me the message "Failed to communicate with the BitDefender Security service". Help please! I have followed the troubleshooting three time now to no avail. Everything else seems to be working fine.


    Cheers!

  • I have the same problem. Have had to uninstall from PC in order to get on line. Pls send me the patch.

  • Even if a fix is available, we would like to know more about why this happens.


    During installation, a Windows dialog may appear asking for permission to install the "BitDefender Firewall NDIS Driver". Did you select "Continue anyway" or "Stop installation"?


    Can you open a command prompt (in Start->Run, enter "cmd") and post here the result of the following commands:


    sc query bdfndisf


    sc query bdftdif


    sc query bdfwfpf


    Thank you.

  • dary
    Options

    I have same issue, firewall is disabled and while trying to enable it shows the error:


    'Failed to communicate with the BitDefender Security service!'


    Kindly email me the solutions, Thanks a million....

  • I am having the same issues. worked with Vista, put 7 on today and Firewall will not enable. please help.

  • I am having a very similar problem. I upgraded my work computers to bitdefender 2010 under Windows Vista within the last few weeks and everything seemed to be working fine.


    THen I upgraded one of the PCs to Windows 7 as a trial to make sure everything worked fine under the new OS, and now the firewall in 2010 is disabled and i get the message "Failed to communicate with the BitDefender Security service"


    PLEASE HELP!

  • Dave1972
    edited October 2009
    Options

    Try this. Right click any random small file (e.g. a text file) and select "Scan with BitDefender" (should only take a couple of seconds). Then look to see if BD Firewall has started working.


    This works for me. Hardly a definitive solution, but better than nothing. Hope this helps some people.


    Also could someone who has had a support email please copy-paste it onto this thread so we can all see it please? Clearly this bug is affecting a lot of people.

  • Sorry, I just noticed the link to the patch. The patch seems to have worked for me... for now.

  • I have the same problem as everybody else. I have Bitdefender 2010 Total Security and Windows Vista Home Premium x64. When I try to turn on the Firewall option it shows a dialog box saying. "Failed to communicate with the Bitdefender Security service!" If you could send me something to get around this error I would really appreciate it. (If this helps, I just upgraded from Bitdefender Total Security 2009)

  • My firewall continuously stops working (about every 2 weeks) and I must follow the directions herein to restart it.


    THIS IS INEXCUSABLE!!


    I actually had BD 2008 working better on Vista than BD 2010...not certain the upgrade is necessary.


    -Scott

  • When installing Windows 7 I had to turn off my BD Firewall so the process wouldn't be canceled halfway <_<


    And then when Windows 7 was done installing I tried to turn the firewall back on and I got the same error message.


    Can you e-mail me a copy of the procedure please?

  • I have the same problem too.


    I have tried the suggested KB workaround using the two patches twice now and the firewall still does not work.


    Any proper solution please as if I can't get it working I will not purchase the product (using a trial version at the moment).


    Nick

  • Dave1972
    edited October 2009
    Options
    I have the same problem too.


    I have tried the suggested KB workaround using the two patches twice now and the firewall still does not work.


    Any proper solution please as if I can't get it working I will not purchase the product (using a trial version at the moment).


    Nick


    That's because the patches are bullsh!t my friend. I have tried them too - they simply don't work. Like you I am on the trial version. 5 more days left, then if no definitive fix by then (and we all know there won't be) I'm reverting back to Zone Alarm - which I hate to do - I so want BD to work, everything about it is nice - the layout, the intuitive settings and alerts etc - much nicer than Zone Alarm in most respects - except the dam thing thinks its own files are viruses and quarantines them, then failes to open up. I'm still hoping for that last chance fix before my trial runs out - I'm still rooting for BD - their free online scan really helped me recently and that's what influenced me to choose BD when my ZA sub ran out. But they must get this bug fixed and fast! :o

  • Hello kunalkoool,


    We have sent you a procedure that should help you re-enable the BitDefender firewall . Please reply to my email if you have any other questions .


    Thank you .


    may i please have the procedure, i am also experiencing this problem with my new installation of windows 7

  • Hello all,


    In order to be able to reinstall the BitDefender Firewall, we recommend you to follow the steps from the next article:http://www.bitdefender.com/KB391 .


    Thank you .


    Hello, for the awareness of other users and (hopefully) Bit Defender, I provide a few details about my unsuccessful attempt at completing the "fix" described the instructions in the "Bit Defender KB391 article titled " What actions to take when the Firewall is unavailable"". In short, running the executable files (Step A and Step G in my case), in the sequence described in the article, resulted in repeated messages of "system cannot find path specified" (see screen capture below) and, after completing all steps described in the article, the firewall still could not be enabled.


    More details:


    I am running BitDefender Total Security 2010 version 13.0.16 updated on October 26, 2009 at 10:18 PM Pacific daylight time (near end of day, West Coast United States), less than 2-hours before I completed the process described in the KB391 article.


    Windows Vista64 SP2 system.post-8271-1256628001_thumb.jpg


    All actions described below were completed while logged into Windows as an administrator.


    Running Step A resulted in the following window opening and the two "system cannot find the path specified" messages.


    post-8271-1256628025_thumb.jpg


    Upon pressing "any key" (spacebar), the computer immediately restarted itself.


    Following the restart and logging into my administrator account, I immediately ran BitDefender and had it check for updates. It found none since I had checked for, and installed, updates only 90 minutes earlier.


    post-8271-1256628038_thumb.jpg


    Even though there were not updates, I restarted the computer again.


    I then ran Step G and it resulted in the same window opening and "system cannot find the path specified" messages like following Step A. Even so, I restarted the computer once again and ran BitDefender and attempted to enable the Firewall as the last step of the article indicated. The "Failed to communicate with the BitDefender Security Service" message still resulted.


    post-8271-1256628049_thumb.jpg


    As for "system cannot find the path" problem I experienced with running the "fix", my guess is the Step A and Step G executible programs that are downloaded maybe needs to be in a specific folder and the programs assume this when attempting to complete the "fixes". I saved them into a user-selected folder. I do not know what folder Step A and Step G programs should be saved in if they, in fact, there operation relies on being in a specific folder. Those prior forum posters who had success in running the "fix", can you identify what folders you saved the Step A and Step (E) or (G) executable programs in before running the fix? Anyone else with the needed knowledge is encouraged to respond for my benefit and the benefit of others who probably run into this problem, too.


    Last detail: Until I installed BitDefender Total Security 2010 three hours ago, I had been successfully running BitDefender Total Security 2009, with success at enabling the Firewall.


    Thank you. Steven

  • Alex Stanciu
    Options

    Hello Steven_of_CA,


    It seems that this error message occurs because the operating system that you are using is on 64 bits and the executable files from our article can only be used for the 32 bits operating system. Thank you for reporting this sittuation and we are sorry for any inconveniences that we may caused you. We will modify the article, so that the tools that can be found there, to be compatible with both 32 and 64 Windows operating systems. Until then, please follow the steps from the email that we have sent you and let us know if you were able to reinstall the BitDefender Firewall module.


    Thank you.

  • Hello Steven_of_CA,


    It seems that this error message occurs because the operating system that you are using is on 64 bits and the executable files from our article can only be used for the 32 bits operating system. Thank you for reporting this sittuation and we are sorry for any inconveniences that we may caused you. We will modify the article, so that the tools that can be found there, to be compatible with both 32 and 64 Windows operating systems. Until then, please follow the steps from the email that we have sent you and let us know if you were able to reinstall the BitDefender Firewall module.


    Thank you.


    Dear Alex and BitDefender support staff,


    Thank you very much for the very quick response post (roughly 6 hours). Regrettably, it has been over four hours since your post and so far, I have not received any e-mail from BitDefender, in spite of Alex' comment that the e-mail has already been sent (Alex said in his post: "...please follow the steps from the email that we have sent you and let us know if you were able to reinstall the BitDefender Firewall module.")


    I was attempting to send a message to you through your Contact Customer Care system about this issue of my not receiving the e-mail (and not post about this unsent e-mail problem on the forum), however, in my significantly increasing frustration, the Contact Customer Care system gave me an "Unable to process contact messageDB insert error" when I attempted to submit the message. See the attached screen capture of that system's error message.


    post-8271-1256666146_thumb.jpg


    My attempted contact message was tried both with quotes and colons removed from my message and without attaching the PDF file that I was trying to attach to that message. In all attempts, the same error by that system appeared and my message was never successfully submitted. Please advise staff who maintain the Contact Customer Care system.


    As for the e-mail from BitDefender providing me with instructions or patch executable programs for correcting the Firewall enable problem on Windows Vista 64-bit operating system with SP2, I continue to wait for the e-mail. If the e-mail was sent to me, please confirm the e-mail address being used is that specified in my account and send it to me again. If the e-mail has not been sent because the 64-bit operating system version of the patch executable files are not yet ready, please send me an e-mail and advise me of when you expect them to be ready.


    Thank you. Steven

  • For benefit of forum readers and adminstrator, here is an update.


    I came across the following different forum post in which Alex, the responding forum administrator, provides a link to download the 64-bit version of BitDefender Total Security 2010 installation program.


    Forum post in which moderator provides link to download for 64-bit version of BitDefender Total Security 2010


    I do not know if the BitDefender Total Security 2010 installed by the link on the products page results in the installation of the 64-bit version of the program. In my continuing efforts to solve the problem of the installed BitDefender Total Security 2010 not permitting the Firewall to be enabled, I uninstalled the BitDefender Total Security 2010 that I had installed yesterday and then I downloaded the installation program for the 64-bit version of the program from the link in the other forum post (the link provided above). I ran this newly downloaded installation program and installed that presumably different (by being a 64-bit version) version of of BitDefender Total Security 2010. As noted in my original post, my system is running Windows Vista 64-bit updated through Service Pack 2 (SP2).


    I am pleased to report that this subsequent installation of the of the 64-bit version of BitDefender Total Security 2010 was completed with no problem and, as hoped and proved to be the result, I am now able to enable the Firewall.


    As a follow up on the secondary issue that I raised in my last post in this topic, I still have not received any e-mail from BitDefender even though Alex (forum administrator) indicated about 18 hours ago that an e-mail had already been sent to me. I realize time zone differences have left it only about now that BitDeferender staff in Europe are likely reading my second (last) post in this topic and are now only likely able to respond. I do not know what happened but I am moving on to work on other tasks with BitDefender TS 2010, namely, setting up the home network.


    I hope these comments about my experience prove helpful for other users.


    Steven