Vsserv.exe Running Even When System Is Not Idle

Options

I have Autoscan enabled, and I expect vsserv.exe to run only when I am not using the computer, as stated in the documentation.


However, this is not happening. It starts running and accessing the hard drive like mad even while I am using the computer.


And once it starts, it does not seem to stop for quite a long time until it's done doing whatever it's doing. Like for a full half hour or more.


I checked that it is not Windows search indexer that's running, it's the vsserv.exe process, usually between 3 to 12% of CPU usage.


I don't know what kind of criteria Bitdefender is using, but it should check mouse and keyboard activity to detect idle times.


With the other disk tasks that I am running, like file downloads, the scans stress the disk too much, and it's extremely noisy too.


It should probably not scan while there is other important disk activity, it makes the hard drive heads constantly move between the scanned files and the other regular files being downloaded or uploaded.


Either this bug should be fixed, or I should be able to disable Autoscan and replace it with a scheduled scan, but I can't because it has been removed from 2012.

Comments

  • rootkit
    Options

    Hi Chimel


    Vsserv.exe is the main process from our product. It's also the process that handles the scanning processes.


    It's normal to run on a machine when is used because it handles the on access scanning, the web protection, etc. Also, during the idle period Vsserv.exe starts the AutoScan process in background.


    Please let us know if you have any other questions.


    Have a nice day.

  • Hi Cristi, my point is that it seems to scan my disks even when the computer is not idle.


    I can see it from the constant red LED showing disk access, and I can also hear the disks.


    Or does vsserv.exe run disk-intensive tasks other than the scans?


    It's no big deal, but Bitdefender Autoscan does not seem to behave according to the documentation.


    It does not happen frequently though, and it uses much less CPU than the early 2012 versions (see other threads from August-September), so that's not too bad, I'm mostly concerned with the stress on the hard drives, because it happened while I had other disk-accessing tasks running, which don't cause the red disk activity LED to flash as often, and are certainly quiet operations.

  • rootkit
    Options

    Welcome back Chimel


    Vsserv.exe handles also the on demand and on access scanning.


    When you run a software from your machine, all the background processes(drivers, DLL files, etc) loaded in the memory are scanned.


    Also all the http traffic is unpacked and scanned locally.


    Please make sure that your HDD is defragmented and you should see some improvements.


    Thank you.

  • Yes, but running the exact same programs and Internet browsing pattern rarely generates this kind of disk activity.


    It seems to happen very rarely, vsserv.exe usually takes 0-3% of the CPU usage with no noticeable disk activity.


    By coincidence, it's doing it again while I am answering this thread...


    I am not asking for a solution, just bringing it to your attention, as I am 99% sure this is not working as expected.


    I do not have thousands of new or modified files that suddenly require scanning while my system is not idle.


    If there was a way to log Autoscan activity, I could maybe check what it does and why if that helps.


    I won't focus on that bug, there are many more important ones to me, like the toolbar and the 8 days later manual scan message.


    Feel free to escalate or not as you wish, I am embarrassed enough to monopolize all your time! ^-^

  • rootkit
    rootkit ✭✭✭
    edited November 2011
    Options

    Welcome back Chimel


    The Auto Scan is scanning your machine when is not used(no necessary in idle).


    Just to give you an example: I use my machine 8 hours / day and the computer is in idle or unused for around 1 hour / day. Only in that moment the Auto Scan does his "job". In the rest of the time, the On Access component from the Real Time Protection module scans all the files that are accessed.


    In some cases, depending on what you use to access those files (a specific software or Windows Explorer), you will see some activity regarding vsserv.exe.


    Also, please note that even if those files are added to our Smart Cache(files declared clean and skipped by the On Access component), the Active Virus Control still injects in the processes to monitor their activity.


    Thank you.

  • Hi Cristi, I don't mean just when idle, I said when I am typing a document or browsing the web.


    I might be accessing a few dozen bitmaps and other Internet cache files at the time, if that much.


    But vsserv.exe is scanning tens of thousands of files during the 10-15 minutes it's running high, while I use the computer.


    Why isn't the scanner activity logged? At least in some advanced debugging mode, so we know what it's doing and for how long.


    Whatever it's doing, it doesn't stop until it's done, and again, it's running intensively while I'm using the computer, which it shouldn't.

  • rootkit
    Options

    Hello


    We can not provide advanced logging for users for 2 reasons:


    - it is only used for internal purposes.


    - the log will reach up to 10 GB in under 3 minutes(imagine the situation in 15-20 minutes).


    If you use the computer, it normal for the On-Access to scan all the files. All the "classic" antivirus engines(the ones that still use definitions, not the cloud ones) use this method to deliver protection for their users.


    Thank you.

  • Bring it on, 10GB, 0.33% of my system drive... ^-^


    Never mind, most of the time vsserv.exe sleeps at 0% of CPU usage, and when it does run to 3-12% (or even 41%) for an hour or more at a time (no way to know without logs), which happens several times a day, it usually does so silently, even with disk activity. It is stressing the disk in an obvious manner quite rarely during that 3-12% CPU usage time, and for a much shorter duration than the whole vsserv.exe run.


    It's just that with all this v. 2012 simplification and unlogged scanning, it's troubling not knowing what's happening and why, and thus not being able to help Bitdefender improve its products and customer satisfaction.


    Obviously, Bitdefender does not consider this disk stress to be a problem, cannot even tell what causes it and does not want to investigate this issue, so I am giving up too. I consider this issue closed and don't need advanced logging.

  • rootkit
    Options

    Welcome back Chimel


    We appreciate your understanding and cooperation in this matter.


    Since you consider this discussion finished, I will close this topic.


    Take care.

  • Bring it on, 10GB, 0.33% of my system drive... ^-^


    Never mind, most of the time vsserv.exe sleeps at 0% of CPU usage, and when it does run to 3-12% (or even 41%) for an hour or more at a time (no way to know without logs), which happens several times a day, it usually does so silently, even with disk activity. It is stressing the disk in an obvious manner quite rarely during that 3-12% CPU usage time, and for a much shorter duration than the whole vsserv.exe run.


    It's just that with all this v. 2012 simplification and unlogged scanning, it's troubling not knowing what's happening and why, and thus not being able to help Bitdefender improve its products and customer satisfaction.


    Obviously, Bitdefender does not consider this disk stress to be a problem, cannot even tell what causes it and does not want to investigate this issue, so I am giving up too. I consider this issue closed and don't need advanced logging.


    Hi Chimel,


    You are not alone! Vsserve.exe has slowed my I-7 running Windows XP service pack 3 using Total Security 2012,down to a crawl often times just setting there cranking doing nothing. My Internet Explorer at times just locks up. It appears that BitDefender has no interest in addressing this problem which apparently has been going on for years. My computer is a business tool, not a toy, so time is money. To have the best computer security in the world is little comfort if I am unable to use the computer!

  • rootkit
    rootkit ✭✭✭
    edited November 2011
    Options

    Hello Dragonheart


    With all the respect, could you please try Windows 7 Service Pack 1 on that Intel Core i7 machine?


    You have the extended trial version on Softpedia:


    http://www.softpedia.com/get/System/OS-Enh...Windows-7.shtml


    This copy is genuine. You can test it for free.


    Your machine should work a lot faster with the new operating system.


    Thank you.

  • Chimel's problem is my problem too..


    If i turn on Autoscan, then BDTS 2012 is busy with its own business, eventhough i am in a big memory need (editing huge photo in Photoshop)


    if i turn off Autoscan, then it stop doing anything..


    Chimel was right. Once Autoscan start, then it wont stop until it finish..


    it happened almost 4 hours on my system, whether or not i am idle

  • Christi:


    I replied under a different thread but I have also narrowed the problem to Auto Scan. It scans when the computer IS being used. And I do not mean a light scan. The drive is THRASHING. It is non stop.


    CPU utilization is low but a computer is only as fast as it's slowest component. As the drive is fully occupied by Bitdefender, not much else happens except in the few time slices it can find from the drive. Hence the 'slowdown' in everything else.


    I look forward to Bitdefender fixing the Auto Scan to only work when the computer actually idle.

  • I am soooo frustrated. Within the last 3 weeks something dramatic has changed. I often use my computer to download files from my office overnight. They can be large files so I often start them before I go to bed. Suddenly the computer LOCKS UP. I don't mean slows to a crawl, I mean locks up. I can see activity on my hard drive. When I uninstalled Bitdefender for a night, guess what?! No problem. I used this program in the past and it was "okay". I started using Vipre Anti-Virus and it worked well too. When I saw that BD had updated I was excited to come back. If someone doesn't address this issue I'm going to have to say good-bye to BD (and leave my comments in as many forums as I have access to.)

  • Just wanted to add here, that there are several threads concerning this problem:


    http://forum.bitdefender.com/index.php?showtopic=30727 / http://forum.bitdefender.com/index.php?sho...mp;#entry128446


    The solution provided - a new installation - didn't work for me. When disabling Auto-Scan, for example in game mode, my system responds normally and fast. As mentioned above most annoying is the hdd usage by vsserv.exe, as it slows down the system.


    Hopefully Bitdefender is aware of that problem?

  • I have Autoscan enabled, and I expect vsserv.exe to run only when I am not using the computer, as stated in the documentation.


    However, this is not happening. It starts running and accessing the hard drive like mad even while I am using the computer.


    And once it starts, it does not seem to stop for quite a long time until it's done doing whatever it's doing. Like for a full half hour or more.


    I checked that it is not Windows search indexer that's running, it's the vsserv.exe process, usually between 3 to 12% of CPU usage.


    I don't know what kind of criteria Bitdefender is using, but it should check mouse and keyboard activity to detect idle times.


    With the other disk tasks that I am running, like file downloads, the scans stress the disk too much, and it's extremely noisy too.


    It should probably not scan while there is other important disk activity, it makes the hard drive heads constantly move between the scanned files and the other regular files being downloaded or uploaded.


    Either this bug should be fixed, or I should be able to disable Autoscan and replace it with a scheduled scan, but I can't because it has been removed from 2012.


    This IS indeed a problem with BD2012, and for a long time. It is not due to OS updates, service packs, old AV products as can be seen from mnay posts and from my own experience. It really does need to be fixed.

  • rootkit
    Options

    Hello guys :)


    I need some logs before we can continue this discussion.


    You have all the details here:


    http://forum.bitdefender.com/index.php?showtopic=29927


    Thank you.

  • Hello I also have the same problem on a Vista machine - one of the two Cpu's is running permanently at 100%. This causes the fan speeds to increase as the system stresses.


    1) If you turn off autoscan it has no effect but if you then re-boot the system settles down to a 3-4% cpu usage. If you then turn on autoscan the system starts to stress again.


    2) I have removed Bitdefender Total Security 2012 and the system is fine, I then re-installed it from the download ~(the first installation was from CD. The problem has reoccurred.


    3) I use Acronis to backup the system - the system locks up after about five minutes of starting the backup and the only way out is to re-boot.

  • rootkit
    Options

    Hello


    Please follow the steps described here and send me a log via PM.


    http://forum.bitdefender.com/index.php?showtopic=29927


    Thank you.

  • Oh, so it's Anglicized Christian now? ^-^ Welcome back, Christian!


    The issue is random and rare, so current logs would not help.


    Besides, the logs of the retail version don't show anything if I remember.


    I would need some debug version with much more advanced logging to see if we can pinpoint the issue.


    It's not something users can easily detect: I am not always at my computer and I am wearing a headset most of the time, so I haven't even heard the hard disk spinning madly for at least a week. And the red disk activity LED is out of my sight.

  • Hello


    Please follow the steps described here and send me a log via PM.


    http://forum.bitdefender.com/index.php?showtopic=29927


    Thank you.


    Christian:


    Y'know, I would expect you don't need logs anymore to be able to know there is a problem. It looks like this is just a delay tactic.


    I have used Norton and AVG free with no problem. I am going to reinstall BDIS and see if the drive starts to thrash again.


    It would seem to be if we really want to keep using BD, then turn off Autoscan and just do manual scans as required. But it seems that after over 30 days, if you can't fix the problem it does not bode well for BD 2013. BD 2012 was reviewed before this issue. Once the reviewers get wind of the problem, I expect your product rating is going to drop significantly.

  • What do you know, maybe it's not so rare an instance after all, I just heard my hard drive magnetic heads dancing the rock 'n roll, and sure enough, vsserv.exe is regularly exceeding 30% CPU usage in Windows Task Manager. I even saw it jump to 39% once during the minute or so I watched it.


    Is the support tool file I already sent sufficient, or do you need one from after the crazy scan stops?

  • rootkit
    Options

    Hi Chimel


    I will analyze that support tool tomorrow and I will see if something is corrupt or in conflict.


    I will get back to you with the results. Thank you.

  • fqr
    fqr
    edited December 2011
    Options

    Hi all,


    i just updated from BD i-sec 2010 to 2012, due to an icompatibility with BD 2010 antiphishing toolbar and firefox 8. (i did a clean uninstall incl registry clean and a fresh new install). Now firefox works again, but my harddisk is about to be rosted, as vsserv.exe is permanetntly running (not occasionally like in BD 2010, but uninteruptedly using between 5% and 50% cpu load ) and permanently accessing my notebook harddisk even if i'm fully working and not idle. so my disk is heating up like ###### and moreover rattes all the time which slows down my momentus-xt hybrid-hdd to a max transferrate of app 30mb/s (instead of more than 100mb/s). so i would have to switch BD detection off from time to time in order to prevent my drive from overheating and to be able to work, but its piontless for an anti-virus suite to switch of its active protection...


    i called the support hotline today and a girl told me to use this stupid supporttool. as i couldn't find out what specific data will be collected and transferred to bitdefender by this tool, i refused to use it. so she told me that she won't help me if i do not use this tool, but generally she pointed out that this problem is already known, but they do not have a remedy for it.


    great help... thanks! so i removed BD after beeing a user for five years now, and installed a free AV programm for now, till they found something at BD's tech support.... next time i won't extend my licenses for my office.

  • BITDEFENDER SUPPORT TEAM...READ THIS...AND I MEAN READ THIS


    Everybody has problems with your product but you dont seem to understand this..or you dont seems to think its a big issue


    One thing I have all ready notised even if I know you deny it..you guys working in total denial of the problem


    But understand..it is a BIG problem! People installs this product..but they can hardly use the computer..beacuse the product makes the computer unusable..UNDERSTAND THIS!


    You request logs,sreendumps,Computer specifications etc..and you doing this in every tread but you always offer same lame


    solution..Run the SupportTool..and upload the files..and what happens next?...Nada!!! and Im so tired of this.


    I know your wrot to me on a diffrent thread to run the support tool..and my first tought was..why? You must have so many logs


    and sreendumps that you could make like 10 photo albums and 10 books..I mean..what diffrens does it make?


    I am experince that same problems as everybody els..and I have tried it all..New OS Installation,updating this,updating that


    install this..uninstall that..and to be honest..this workaround fix is just lazyness from Bitdefender.


    And I have to do my own workaround to even make Bitdefender service running at all!


    Slow Internet = Disable Virus Protection CPU hogging = disable Virus Protection and updating function or simply disconnect network


    A user shouldn't have to to this...I mean whats the point of having Bitdefender installed when the user have to disable protection beacuse of slowdowns...or to be able to use the computer


    Have any of you guys even managed to fix any issue? ...One thing is for sure..You guys at Bitdefender are seriously not AWAKE!!!

  • I must say I totally agree on the privacy concern about the support tool.


    It says it is gathering Bitdefender related data, so I think if it has nothing to hide, it should go one step further and display what kind of data is being collected in the first screen, and maybe also display it as it is being collected, as the tool runs for 5 minutes without telling anything about what it does. This tool has obviously not been developed by the same genius who did the uninstall tool, which lists everything it does all along the way.


    I use the support tool because I trust Bitdefender and want to help them get rid of the bugs, which would ultimately benefit me and many others, but I don't like this gray area a single bit.

  • I must say I totally agree on the privacy concern about the support tool.


    It says it is gathering Bitdefender related data, so I think if it has nothing to hide, it should go one step further and display what kind of data is being collected in the first screen, and maybe also display it as it is being collected, as the tool runs for 5 minutes without telling anything about what it does. This tool has obviously not been developed by the same genius who did the uninstall tool, which lists everything it does all along the way.


    I use the support tool because I trust Bitdefender and want to help them get rid of the bugs, which would ultimately benefit me and many others, but I don't like this gray area a single bit.


    Well..Im not worried about any privacy..Just mad..over that Bitdefender just offering same lame solutions,workaround etc


    All these logs...over and over again..but they dont fixa a f-cking thing..just capture the logs...say we get back to you...done


    Thread closed!!! So p-ssed off!!! Bitdefender is beginning to behave like Norton People..Same old sh-t

  • mickb
    edited December 2011
    Options
    BITDEFENDER SUPPORT TEAM...READ THIS...AND I MEAN READ THIS


    Everybody has problems with your product but you dont seem to understand this..or you dont seems to think its a big issue


    One thing I have all ready notised even if I know you deny it..you guys working in total denial of the problem


    But understand..it is a BIG problem! People installs this product..but they can hardly use the computer..beacuse the product makes the computer unusable..UNDERSTAND THIS!


    You request logs,sreendumps,Computer specifications etc..and you doing this in every tread but you always offer same lame


    solution..Run the SupportTool..and upload the files..and what happens next?...Nada!!! and Im so tired of this.


    I know your wrot to me on a diffrent thread to run the support tool..and my first tought was..why? You must have so many logs


    and sreendumps that you could make like 10 photo albums and 10 books..I mean..what diffrens does it make?


    I am experince that same problems as everybody els..and I have tried it all..New OS Installation,updating this,updating that


    install this..uninstall that..and to be honest..this workaround fix is just lazyness from Bitdefender.


    And I have to do my own workaround to even make Bitdefender service running at all!


    Slow Internet = Disable Virus Protection CPU hogging = disable Virus Protection and updating function or simply disconnect network


    A user shouldn't have to to this...I mean whats the point of having Bitdefender installed when the user have to disable protection beacuse of slowdowns...or to be able to use the computer


    Have any of you guys even managed to fix any issue? ...One thing is for sure..You guys at Bitdefender are seriously not AWAKE!!!


    I, and no doubt many other purchasers, agree with this statement. I have found two topics with a link to the issue being continued elsewhere, to find the topic has 'been resolved' and closed. After 4 years BD I may migrate to KIS as this seems to be the preferred destination of all those heading for the lifeboats on BD Titanic. Sad.

  • Well this version was riddled with bugs from the start, the most horrible release since at least v. 2009, which is the one I started with, but some bugs are getting fixed, albeit extremely slowly. The scripting code injection when the toolbar is disabled, the "manual scan required" alert when Autoscan is enabled, etc. If you look at other threads and at the pinned updates thread, there are also lots of important bugs that get fixed with every update, so I learned to put the bugs I opened in perspective.


    Yeah, I find it a bit frustrating too when the support people ask for logs and screenshots when it is clear that the issue is 100% reproducible and easily at that, but you got to understand that support people have a protocol to follow. Many customers are not native English speakers, and well, I suppose most of the support people aren't either, so a screenshot speaks better than words, and many issues can probably be easily identified from the logs and other data files in the support tool archive. It's only for us advanced users that it's frustrating, on the verge of insulting...


    Some changes in the support protocol should probably be implemented. I also learned that some support or forum people are using laptops with non default settings or offline machines when trying to repro the bugs we report, so that does not always help either.


    But this is out of topic, it should be discussed in a separate thread. Actually, I think there was such a thread already, unless that discussion about support also emanated from a standard topic.

  • Well..the thing thats gets me most frustrated is quite simple.


    Bitdefender release a product to the public which is full of bugs right from the beginning like its was a finished product


    A bug free product.


    In my opinion Bitdefender would suite in a BETA stage..a product know to have buggs but available for public testing


    If I had known from the beginning that the product had issues..and not perform lika a BETA product..I wouldnt be mad at all


    At least I would have know what to expect...and clearly just state the issues the product has.


    But Bitdefender release this product as it was finished t


    This is a advertising statment taking form your website..this is the first view the buyer would see


    No pop-ups. No configuring. No interruptions. In fact, it requires zero interaction on your part. That’s the kind of silent security you’ll find in all three levels of Bitdefender 2012 antivirus software.


    Whether you’re a PC novice or expert, parent or gamer, select the protection that’s right for you!


    Save time and avoid all hassles - the Autopilot makes the best security decisions for you! This means no pop-ups, no alerts, nothing to configure


    Full Speed


    No impact on the computer performance, as scanning only takes place when your system is idle.


    In my opinion aboutwhat is false in this advertising statment


    No configuring


    It requires zero interaction on your part.


    Save time and avoid all hassles


    Autopilot makes the best security decisions for you


    No impact on the computer performance


    Seriously..


    Dont release a product to public if it cant stand for its advertisement


    This is false advertising


    It will lead to bad business in the long run

  • I posted exactly the same excerpts in some other thread a few months back, but you were complaining about the support people earlier, and none of this has anything to do with them or this thread, even if I agree with everything you say. The program managers for version 2012 should be fired, they're responsible for the whole Earth population associating "2012" not to Armageddon, but to the Bitdefender catastrophe. And now I'm off topic...


    If Bitdefender is game, they should open a new forum section "Help us improve our technical support response." Time to shake up things a little and restructure.

  • I posted exactly the same excerpts in some other thread a few months back, but you were complaining about the support people earlier, and none of this has anything to do with them or this thread, even if I agree with everything you say. The program managers for version 2012 should be fired, they're responsible for the whole Earth population associating "2012" not to Armageddon, but to the Bitdefender catastrophe. And now I'm off topic...


    If Bitdefender is game, they should open a new forum section "Help us improve our technical support response." Time to shake up things a little and restructure.


    I know that Iam in wrong thread so..I will back off..

  • The problem with CPU usage and vsserve.exe for many users, in addition to excessive hard drive activity, dates back to at the latest 1st August 2011 (perhaps there are earlier threads in BD fora that I haven't seen?).


    This problem seems to occur with machines hosting different OSs (Vista, 7, XP etc), on desktop machines and on laptops and netbooks, on machines that have been subjected to re-installations of BD, and on those that are 'clean' and free of remnants of other av suites. Presumably people wearing either brown ###### or black ###### have the same problem. After such a very long time (at least 4½ months), should we not be past the point of suggesting that users change the colour of their ######, but instead de-bug BD2012 and thereby provide a product that is fit for purpose and that is consitant with the claims made in BD advertisements? I expect that this post will fall upon deaf ears at BD but I remain, for now at least, optimistic.

  • Christian, I have a support tool data file that was snapped seconds after vsserv stopped stressing my hard drive and resumed to normal 0% CPU usage, I'll send it your way in a couple of hours when I can upload, as the previous file was snapped during normal operation, before vsserv started weirding out.

  • I too am frustrated by Auto Scan. I simply turned it off shortly after installing BD 2012. Annoyance gone. But after years (decades?) of the industry norm being a scheduled scan that one can schedule to run when one is dreaming of sugar plums and Santa Claus, I am totally perplexed why BD would decide to remove this feature. What does it hurt to leave the code in the application and if we want to use it, we can. Fine if you want to default to Auto Scan "On' and Scheduled Scan "Off." Give us the option of controlling how and when our system is scanned. If there were more controls over Auto Scan, it might not be so bad, but it seems to be a black box that is either activated or not. I don't believe I can control anything about Auto Scan other than the On-Off toggle switch on the home page of the control panel.


    I certainly don't consider disabling a key feature of BD 2012 to be a good long-term solution. And having to remember to occasionally do a full system scan isn't a good plan either.


    So please please please give us our scheduling tool back! I really don't mind if BD consumes my maching at 4 a.m. while I'm sleeping. Take my hard drives. Take my CPUs. Take my internet bandwidth. They're yours! Just let me have them back when I'm awake!

  • tds
    Options

    I finally gave up several months ago, this has been a on going problem for at least 2 years now, before this happened BD had my support as being the BEST security solution around. I was just checking in to see if BD had solved the problem, seems it still is going on unanswered. I wish they would get it fixed.

  • rootkit
    Options

    Hi tds :)


    Please send me a log so I can take look on it.


    http://forum.bitdefender.com/index.php?showtopic=29927


    Thank you. Merry Christmas.

  • Hi Chimel


    Vsserv.exe is the main process from our product. It's also the process that handles the scanning processes.


    It's normal to run on a machine when is used because it handles the on access scanning, the web protection, etc. Also, during the idle period Vsserv.exe starts the AutoScan process in background.


    Please let us know if you have any other questions.


    Have a nice day.


    Hello


    I just installed Bitdefender about a month ago. I'm running Xp sp3 on a Pentium4 computer, at 2.9ghz with 1 gb of ram.


    My vsserv is consumming almost 50% of my cpu when I turn on my computer. This last for 3-4 minutes. Everything is extremely slow.


    Help


    Curis

  • Huami
    edited December 2011
    Options

    hi guys, I was doing a random system check up and was curious to find out what vsserv.exe was when I saw it taking up 7gb of ram on my system, then I saw this thread, luckily though I got 48gb memory ddr3 so it's not a problem for me, if I may suggest, another solution could be to upgrade your memory systems in order to meet the demands of all your requirements. When committing to my pc, I went no holds barred with the thought in mind - if I was going to invest heavily in software, I'd have to have the best hardware available in the market.


    Currently running this system:


    14.320 tb internal memory (7 2tb internal hd with 320gb ssd primary)


    i7-980x extreme edition processor 3.33ghz 12mb cache


    48gb memory ddr3


    thermaltake level 10 gt housing


    2x amd radeon hd 6990 4gb ddr5 512 bit crossfire


    2000watts psu


    2000watts ups


    2x optical drive


    3x 28" hanns-g monitor (hg281d)


    creative x-Fi sound blaster titanium sound card


    etc, etc

  • rootkit
    Options

    Hi Huami


    I can tell you that you have there an impressive configuration.


    Could you please send me a log so I can take a look?


    http://forum.bitdefender.com/index.php?sho...st&p=131491


    Take care. Happy Holidays!

  • Hallo Christian or any other BD member


    As many others I have problems with vsserv.exe consuming up to 99% of my CPU and around 110mb memory.


    With BD 2010 this could be solved by deleting httproxy.dll, but I cannot find that file in the current installation.


    Currently using BD 2012 with all updates


    Windows 7 Ultimate 64bit, SP1 and all updates


    Processor AMD Phenom II X4, 3.21Ghz and 8GB memory


    I've created a logfile and uploaded it to www.sendspace.com


    Please let me know how I can communicate the dowload link in a private way so you can have have a look at it and advise me on how to solve this issue because it is blocking my computer on a regular basis.


    Regards

  • rootkit
    rootkit ✭✭✭
    Options

    Hi :)


    I think I have a solution for your case.


    As the new Bitdefender 2013 product suite was released, we would like to inform you that you benefit from a FREE upgrade to the latest version.


    Apart from the fact that the 2013 suite brings lots of new features and improvements, it will most likely solve any issues that you may have encountered with your previous Bitdefender product.


    Please check out this announcement:


    http://forum.bitdefender.com/index.php?act...f=241&id=42


    After you install the new version, if needed, we will continue the conversation on the new area from here:


    http://forum.bitdefender.com/index.php?showforum=293


    Thank you.

  • Firestart
    edited November 2013
    Options

    I had same issue with vsserv.exe.The cause seems to be vsserv.exe struggling to scan big overcompressed files.If you have big compressed files 80mb or more this can be the problem.Set on acces scanning to "agressive" or limit file scanning custom to 5 or 10 mb.In my case this was the problem prtSc Microsoft Baseline Security Analyzer.That programm 'killed" my pc till I unninstal it and delete those huge overcompressed files.Hope this would help in some cases


    Alternatively u can make exlusion rules for those files if u know for sure those are safe

  • running BitDefender Internet Security 2015, right now vsserv.exe is consuming between 200,000k- 300,000k in processes, and boot time is considerably slower. only firefox consumes this much ram on my older desktop. once it boot_s machine runs normally....

  • I also regularly experience this problem with BD AV Plus 2015. I very much regret having purchased this product. It regularly causes quicken to hang as well as running high CPU as described in this thread. I guess it is time to go back to free AVG. So many good reviews for BitDefender, but it doesn't come close to performing as described.


    I'm also not impressed with their support. I opened a ticket on the quicken problem and after a few weeks was told to upgrade to 2015. The problem has persisted and now two months later they still don't have any reply or suggestion.


    Paul

  • Bitdefender Support Team, Software engineers and Management.


    the vsserve.exe problem has been going on for the last 5 years Yet you still do nothing about it.


    I am having the same problem, vsserve.exe at boot up is taking 70-100% of my CPU time for more than 20 minutes and 431MB of


    Memory and only 1% when running after 20 minutes. I shutdown my computer at night to save energy, so everyday I have this problem.


    Why do you insist on IGNORING the problem.


    If I had read and investigated this problem before I purchased your POS crapware (nothing should cripple a PC when being used)


    I would not have purchased your product. I will in fact tell everyone


    I know NEVER to purchase your POS CRAPWARE because the SOFTWARE SUPPORT


    is the Worst I have seen, 5 years of vsserve.exe problems and not one valid fix to the problem.


    PULL YOU HAEADS OUT OF YOUR COLLECTIVE ######'s and FIX the SYSTEMIC glaringly blatant problem with how vsserve.exe works.


    You have a nice product if it Didn't CRIPPLE the PC multiple times per day and especially at BOOT UP....


    Also why the ###### doesn't your text editor work correctly. the sentences just run on unless you hit enter at the end of the window space.


    and the shift to RICH TEXT Editor doesn't work.


    I still have over 500 days of service, I need a refund, if you can't get this fixed.

This discussion has been closed.