Kindly be advised we cannot cancel subscriptions or issue refunds on the forum.
You may cancel your Bitdefender subscription from Bitdefender Central or by contacting Customer Support at: https://www.bitdefender.com/consumer/support/help/

Thank you for your understanding.

How to disable prompts for SafePay? Not for this page button doesn't work

I was just doing some online banking (at Wells Fargo) and BitDefender kept prompting me to Open SafePay. Each time I clicked "Not for this page", but BitDefender kept prompt me yet again to Open SafePay. I have the Special Offers setting turned off, as well as pretty much all other notifications. Please make it stop nagging to Open Safepay. Thanks!

Best Answer

  • Gjoksi
    Gjoksi DEFENDER OF THE YEAR 2022 / DEFENDER OF THE MONTH ✭✭✭✭✭
    Answer ✓

    Hello.

    Open your Bitdefender program and go to:

    1. Settings -> General and disable "Special offers" and "Recommendation notifications" (for the "Password Manager" notification)

    2. Protection -> Antivirus -> Settings -> Scan flash drives and select "Autoscan" or "Disabled", do not select "Ask every time" (for the "USB Immunizer Recommendation" notification)

    3. Protection -> Antivirus -> Settings -> Scan CD & DVD and select "Autoscan" or "Disabled", do not select "Ask every time" (for the "CD/DVD Recommendation" notification)

    4. Privacy -> Safepay -> Settings and disable "Safepay notifications" and "Automatically open Bitdefender Safepay"

    5. Privacy -> Video & Audio Protection -> Settings and disable "Notify when allowed applications connect to the webcam", "Notify when an application tries to access the microphone" and "Notify when browsers access the microphone"

    6. Utilities -> Profiles -> Settings and disable "Activate profiles automatically" (for the Profile notification)

    After doing that, in the future no pop-up notifications will be displayed in the lower right corner of your screen.

    REMEMBER: When a threat is detected, a pop-up notification will be displayed in the lower right corner of your screen and you can't disable those pop-up notifications.

    Next, as an option to fully disable the Bitdefender alerts and pop-ups, open your Bitdefender program, go to Utilities -> Profiles -> Settings and enable/activate "Work Profile" or "Game Profile".

    When "Work Profile" or "Game Profile" is enabled/activated, all Bitdefender alerts and pop-ups are disabled.

    Finally, as for the Bitdefender VPN pop-ups, you can simply uninstall Bitdefender VPN from your device by following the steps provided here (just select "Bitdefender VPN"):

    or

    open the Bitdefender VPN program, go to Settings -> Notifications and disable "Allow notifications".

    It is recommended that you also review the privacy preferences set in your Bitdefender Central account:

    1. On any internet-connected device launch a web browser, visit

    and sign in to your Bitdefender Central account.

    2. Click on your username in the top right corner and select "Bitdefender Account" in the menu. This option will launch in a new browser tab.

    3. Access the "Data & Privacy" tab, then click on the "Privacy preferences" section.

    4. Uncheck both boxes to stop promotional messages:

    - Receive in product insights regarding threats, news, and offers.

    - Receive insights regarding threats, news, and offers via email.

    Regards.

Answers

  • Ah, thank you Gjoksi! That step you bolded is exactly what I needed.

  • I struggled with this also and was tearing my hair out (and I have a crew cut). BD it comes with the SafePay shortcut right there on the dashboard. It seems logical that the option should be accessible through its settings.

    I had to go to the website and after a brief search did find the instructions. But it shouldn't have been that hard.

    I chose BitDefender because it is not annoying. But that SafePay popup really was.

  • Any initiative to fix the "Not for this page" issue?

    Thanks!