Firewall allowing all through

The firewall is allowing all processes that need to use the internet full access, the only chance I can block it is by going to the rules section and denying access, correct me if I'm wrong but by then it's too late. Problem is that the app doesn't even appear in the rules section, I've had Opera and Chrome browsers open and there's no indication in the rules section that they've been given/denied access. I've set it to paranoid mode and it still wont ask me  if I will allow anything access. It's a poor Firewall if you cant block stuff from accessing the internet.

Windows 10 64bit



  • Hi,

    The PROTECTION thread I wrote today with the same concern you have. How do we make BD Total Security 2107 to block unsafe things? I hope support expert will provide some good answers to this.

      - Val

  • Hello,


    Signed applications receive access by default. Unsigned applications do not get the same treatment.

    If something malicious would request internet access it would have been killed by the Intrusion Detection module before it can even reach the Firewall.

  • edited February 2017

    I don't want anything having access to everything by default, I want it to ask me beforehand otherwise it's not a firewall.


    I don't want hand holding through the process, I want total control.

  • Hello,


    In that case I suggest activating the Paranoid Mode.

    Bitdefender > Settings > Paranoid mode

  • If you'd read the first post then that's the whole point, paranoid mode doesn't work.


    I've already submitted a report to 2nd level tech but as yet they have not got back to me.

  • Hello,


    Please provide me with the ticket number offered after contacting our support team.

  • RE: New Ticket from Chat 2017021219510003

  •  Put a check in the box to the left of the entry for the program in question. Then add or delete appropriate check marks for "Home/Work/Private" and/or "Public".

  • edited February 2017

    With the help from Tech, the problem has now been resolved.

    The issue is with Windows 10 notifications, BitDefender uses Windows 10 Action center to popup requests against the Firewall rather than it's own interface, I had Windows Notifications Off. After enabling it everything works great now

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.