Legacy system extensions - "Antivirus for Mac"

Recently I did an upgrade on my MacBook Pro 2016, “macOS Catalina” from Version 10.15.3 to Version 10.15.4 and received the following: (What is Bitdefender Planning to do in order to resolve this issue now and in the future, as I was planning a renewal, but may now have to look at alternatives? I would rather not change, I have been using Bitdefender since 2009 on Windows and Mac operating systems.)

Existing software on your system loaded a system extension signed by "DEVELOPER_NAME" which will be incompatible with a future version of macOS Contact the developer for support.

Apple indicates:

Some system extensions will not be compatible with a future version of macOS.

System extensions are a category of software that works in the background to extend the functionality of your MAC. Some apps install kernel extensions, which are a kind of system extension that works using older methods that aren't as secure or reliable as modern alternatives. Your Mac identifies these as legacy system extensions.

In 2019, Apple informed developers that macOS Catalina will be the last macOS to fully support legacy system extensions, and we've been working with developers to transition their software. By moving beyond these extensions, developers are helping to further modernize the Mac, improve its security and reliability, and enable more user-friendly software distribution methods. A final transition date has not yet been set.

Until the transition is complete, your Mac displays a message when a legacy system extension first loads, and again periodically while the extension remains in use. This give you advance notice that existing software on your system loaded a system extension that will be incompatible with a future version of macOS.”

Comments

  • I also received this message this morning when I updated to macOS Catalina 10.15.4


    Does Bitdefender have a plan to rectify the situation when it arises?

  • I have also recently upgraded to macOS Catalina Version 10.15.4 and received the same message:-

    'Some system extensions will not be compatible with a future version of macOS'.

    I wish to continue using Bitdefender and I was wondering if they have responded to the above queries?

    Thank you.

  • Same on my: MacBook Pro (13-inch, 2016, Four Thunderbolt 3 Ports) running 10.15.4 (19E266)

  • Me too on Mini Mac 2019.

  • Me Too! Want to keep Bitdefender. Are they working to fix the incompatibility?

  • I also received the same message.

    Can Bitdefender please respond?

  • Product has worked well until now. Sadly, with no word from BD I will be looking elsewhere when my subscription ends.

  • Me too, on 1 April, but obviously not an April Fool's joke. When will we gat a response from Bitdefender?

  • Hello everyone!

    Rest assured, Bitdefender will comply with Apple's policy and the browser extensions will still be functional. You can find out more about this in the article below:

    https://www.bitdefender.com/consumer/support/answer/3779/

  • Thank you @Alex D. Let's hope BitDefender develop on time.

  • It's been a couple of months since this thread was last active. Is there a new build yet? I keep getting this error, almost daily.

  • Getting worried now -- should I start shopping for alternative to BD? Does anybody have recommendations for other security apps that conform to Mac Catalina? Norton? Kaspersky?

  • My Bitdefender on my iMac is not working at all now. Support has been woeful. I think I’ll be asking for a refund. Shame it has been a great product. Very disappointed. Just got the run around

  • Could you please let us know how it looks with the Legacy System Extensions changes? I received another warning this morning from Apple.

    When can I expect a solution to the problem?

    Thanks in advance.

  • OK guys, so you knew in 2019. We've been seeing the message since March of this year yet all we've heard from BitDefender is from back in March that "we got this."

    Well it is seven months later, Public Beta ten of the new OS is out and there has not been any update. I'm up for renewal in another 45 days and can not renew based on a 8 months old "we got this." Please provide an update on Bitdefender's readiness and that the legacy extensions are no longer used and we will not receive further warning messages.

Sign In or Register to comment.