Bitdefender firewall wont allow WSL traffic

Hi there,

I've just installed Bitdefender total security 2020 and I can't seem to get any traffic through WSL2 (windows subsystem for linux). Does anyone know how to allow this or what settings? I've tried a few things but the only thing that works is reverting back to using the Windows Firewall.

Many thanks,

Xephys

Tagged:

Comments

  • FlexxFlexx ✭✭✭✭

    Hi Member

    Kindly drop an email to bitdefender support at [email protected] regarding your query.

    Regards

    Flex

    (Bitdefender beta tester 2019/ 2020)

  • Hi there,

    Are there any updates on this?

    I am experiencing the same issues.

  • I have the same issue.

    Disabling BitDefender firewall fixes it.

  • Guys, this is ridiculous... We pay for a product that doesn't work as intended and there's not even a response for 2 months regarding this issue. Could you at least tell us whether you're aware of it, you're working on it or you can't do anything about it, since it may be WSL2/Windows related or whatever... Just give us feedback.

  • FlexxFlexx ✭✭✭✭
    edited October 2020

    Hi Member

    Kindly drop an email to bitdefender support at [email protected] regarding your query. These types of issue can only be handled by bitdefender support since they can connect internally with the development team to provide you with a feedback.

    Support on forum is limited to basic troubleshooting of the bitdefender products.

    Regards

    Flex

    (Bitdefender beta tester 2019/ 2020)

  • So yeah... I sent an email, and guess what - nothing!

  • Nice post. Thanks for sharing this post with us. I got many information from this post. This post was very useful for me. I got many information from this post . Keep sharing this type of post with us. Your all posts are readable. https://jobsflyer.com job search

  • I also have that issue

  • FlexxFlexx ✭✭✭✭

    Maximum time for support to revert back to any query is 72 hours excluding saturday & sunday.

    @Alex D., @Andy_BD kindly have a look.

    Regards

    Flex

  • I just renewed my license, and moved my dev env to WSL, if I´d known about this I wouldn't have renewed it

  • I am experiencing this issue again after 2-3 months. It was working fine until today. :( Do something

  • Just received an E-Mail that the issue should be resolved with version 25.0.10.52, but it isn't.

  • The issue is presents with all newest versions windows/bitdefender, any updates with it?

  • TyorkinTyorkin
    edited February 9

    I set vEthernet adapter as public network, manually added and approve any traffic for svchost.exe (for main adapter, for me it's ethernet) and everything is ok now. Can anybody confirm?

  • After allowing "C:\Windows\System32\svchost.exe", it works for me.

  • LottieLottie
    edited February 28

    Windows 10 Pro using Ubuntu installed under WSL2

    Bitdefender Total Security: Build 25.0.14.58 - paid version

    Thank you to everyone above.

    In the process of setting up a Windows dev environment using WSL2, I was getting "error: curl: (6) Could not resolve host" even when I tried "curl example.com" from Ubuntu installed under WSL2. No notifications from Bitdefender but just happened a few posts that made me realize Bitdefender is the culprit.

    This post: https://github.com/microsoft/WSL/issues/3761 - suggested running the following command under Ubuntu so I could clearly see what antivirus software is running on my system:

    $ powershell.exe "Get-CimInstance -Namespace root/SecurityCenter2 -ClassName AntivirusProduct" | grep displayName
    

    And helped make it clear that I need to opt for one of the follow solutions in my configuration of BitDefender (BD):

    "If you pause BD protection, HTTPS still fails. But you do not need to fully uninstall it. You can simply exit it before running some HTTPS requests in WSL and start it again after.You can also modify some Network settings. There are 3 solutions:"

    * Disable monitoring of HTTPS/443 port
     
    * Disable encrypted connections scanning
     
    * Add the domain names you usually call, like those called by apt update
    

    I tried adding a rule specifically for Ubuntu but because it is installed under WSL2, the path is not seen as valid by BitDefender.

    What I opted for, which is not optimal, is to add Firewall Rule as follows:

    Program path: C:\Windows\System32\svchost.exe

    Permission: Allow

    Network Type: Home/Office

    Protocol: 6. TCP

    Direction: Both

    Under Advanced Settings >> Ports (for local and remote): 443

    And then rebooted my machine.

    I figure, until BitDefender fixes the issue that will allow me to add Ubuntu specifically or I change protection programs, I'll just enable/disable this rule as needed.

    I would love to hear another way around this if possible. I'll try sending an email to BitDefender...

  • Allowing C:\Windows\System32\svchost.exe worked for me.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.