Sign in button does not work after install of Free

I removed my expired Norton and was going to try Bitdefender Free. Download and install seemed find but the sign in button on the splash screen does nothing. The "view offer button responds".


  • I should add that when I hover over the sign-in it changes to a blue button but clicking does nothing.

  • Hey everyone, I am also unable to find the sign in option after removing avast from my laptop. Can anyone help me?

  • Hy everyone, the same problem with "sign in" option.

    Until today, the app Bitdefender Antivirus Free Edition worked very well in the last month (after the installation, updates, scan, ....).

    The Bitdef Central account is working, the app from my laptop is not.

    Please tell me if you have a solution for this.

    Thank you !

  • I just started having the same problem. Up until today it was working fine.

    Nothing seem to work so I uninstalled it and re-installed it.

    Still the same problem as everyone above.

    Is there a solution???

  • Yep, same is happening for me. My account says BitDefender is running fine on my computer, and I can still run virus scans with the right-click option, but I am locked from seeing the other menus due to this problem.

  • Same prob here...

  • everyone having this problem no one knows the solution

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.