My Devices not showing up correctly in Bitdefender Central

I'm having issues with Bitdefender Central. My devices, three in particular, are constantly replacing each other in Bitdefender Central. I have checked their physical addresses (MAC addresses), uninstalled Bitdefender, re-installed Bitdefender, but the problem is still there. It seems that the device most recently logged on is the one that shows up and the others don't appear in "My Devices" on Bitdefender Central. All three of these particular devices are Windows notebook computers. All my other devices show up correctly, but these three only show up in one slot with names changing depending on log-in status. This seems to be a relatively new occurrence for me.

I have already done all of the troubleshooting, IP addresses checking, uninstalls and re-installs as suggested by the tech support article.

Not sure if this helps you on your end, but the three computers that keep replacing themselves in the “My Devices” list are all Microsoft Surface computers. At any one point in time, only one of those three computers shows up in that “My Devices” list. It appears that the most recently active (on-line) device is the one that shows up in the list.

Answers

  • FlexxFlexx ✭✭✭✭✭

    Kindly drop a mail to bitdefender support at [email protected] regarding your query. They will reply asap.

    Regards

    Flex

    (Bitdefender beta tester 2019/ 2020)

  • I am having the same issue. The other devices are showing, but not a particular one. I have uninstalled and reinstalled and have the same problem. The only difference is that this device is running Mac OS Big Sur and the rest are not.

  • My wife upgraded het mobile phone. Old and new phone is Samsung and Bitdefender was installed and active in her old phone. SIM card was removed from old phone and placed in new phone retaining her mobile number . I, as the Bitdefender account holder, installed Bitdefender on the new phone using my sign in and password. Will this be sufficient in order for Bitdefender to function 100% on her new mobile phone? Please confirm and/or advise the process to be followed if I made an error ? 

Sign In or Register to comment.