Firewall And Windows Explorer Ftp

Hi guys,

I am a very frustrated BitDefender user.

I am using the Total Security 2013.

With the firewall turned on, I cannot use Windows 7's file explorer to do FTP.

I have searched up and down, inside and outside, but found no solution.

I have tried all the combinations of the settings of the firewall that appear relevant with no success.

The network adapter = network type: home/office = stealth mode: off = generic: yes

General rules: all allowed

Application rules: cannot find explorer.exe in the list although I can see a bunch of explorer.exe nodes in the rules.xml file.

Adapter rules: Wireless Network Connection: allowed

Intrusion Detection System: off

Internet Connection Sharing: on

I have first repaired and then reinstalled the Total Security software. The build is 17.xxxxxxx.

What more can I do other than turning off the firewall to allow the explorer to have access to FTP sites?

Please help!



  • I have found a solution to this problem that works for me:

    As explained by Bitdefender in another thread, the issue seems to be that Windows Explorer by default uses a different port every time to connect to FTP servers ("passive" FTP). So they would have to allow all ports for Explorer, but that isn't a good idea from a security perspective because malware could inject itself into the Explorer process and use it for undetected communications.

    The solution therefore is to force Explorer to only use the traditional standard FTP ports (so-called "active" FTP). This is done as follows:

    1. Open Internet Explorer (yes, Internet Explorer - Windows Explorer uses those settings under the hood)

    2. Go to Tools - Internet Settings - Advanced

    3. Locate the setting called "Use passive FTP" and uncheck it

    4. Click OK and close IE

    After I did this, FTP access from Windows Explorer worked perfectly (provided that the "Windows Explorer traffic on FTP" rule in Bitdefender is set to Allow).

    NB: There may still be issues if your network environment is configured in a way that does not allow active FTP, for example, due to hardware firewall settings. In that case, please contact your network admin, my knowledge on that is far too limited so I won't be able to help you.

This discussion has been closed.