Bitdefender for Mac consistently drops "Allowed Applications" for Safe Files.

edited January 2022 in Archive

Bitdefender, now in version, has a terrible bug that I've reported for over six months with zero resolution.

If I add a new application to the safe files' "Application Access", BitDefender will drop that from the list and it will be blocked when it tries to run. I've reported this to "support" many times with files requested, etc. I've also tried completely uninstalling BD, including the PLIST file that holds the allowed applications.

Nothing has worked thus far and it makes BitDefender's safe files useless as I need to disable that feature to just get work done.

Furthermore, Bitdefender takes so much CPU, my fans are always running so I often have to disable it entirely.

Does anyone have any suggestions how to fix the bug where BD drops added files from the "Allowed Applications"?

I was hoping Bitdefender would have fixed this bug after six+ months.



  • I have the same problem on with adding Parallels but not with CPU. I often have to add Parallels to the Allowed Applications. It then drops off.

  • I have exactly the same problem. I run Parallels on my Mac (for virtual Windows). I keep on having to add Parallels to the Safe Files list, as it gets deleted every time I shutdown my Mac. I contacted Support, they suggested I delete BitDef off my Mac, ensuring that all BD directories are wiped. Then reinstall. This didn't work, and remains a thorn in my side. I'm planning not to renew BitDef when the renewal comes up this time, as this problem has been ongoing to 2 years now, despite new versions of Bit Def / MacOS / Parallels.

  • I had this same problem in mid 2020 of Parallels Desktop repeatedly being automatically removed from the "Application Access" list. I contacted BD Support who advised the following (as I remember it, unfortunately I no longer have the email from BD Support)

    1. Enter Parallels Desktop in Application Access and set permissions from Blocked to Allowed.
    2. Manually delete Parallels Desktop from Application Access.
    3. Re-enter Parallels Desktop in Application Access and set permissions from Blocked to Allowed.
    4. I followed these steps and have not since had a single incident of Parallels Desktop being removed from my Application Access list. Seems kind of weird but it worked, let me know if it works for you.
  • Further to the above, the actual response from BD Support is posted below, I followed their direction and no more issues.



    On 18th Aug 2020 at 8:58 am, Roxana Grecu wrote:

    The reported behavior is encountered primarily when an application is updated, reinstalled or otherwise has a process that is executed from an unsigned binary inside its app bundle.

    Please proceed with the workaround below:

    - click on the Bitdefender icon from the Menu Bar and then on Open Main Window

    - click on Protection from the side-menu

    - click on the Anti-Ransomware tab and then on Application Access

    - click on + to manually add Parallels and set it to "Allowed" and click OK

    - reopen the Application Access list and delete Parallels by clicking on the - button and then OK

    - reopen Application Access a third time, add Parallels, set it to Allowed and click OK

    Let me know how it goes.

    Have a great day ahead!

    Best regards,

    Roxana G.

    Senior Technical Support Engineer

  • CoreyC
    edited May 2021
    Thanks Lester,
    That worked for me.
    I think that I unknowing denied access for an older version of Parallels when the prompt popped up. After updating parallels, the older version no longer appeared on the Allowed Apps list. But, making assumptions, I suspect it was still in the Bitdefender settings files and causing problems allowing the new version of Parallels in the same file location. By clicking (-) to remove it, it probably removes the old, hidden entry from the list, then you can create a new entry without issue.