[solved] Uploading Taking Twice As Long With Bitdefender 2010

Options

BD product: BD 2010 - Trial


OS: Win XP Home


Hi


I am currently trialing DB 2010 (after uninstalling Zone Alarm pro after several years) as I am looking for a more reliable firewall.


However, since installing BD 2010 trial, I am now having problems when uploading to my file host account. I am using Rapidshare Manager to upload, but uploads are interupted aprox every 30 seconds by Bit Defender for 30 seconds at a time (aprox), so my uploads take twice as long to complete as they did prior to installing BD.


So here is the current scenario:


  • RS Manager is open, and is uploading a file. The max upload speed is set at 64kbps.
  • The file is uploading fine at around 64 kbps - but only for 30 seconds
  • After 30 seconds the file stops uploading (upload speed is 0 kbps)
  • Whilst the file is stopped, in Bit Defender 2010 Firewall under 'Settings' it is showing Outgoing around 65-70kbps (my max upload speed) - this lasts for about 30 seconds, then drops back to 0 kbps
  • Whilst Bit Defender 2010 is showing Outgoing traffic of 66-70 kbps, my RapidShare Manager upload speed is 0kbps
  • Whilst Bit Defender 2010 is showing Outgoing traffic of 0 kbps, my RapidShare Manager upload speed is 64 kbps


So you see, my uploads start for aprox 30 seconds, then stop for aprox 30 seconds, then start again for 30 seconds, then stop, etc, etc. and files are taking twice as long to upload.


  • I have found that if I lower my upload speed in RS Manager to, say, 32 kbps, uploads are still interupted every 30 seconds, and Bit Defender 2010 still shows Outgoing at aprox 66-70 kbps, but for just around 15 seconds at a time (during which time my RS Manager upload again drops to 0 kbps for about 15 seconds, before resuming at 32 kbps for 30 seconds).


I would appreciate any advice on how to resolve this :huh:


Many thanks in advance


Dave :)

Comments

  • Alex Stanciu
    Options

    Hello Dave,


    Try the steps bellow and let us know what happened :


    1. Open BitDefender, click on the Settings button and choose the Expert Mode .


    2. Click on the Firewall module and disable it temporarily.


    3. Test to see if you have the same issues.


    4. If everything is working as it should, please re-enable the Firewall and under the Settings tab, click on the Advanced Settings button and uncheck the "Intrusion detection System " option then click on Ok.


    5. Now, click on the Network tab, and set your local adapter Trust Level to Trusted Local, Stealth to Off and Generic to Yes .


    6. Click on the Rules tab, select the Advanced button from the right and make sure that the process that belongs to Rapidshare Manager are set to Allow .


    7. Test to see if the same issue occurs.


    We are looking forward to your reply .


    Thank you.

  • Hi,


    The problem happens because of BitDefender's http filter module.


    You have 2 options: either you disable RS Manager's upload limit or you exclude RS Manager from http filtering.


    For the second option:


    - open regedit and create a value in "HKEY_LOCAL_MACHINE\SOFTWARE\BitDefender" named "HttpAppSkip" and with type "Multi-String Value"


    - edit the value and set it's data to the complete path of the program(s) you want to exclude from http scanning completely (you can have multiple entries)


    - reboot

  • Dave1972
    edited October 2009
    Options

    @ Alex Stanciu: Thanks for your reply. I disabled the firewall temporarily, and surprisingly exactly the same thing happened - it uploads for about 30 seconds, then freezes for about 30 seconds, then starts again.


    Any ideas? :huh:


    @ Berneanu Cristian: Thanks also for your reply. But I already tried disabling the upload max speed limit (that's how I always had it when I used Zone Alarm, and never had a problem before) but now if I do that, it just freezes permanently - it also displays an upload speed of about 125kbps (twice what my natural speed is) but it just freezes until I set it back to 64 kbps.


    As for your 'second option' - I'm sorry, I don't understand (I'm a bit stupid I guess!). I wouldn't know how to open 'regedit' or 'create a value' or anything else you said - I need simple English instructions, sorry. I'll wait and see if Alex agrees with your advice - but I do appreciate your time :)

  • alexcrist
    alexcrist
    edited October 2009
    Options

    Hello Dave1972,


    The suggestion made by Berneanu Cristian is worth trying.


    In simple terms:


    • First of all, save these instructions in your PC.
    • Then restart your computer in SafeMode (restart your system, and while it's booting press F8 multiple times, until the Boot Menu appears. There, select Safe Mode and press Enter).
    • After the system boot_s up in Safe Mode, a message will appear asking you if you want to continue (Yes), or make a System Restore (No). Press Yes, to start normally.
    • go to Start -> Run, type regedit and press OK

    • Registry Editor will open, and you'll see an Explorer-like interface (the "folders" on the left are called keys, the "files" on the right are called values)
    • as you'd browse in Explorer, go to this key:
    HKEY_LOCAL_MACHINE\SOFTWARE\BitDefender

    and select it.

    • to create a new value, right click on the right panel (where you can see the values), and select New -> Multi-String Value from the menu, and name it HttpAppSkip
    • After that, double click the newly created value. A popup window will appear, where you can set the Value data of that value. There type the full path of the application that you want to exclude, in your case, RC Manager's path (path+filename of the executable).
    • Click OK, close Registry Editor, and reboot your system normally (just choose Restart)
    After the system starts, test to see if the problem persists and post back the result.


    Cris.

  • Dave1972
    edited October 2009
    Options

    :D


    Thank you Cris so much for your VERY clear instructions!!! And thank you Berneanu Cristian for your original suggestions, and to Alex too! :)


    Cris, your instructions worked perfectly. Rapidshare Manager is now uploading fine, and not pausing every 30 seconds, and I can now also set the upload speed to 'Max' and it doesn't freeze!


    Many thanks - I am now sure I will purchase a subscription of BT 2010.


    Maybe a fix can be implemented into BT2010 so that others don't have the same problem, but I'm happy now.


    Kindest regards


    Dave :)

  • alexcrist
    Options

    I'm very glad it worked out, Dave. :)


    Since this issue is solved, I will close this topic. If you need it reopened, just let me know by PM.


    Cris.


    == CLOSED ==


    == Issue solved ==

This discussion has been closed.