Samba Ports On Linux Nas Getting Blocked

In my home network I have a Linux raid NAS for backup purpose, running on vmware virtual machine in a Windows 7 host. Unfortunately, from my Windows 7 host, with BitDefender 2010 Firewall enabled, I cannot acces the samba share of the NAS.

Considering that if I disable the BitDefender firewall everything works well (i.e. I can see and access the samba share), I have been trying playing with the settings of the firewall (allowing almost everything) but in no way I have been able to allow this particular traffic.

This look very strange, since no matter how I allow traffic I still can't see the share on the network. I'm wondering if the firewall is blocking the traffic out from Windows 7 to samba or the packets IN versus the vmware virtual server. The log is not telling too much.

Of course opening SMB ports (plus also the 137-139) simply does not work.

I have been trying also removing completely ALL the rules, put the firewall on "report"mode, and allowing everyting is being asked. No luck even in this way.

I'm loosing my hope so I'm wondering if anyone has the same problem, or if can be of any help.

Thanks in advance,



  • Have you tried turning stealth mode off?

  • Have you tried turning stealth mode off?

    Yes, the stealth mode is off, for all the adapters (the Win7 network card and the two virtual adapted of vmware).

    I tried another thing, adding a second computer on the network (a macbook pro). Things are the following (with the bitdefender firewall active on the Windows 7 machine, host of the linux raid virtual machine):

    1) Windows7 can access the shares of the MBP

    2) MBP can access the shares of Windows 7

    3) MBP can access the shares of the Linux raid

    So BitDefender is not blocking the traffic toward the virtual adapters of vmware, and neither is blocking the Windows 7 traffic versus the MBP. But somehow I can't see the samba share of Ubuntu from Win7. Maybe it has something to do with the fact that Windows 7 is host of the Ubuntu virtual machine?

    Thanks anyway for your email,


  • cberneanu
    edited February 2010

    Is your virtual machine in NAT or bridge mode?

    If you enable the "Increase log verbosity" option, do you see the blocked packets in the log?

    Do you have ICS enabled in the firewall?

  • Is your virtual machine in NAT or bridge mode?

    If you enable the "Increase log verbosity" option, do you see the blocked packets in the log?

    Do you have ICS enabled in the firewall?

    - The virtual machine is in bridge mode, so its IP is in the same subnetwork of Win 7.

    - The log (with enhanced verbosity) has a strange behaviour. With the rules set to default, I get this message:

    2010/02/06 00:20:40.264 [bDFW] [FILTER] Blocked packet because of rule 25. Direction: Outbound, Local Address: FE80:0000:0000:0000:7525:15B6:BDA8:28CD-65357, Remote Address: FF02:0000:0000:0000:0000:0000:0000:000C-1900, Protocol: 17, Local Packet: 0, PID: 00000000000007B4, Process: c:\windows\system32\svchost.exe, Cmd. Line: -k localserviceandnoimpersonation.

    The rule 25 is the last in priority for svchost.exe (the one that blocks everything). If I "allow everything" in this rule, then try to access againg the samba share, and then check the log again, there are no events reported (but I cant still access the VM).

    If I put a rule before that allowing traffic on ports SMB, 137-139, nothing happens

    - Finally, I have tried to enable and disable ICS but with no difference.

    If you would like to try to reproduce this thing, I followed pretty much this sequence of steps:

    1) install windows 7 x64

    2) install vmware server

    3) install Ubuntu server 9.10 64bit (no desktop, just the pure server) on a VM

    4) install samba on ubuntu

    5) share a folder

    Everything is up to date (latest release).



  • I guess there are no solutions to this problem, right?

    I understand that the setup is quite uncommon, but a firewall should work in any case.

    My only possible work around solutionis to disable the BT Firewall and re-enable the Windows 7 embedded firewall (which, instead, does not block my ubuntu share).

    Any word from the tech support?