VPN fails to reconnect after sleep while Kill Switch is active

Options
solus
solus
edited July 3 in VPN

My Windows 10 Pro (22H2) laptop is often slept while connected to Wi-Fi and Bitdefender VPN with Kill Switch active. When the computer wakes, the system automatically reconnects to Wi-Fi, but there's no internet. Cool. The Kill Switch works.

The problem is that Bitdefender VPN fails to reconnect. It tries and fails. When I manually attempt to connect to VPN, it consistently fails unless I first disable the Internet Kill Switch. After the Kill Switch is disabled, VPN connects without issue.

What's going on here? The VPN should be able to reconnect while its own Kill Switch is active. I shouldn't have to disable it for the VPN to connect. During this window, when the Kill Switch is disabled and before the VPN connects, lots of internet traffic gets through. This isn't secure, and it happens EVERY SINGLE TIME I wake my computer from sleep.

To make this situation more painful, it's a multi-step process to disable the Kill Switch from the main VPN screen but only two click to enable the Kill Switch from there. To disable, I have to go into VPN Settings, click Privacy, and then toggle the Kill Switch off and then back out of that screen just to manually reconnect the VPN. Once the VPN is connected, I just have to click the "Activate Kill Switch" button at the lower-right corner of the screen to access the Kill Switch toggle. The UX should be simplified here by just making that button on the main screen toggle the Kill Switch feature on/off. Why provide a faster way to enable the feature, but require more effort to disable it?