Firewall Blocks Quickbooks

I have QuickBooks Pro 2009 installed on both of my computers with the desktop as QB host. The firewall on the desktop blocks my access to QB on it from my laptop. How do I allow QB commnications?


  • Here's a few things that you can try:

    - Go to Advanced View, then to Firewall, click on Advanced settings and make sure "Intrusion detection system" is unchecked and also uncheck "Block port scan".

    - Next browse to Network and look for the adapter that connects these two machines - set the trust level to Trusted Local, Stealth to "No" and Generic to "Yes". In the Zones part of the window add using the "+" button the IP address of the laptop that is trying to connect.

    - In the Rules section look for the rule created for QuickBooks Pro - click on Advanced and move that rule to the top of the list.

    Let me know if these changes had any effect.