Bitdefender Av 2013: Hide Extensions For Known Files. Help!

Hi, I have a problem with BitDefender AV 2013

I don't like to see the extension of the files, so that I have gone into Control Panel/Folder Option Hide and I have enable the box "hide extensions for known files". Everithing is ok but after some minutes I see the extension of files again. I'm getting a compulsive disorder for it because I have to make that operation many times every day. I also have formatted my hard drive but I'm getting always the same problem. Do I have to replace BitDefender with another AV or can I solve this problem? How can I solve it, please?

Thanks for your precious info.


  • Hello FoxAdriano,

    Could you please please post here a support tool log to see what is wrong with the computer?

    If the files are too big to attach, upload them on or

    and post the download link.

    If you were already asked to generate these logs, disregard the above message and just post the ticket ID.

    Thank you.

  • Hi

    i'm recently moved from eset smart security 6 to bitdefender Internet Security 2013

    I have the same problem with IS 2013

    the extensions for known files always showing and there is nothing that i can do for not showing them!!!

    I'm really getting tired of this.

    please help me as soon as possible

    this is my log, i uploaded it on

  • is there anybody here to help me?!

  • is there anybody here to help me?!

    Looking at BitDefender for my machines based on the positive review in AvTest, but also having this issue - click on Hide check box, and immediately set back to unset! Not good as an Av product looks like it behaving like a virus (albeit fairly innocuous) so I don't know what else it might be doing. Given how long since it was reported in the forums, BitDefender is not looking a good option and maybe I'll go back to looking at Kaspersky or ESET or (and I am surprised to say it) Symantec!

  • Actually, it is highly recommended to untick 'hide extensions for known file types'.

    Just for clarity and not in any way to be considered a product comparison, Kaspersky recommend as part of the vulnerability scan to show the hidden extensions.

    The reason being, malware can often attribute a second file extension for example 'holidaysnap.jpg.exe'. it could be any file though. the computer would show only the holidaysnap.jpg with that setting enabled. so the likelihood of running a hidden executable is increased if you can't see what the file really is.

    Granted any decent antivirus should detect the file and quarantine it, however as malware is a constantly evolving beast no antivirus package can be guaranteed to be 100% effective 24/7 even though they do their best to keep up with threats.

  • Hi

    I have the same problem with bitdefender internet security2014 on windows 8. I had norton internet security on my computer and there is no problem.I moved to bitdefender and After a while the extensions for known files always showing.

    I had the same problem with bitdefender internet security 2013 on windows 7 four months ago. I think bitdefender should really do something about this issue. because it really makes users crazy.

  • hello to all

    because of this ridiculous bug that still exists ( /index.php?/topic/53166-hide-extensions-for-known-files/" rel="">  ) and there is no patch for this , I switched to Kaspersky instead of bitdefender and all of my problems solved .

    I'm sorry bitdefender , you have lost one of your most loyal users , i used your product since 2010 but with this bug....i'm so sorry.  

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.