Kindly be advised we cannot cancel subscriptions or issue refunds on the forum.
You may cancel your Bitdefender subscription from Bitdefender Central or by contacting Customer Support at:

Thank you for your understanding.

Outdated Iso Means No Lan With Asrock Mobo

edited February 2022 in The Archive

Hey, guys! :)

I just love the BitDefender Rescue CD so I carry it with me. The thing is the kernel is way too old for some on-board ethernet to work. Here's the full lspci of an unsupported chip I found on a mainboard dated from 2011 if I recall correctly:

02:00.0 Ethernet controller [0200]: Attansic Technology Corp. Device [1969:2062] (rev c1)

Subsystem: ASRock Incorporation Device [1849:2062]

Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-

Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-

Latency: 0, Cache Line Size: 64 bytes

Interrupt: pin A routed to IRQ 5

Region 0: Memory at fe400000 (64-bit, non-prefetchable)

Region 2: I/O ports at e000

Capabilities: [40] Power Management version 3

Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0+,D1+,D2+,D3hot+,D3cold+)

Status: D0 PME-Enable- DSel=0 DScale=0 PME-

Capabilities: [48] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-

Address: 0000000000000000 Data: 0000

Capabilities: [58] Express (v1) Endpoint, MSI 00

DevCap: MaxPayload 4096 bytes, PhantFunc 0, Latency L0s unlimited, L1 unlimited

ExtTag- AttnBtn+ AttnInd+ PwrInd+ RBE+ FLReset-

DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-

RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-

MaxPayload 128 bytes, MaxReadReq 512 bytes

DevSta: CorrErr- UncorrErr+ FatalErr- UnsuppReq+ AuxPwr+ TransPend-

LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 unlimited, L1 unlimited

ClockPM+ Suprise- LLActRep- BwNot-

LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+

ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-

LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-

Capabilities: [6c] Vital Product Data <?>

Capabilities: [100] Advanced Error Reporting <?>

Capabilities: [180] Device Serial Number ff-22-25-00-79-83-ae-ff

The lspci dump is rather uselss considering newer versions of the Linux kernel allow this on-board ethernet chip to work, but... just so you know.

Also for the record:

mint@mint ~ $ inxi -SMNx

System: Host: mint Kernel: 3.2.0-4-486 i686 (32 bit, gcc: 4.6.3) Desktop: MATE 1.4.0 Distro: LinuxMint 1 debian

Machine: Mobo: ASRock model: H61M-S Bios: American Megatrends version: P1.10 date: 03/07/2011

Network: Card: Atheros AR8152 v2.0 Fast Ethernet driver: atl1c ver: port: e000 bus-ID: 02:00.0

Now for the second part of my BitDefender off-road adventure, I booted
LMDE 201303 and installed Bitdefender Scanner for Unices. I logged out and back in, started "BitDefender Scanner" and after I configured the scanner I ran the update and waited for it to finish. Then I don't know what happend. :P The thing is I closed the GUI.

I started the GUI back, but it kept saying "engines not loaded". I closed it and started again - the same. Then I checked for free space (df -h) because I was on a live-cd(usb actually) session and after all those updates I was curious if the update didn't fill the free space on the root mount. Nope, not the case - over 500MB free and over 600MB free after
apt-get clean. Then I checked if there's another bdgui session open (ps) but also not the case. After this, I ran bdgui from the terminal and clicked "Scan": Segmentation fault. Dang!

Then I though I should look for parameters so I ran "bdgui --help". Interestingly, I found out bdgui tried to scan "--help".
Niiice, I said. So I mounted my target partition and ran "bdgui /media/" and completed the scan. Yaaay! :)

Well... I expected two things:

1. bdgui to simply work

2. bdgui to look the same as the scanner from the BitDefender Rescue CD

Looking at the dates (and also knowing BitDefender), bdgui is older, so I guess it's not exactly worth updating the ISO with this version. However, the ISO should be refreshed with a newer Ubuntu base, because that one is "ancient". It runs great, but it's way too old and newer hardware (eth) are not supported, and networking is essential for virus database updates. You might as well make it easier to update offline by not having to get some zip and unpack it somewhere as root, in the terminal. I can handle that, but most people would avoid trying such procedures and it's a pity such a nice tool to be ditched just because of some missing drivers and/or ease of use.

Pretty please build a new rescue environment.
:) And thanks for the current one. When it works, it works great. :D