Kindly be advised we cannot cancel subscriptions or issue refunds on the forum.
You may cancel your Bitdefender subscription from Bitdefender Central or by contacting Customer Support at:

Thank you for your understanding.

I Can't Boot Bitdefender Rescue Cd .iso Image With Grub4dos

edited February 2022 in The Archive


I have a flash drive that through the boot manager Grub4dos allows me to boot in a simple way multiple operating systems and tools from their .iso images of their Live versions ( or boot CD ) , which not only saves me the cost of burning CD 's or DVD's but also allows me to boot netbooks without CD or DVD drive .

I downloaded the BitDefender Rescue CD .iso image, but I can not boot it in the same way as the other operating systems.

The CD's or DVD's that have a boot menu usually use isolinux, which is often difficult to boot with Grub4dos (with notable exceptions such as Slitaz and Super Grub 2), which I find very comfortable for a multiboot flash drive , because once the pendrive is bootable , you only need two files: grldr ( bootloader ) and menu.lst a plain text menu, easily editable.

Usually I first test if the isolinux is Grub4dos friendly to boot as Slitaz , and it can boot with a few simple instructions , find the iso , mapping , hook and chainloader :

title SliTaz 4.0 Lnx 32b

find --set-root /boot-isos/slitaz-4.0.iso

map --heads=0 --sectors-per-track=0 /boot-isos/slitaz-4.0.iso (hd32)

map --hook

chainloader (hd32)

Most of the time, it does not work, as is the case with BitDefender Rescue CD . So I bypass the isolinux menu following the path of the instructions in the file isolinux.cfg in the folder isolinux. In this case, I take the instructions to boot BitDefender Live in Spanish and adapt them to the syntax of grub4dos:

title Bitdefender Rescue CD Lnx 32b

find --set-root /boot-isos/bitdefender-rescue-cd.iso

map --mem /boot-isos/bitdefender-rescue-cd.iso (0xff)

map --hook

root (0xff)

kernel /casper/vmlinuz file=/cdrom/preseed/ubuntu.seed boot=casper persistent splash vga=normal lang=es iso-scan/filename=/boot-isos/bitdefender-rescue-cd.iso floppy.allowed_drive_mask=0 cdrom-detect/try-usb=true locale=es_ES bootkbd=es console-setup/layoutcode=es

initrd /casper/initrd.gz


It does not work. Taking in account that this is an Ubuntu based distro I tried many other Ubuntu configurations. None worked.

I think the problem may be in the parameter file file=/cdrom/preseed/ubuntu.seed because this file does not exist in the .iso ( or the CD , if I burn it), nor a preseed folder . I tried removing that parameter in the kernel command line. It did not work.

Any idea?

Best regards.


  • bogdanh
    edited November 2013

    Before anything else, have you given unetbootin and LinuxLiveUsb a try ? I know these work with the Bitdefender RescueCD iso (using Karmic Koala as a preset). Maybe you can figure out what modifications LinuxLiveUsb does when writing the image to usb and apply them to grub4dos ?

    Our Total Security suite also has Rescue Mode which is automatically installed along with grldr and a cfg file, and added to the BCD store/boot.ini when you install our product. Rescue Mode only has an on-demand av scanner and a browser which may or may not suit your needs.

  • Before anything else, have you given unetbootin and LinuxLiveUsb a try ? I

    Thank you, Bogdan.

    Sorry about the delay.

    I've used unetbootin some years ago, and it's a great software, but I want try something else this time because the first thing that it does is formatting my flash drive. So, I'd need to back up my files first and then restore them later, and since solid state memories have a limited lifetime, a limited number of read/write operations, formatting them often is not a good idea.

    After some little research, I remastered the Bitdefender Rescue CD including in it a preseed folder "transplanted" from an Ubuntu iso, in order to test my guessing that the lack of this folder is the problem.

    I didn't work.

  • I copy the iso file in my pendrive, partition 8.


    title Bitdefender Antivirus

    map (hd0,7)/bitdefender-rescue-cd.iso (hd32)

    map --hook

    root (hd32)

    chainloader (hd32)



    Note (hd0,7) not (hd0,8)

    This boot ok with grub2dos-0.4.4

  • I copy the iso file in my pendrive, partition 8.

    Thank you, kilowog, but it doesn't work for me.

    It finds the iso, isolinux shows me the menu, I choose Start in Spanish (if I choose the default English, the result is the same), it starts to load the operating system, after 10 seconds it starts to search the iso. It fails, and after a couple of minutes, it says:

    BusyBox: Unable to find a medium containing a live file system.

    If it works for you but not for me, it may be because mine is in a removable USB drive, instead of the hard disk.

    I've already tried this kind of setting before I started this tread, as I already sated.

  • Good news:

    Since I couldn't progress with Bitdefender, I decided give a second chance to Avira. Some years ago, I unsuccessfully tried to boot Avira from its iso. Afters several tries, I gave up. "Self-test failed". Many users also complained about the same in the Avira Forum, but there wasn't any answer. Now they have updated their system. It's based on Ubuntu now, as Bitdefender is. So, I had to search the web for the Grub4dos settings to boot Avira's iso.

    Fortunately, a clever German guy found out a solution. I tried it and it worked, so, since Bitdefender is also based on Ubuntu, I adapted it to Bitdefender. Besides of the name of the iso (and the language suffixes de, from Deutsch, German, by the suffixes es, from Español, Spanish), I replaced initrd.lz by initrd.gz in the initrd line. And it worked.

    So this is my working Grub4dos settings:

    title Bitdefender Rescue CD Lnx32

    map /boot-isos/bitdefender-rescue-cd.iso (0xff)||map --mem /boot-isos/bitdefender-rescue-cd.iso (0xff)

    map --hook

    root (0xff)

    kernel /casper/vmlinuz file=/cdrom/preseed/ubuntu.seed boot=casper iso-scan/filename=/boot-isos/bitdefender-rescue-cd.iso -- debian-installer/language=es console-setup/layoutcode=es

    initrd /casper/initrd.gz

    Say thanks to the German Avira Support.

    Besides it is mapped to memory (maybe this is the key), I still can't see much difference with the other settings that I tried before to start this tread, when I skipped the isolinux menu after the kilowog (or Slitaz) style settings failed.

    Maybe your can spread the word and add this to the techs notes, for support.

    Now I only have to find out how to mark this tread as SOLVED.

    One more thing, off-topic. No matter how much I tried, I couldn't enable the checkbox to agree to the license terms. Left-click, right-click, space-bar, enter, escape key, nothing worked.

    Best regards.