Kindly be advised we cannot cancel subscriptions or issue refunds on the forum.
You may cancel your Bitdefender subscription from Bitdefender Central or by contacting Customer Support at: https://www.bitdefender.com/consumer/support/help/

Thank you for your understanding.

Firewall Is Blocking Ftp Via Windows Explorer

Options

I am using Windows 10 and Bitdefender Total Security 2016.


Even I set the rule "Windows Explorer traffic on FTP" to allow, it still doesn't work.


I have to turn the firewall off, or set the network type of adapter to Trusted. But obviously neither is a good choice because the real network type is Public.


Any solution?

Comments

  • PDP
    Options

    I have found a solution to this problem that works for me:

    As explained by Bitdefender in another thread, the issue seems to be that Windows Explorer by default uses a different port every time to connect to FTP servers ("passive" FTP). So they would have to allow all ports for Explorer, but that isn't a good idea from a security perspective because malware could inject itself into the Explorer process and use it for undetected communications.

    The solution therefore is to force Explorer to only use the traditional standard FTP ports (so-called "active" FTP). This is done as follows:

    1. Open Internet Explorer (yes, Internet Explorer - Windows Explorer uses those settings under the hood)

    2. Go to Tools - Internet Settings - Advanced

    3. Locate the setting called "Use passive FTP" and uncheck it

    4. Click OK and close IE

    After I did this, FTP access from Windows Explorer worked perfectly (provided that the "Windows Explorer traffic on FTP" rule in Bitdefender is set to Allow).

    NB: There may still be issues if your network environment is configured in a way that does not allow active FTP, for example, due to hardware firewall settings. In that case, please contact your network admin, my knowledge on that is far too limited so I won't be able to help you.