Kindly be advised we cannot cancel subscriptions or issue refunds on the forum.
You may cancel your Bitdefender subscription from Bitdefender Central or by contacting Customer Support at:

Thank you for your understanding.

Page Don't Load In Safepay



I use Microsoft Edge as browser, I also tried Google Chroome. I go to my Bank, Bitdefender says:

use Paysafe for Banks. I comfirm. The lay-out paysafe appears and the url of the bank also appears, even the icon of the bank, but the page online banking don't load. Suggestions? Other banks don't work. Who knows?


  • Sorin G.

    Hello DirkVanWaasland,

    Please provide me with the URL of the bank.

  • Sorin G.

    I was able to open the page in SafePay without any issues.

    Please tell me what Bitdefender version and build are you using ? You can locate the build by right clicking on the system tray icon and selecting About.

  • hello, again.

    Bitdefender Total Security 2016


  • Hello, It has worked earlier. A week ago safepay did not. At the moment it works again. I will keep you in touch. Thx

  • Sorin G.

    Glad to hear that it has started working again.

    Should anything happen the Topic is still opened.

  • IrisB


    I am replying to this topic because I've been having this issue for a few weeks now. It magically resolved itself for a while, but now it's back. When Safepay opens it loads the website and according to the url bar the website is opened. However, the screen remains white. I've tried turning off hardware acceleration like I read in a similar topic, but the only thing that happens then is that the screen goes black instead of white.

    I am using Firefox 47.0.1 as a browser and Bitdefender Total Security 2016 version (OS is Windows 10 64-bit) . I've also checked if with Chrome, but that doesn't make a difference.

    Websites I tried to open were and

    Thanks in advance for any answers on / solutions for this issue.

  • Sorin G.
    Sorin G.
    edited July 2016


    It would seem you are using an older version of the product.

    Please follow the steps in the article bellow to reinstall the product and ensure you install the latest build.

    I was able to open both of the websites properly using TS 2016

  • The problem seems resolved. No more problems, it works always. Great!