WiFi problem since I installed BF Total Security 2018

Alright, I need help you guys, cause this is driving me insane.

I recently purchased and installed BitDefender Total Security 2018 on my laptop, and it might be a simple coincidence, but I've had WiFi problems eversince. Typically, I can surf on the net for 5-6 hours straight, without any problem...and then, I usually get a Windows 10 notice, something about 'print & scan' not being available (printer is on WiFi as well). As soon as that happens, I know I'm done. Windows 10 still shows my connection as being 'connected and secured', even if I go to the network setting page, but I have no access to internet what-so-ever. Not on Chrome, which I usually use, nor Edge, nor Firefox, nor Thunderbird for my emails...nothing.

I've called my ISP, and ran a couple of tests with them, and the signal appears to go through. Also worth noting that my other CPU (Mac in my room, which doesn't have BitDefender on) or my cell don't have that problem. Even when my laptop does.

I've three full scans with BitDefender in the last week on my laptop, and didn't find anything. Tried to turn BitDefender's firewall off...the same problem happened.

So basically, everytime that happens...I have to go to the 'status' screen of my windows 'network settings', and reset the whole network...that's the only way to get my internet back, each time.

Now, I'm still not sure this is a BitDefender issue...all I know is that installing BitDefender is the only change I've made for quite awhile before the problem started to appear. But it might also be hardware related. I just wanted to know if any of you had an idea, before I go spend money on some new hardware.

Thanks to anyone who will help ! :)


  • Just to get some further information on this: What does the Wi-Fi Security Advisor show your network connection as - Home or Public ?  (To view this go to the main screen > Protection features > Vulnerability > Wi-Fi Security Advisor).

    Also, what is the Network Adapter setting ( Protection features > Firewall settings [gear icon] > Network Adapters )?


  • KomicJ
    edited July 2017

    Wi-Fi Security Advisor was set to 'Public'...I just changed it to 'Home' after reading your post.

    Network Adapter settings used to be 'Public', but I changed it to 'Home' after reading about it in another topic, earlier today. The problem presisted however, as I've lost my internet since.

    Any chance changing my Security Advisor to 'Home' would solve the issue ?

  • Hello,


    Please let me know what Bitdefender build you are running on your machine.



  • 23 hours ago, Sorin G. said:



    Please let me know what Bitdefender build you are running on your machine.



    It appears to be

    As for the operating system, I'm running Window 10, version 1607, Os Build 14393.1480

    As for Google Chrome (in case it's relevant), I'm using Version 60.0.3112.78 (Official Build) (64-bit).


    For what it's worth, changing it from 'Public' to 'Home' doesn't appear to have solved the issue... :/

  • Hello,


    Please use the reinstall feature from Control Panel (similar to the old repair).

    Control Panel > Applications and Features >  click on Bitdefender and select Uninstall, afterwards you will receive a prompt to Reinstall or Uninstall. Ensure that you choose reinstall to deploy the 118 build.

  • Done.

    Hopefully, that will solve the problem. I'll let you know.

    Thanks for your input.

  • Update: So far so good, I think it solved my problem...more than 72 hours without any loss of connection. :)

    Thanks for your support ! Feel free to lock this topic, I'll create another one if needed. But I just wanted to take the time to say thanks. :)

This discussion has been closed.