Suspicious Connection Blocked

PAH707
edited January 2022 in General Topics

I get this message every day, every time I use the internet. I typically use Edge. Even when I go to Bitdefender. It is very annoying, and I can't seem to turn it off. Help please.


Best Answer

  • Alex_A
    Alex_A ✭✭✭
    edited December 2021 Answer ✓

    Heiio, @PAH707

    Kindly perform below steps & see if this helps you in anyway.

    1) Disconnect your computer's internet connection.

    2) Clear the cache of the browsers you have been using.

    3) Restart PC in safe mode (https://support.microsoft.com/en-in/help/12376/windows-10-start-your-pc-in-safe-mode)

    4) As soon as desktop opens, assuming your windows drive is C, open below things in run (windows icon + R) command one by one :

    temp ,delete all the files in the folder

    %temp% ,delete all the files in folder

    prefetch ,delete all the files in folder

    5) Restart your PC in general mode by unticking the option that you selected to run the system in safe mode and then click apply.

    Check if the problem recurs again.

    If the issue persists, kindly drop an email to bitdefender support at [email protected] or follow this link at the bottom of the page. https://www.bitdefender.com/consumer/support/

    You will be answered about the acceptance and solution of the problem.

    Have a good mood.

Answers

  • I have the same problem using Edge.

    msedge.exe attempted to establish a connection relying on an untrusted certificate to api.edgeoffer.microsoft.com. We blocked the connection to keep your data safe since untrusted certificates are issued by unrecognized Certificate Authorities.

    Started getting this message for about a month now.

  • How do we make it stop, so annoying. HELP!!!!

  • Hello, members!

    Can you please also nominate the websites for which you get this message?

    Cheers,

    Mike

    Intel Core i7-7700 @ 3.60Ghz, 64GB DDR4 || Gigabyte nVIDIA GeForce® GTX 1070 G1 8GB || WD Blue NAND 500GB + 1TB

  • Every website, it just popped up when I opened this. It is pervasive, I need to get rid of it. HELP

  • Alex_A
    Alex_A ✭✭✭

    Additionally, check your computer with some kind of antivirus scanners, in normal or safe mode.

  • Hello Alex_A

    I followed your instructions and got to step 4. I was at the DOS prompts and tried several things based on your instructions but I continued to get an error saying that whatever I typed was not recognized. I tried the words, run, delete, temp, etc, no luck.

    I then exited and am back to Windows. I think clearing the caches has solved the issue, as I haven't had it pop up yet. So even though I couldn't finish per your instructions I think I am "saved"!!!!!!

    I'll keep you posted but so far so good. 😀

  • I have the same issue by just opening the browsers without even connecting to any website. I don’t usually use Chrome, but I opened Chrome just because Bitdefender blocked FF. But by just opening Chrome, I got the “Suspicious connection blocked” message saying Chrome is blocked for establishing a connection relying on an unmatching security certificate to www.google.com. I almost never use Edge, and I opened it just to try. Now, Bitdefender says the same thing, but the “certificate to” address is changed to edge.microsoft.com. I got 74 notifications by just opening the browsers. My home wifi went down after this first happened. So half of those 74 notifications happened when the wifi is down. I wonder if the wifi disconnection is related, because it went down right after I started to get Bitdefender’s crazy number of notifications. What is going on?

  • Hi I am back, you will see I reported above back in December and I am not the only one. The warning returned within a day or two of thinking I solved the problem. Obviously I didn't fix it. Very frustrating. I should not have to delete per your instructions, I will try them again but honestly, you need to fix this.

  • It went nuts again today. So I disabled the web browsing safety related functions. Finally able to use my browsers. Feels like Bitdefender is having an allergy.

  • How do i disable the popup for this detection entirely? I'm not really concerned the app has successfully done its job. In fact, how do i disable all the popups; add a device, try this other feature, etc?

  • There doesn’t seem to be a way to turn this type of notification off. I disabled “Web attack prevention” in “Online Threat Prevention,” and it stopped the notifications. But of course, Bitdefender can’t protect us from web threats this way…oh well, it’s the only way I could use my web browsers though.

  • The same thing started happening to me in May 2022. but ONLY when I opened hotmail at https://outlook.live.com/mail/

    I close it and it keeps repeating 10 times or so before it goes away. really annoying. and it happens only with my hotmail account.

  • Hello @Mike Stewart and welcome to the Community!

    The “Suspicious connection blocked” notification is triggered by Bitdefender’s Online Threat Prevention module whenever there is an attempt to access an HTTPS domain that has security certificate issues. Unlike HTTP (Hypertext Transfer Protocol), HTTPS (safer HTTP Secure standard, HTTPS) is encrypted using Transport Layer Security (TLS), securing communications between your computer and the websites you visit.

    More information about this notification can be found here

    https://www.bitdefender.com/consumer/support/answer/2471/

    If the situation persists, you can add https://outlook.live.com/mail/ to the exceptions list by following these steps:

    https://www.bitdefender.com/consumer/support/answer/1519/#accordion-1-t1

    Let us know how it goes.

    Regards

    Premium Security & Bitdefender Endpoint Security Tools user

  • morfeas1000
    edited August 2022

    Hello. I have the same problem tens of times per day, notifying me "chrome.exe attempted to establish a connection relying on an unmatching security certificate to email.mail.ydata.eu" even though i am not at this site. I want to disable the notification but i dont want to disable the online security. How can i do that cause i dont find a way. I dont want to add the site as an exception also.. I DONT want to get notified that a program did its job, i want to focus on my work.

  • Gjoksi
    Gjoksi DEFENDER OF THE YEAR 2022 / DEFENDER OF THE MONTH ✭✭✭✭✭
    edited August 2022

    @morfeas1000

    Hello.

    Open your Bitdefender program, go to Utilities -> Profiles -> Settings and enable/activate "Work Profile" or "Game Profile".

    When "Work Profile" or "Game Profile" is enabled/activated, all Bitdefender alerts and pop-ups are disabled.

    And that is the only way to stop those pop-up notifications.

    Regards.

  • Hi,

    If you do not visit the website and you still receive these notifications, then your browser connects to it either through allowed notifications or toolbars/extensions. I suggest that you clear the cache & cookies, remove any unused/unknown extensions and if the issues persist, reset your browser. You can find these steps here:

    https://www.bitdefender.com/consumer/support/answer/2574/

    Let us know how it goes.

    Premium Security & Bitdefender Endpoint Security Tools user

  • Mike_BD
    Mike_BD admin
    edited August 2022

    Hello @morfeas1000 and welcome to our Community!

    In addition to what my fellows have already written, I assume you have updated your Bitdefender Total Security to the latest version - if not, please make sure you do, as we have implemented a throttling mechanism in the alerts that the user receives. This will not eliminate the root cause of your problem, however, as it seems you have a trojan in your system: Trojan.******.GenericKDZ.10321.

    So, my suggestion is to do an update for the antivirus, then do a full system scan, on all your drives.

    cheers,

    Mike

    Intel Core i7-7700 @ 3.60Ghz, 64GB DDR4 || Gigabyte nVIDIA GeForce® GTX 1070 G1 8GB || WD Blue NAND 500GB + 1TB

  • Hello there. I have updated to the latest version two days ago and still the notification remains. I have also scanned my system and nothing was found

  • Alexandru_BD
    Alexandru_BD admin
    edited August 2022

    Hi,

    There are 3 ways to fix this (not necessary in this order):

    1. Contact the Support Teams for assistance
    2. Disable Encrypted web scan (not a recommended action)
    3. Add the URL to exceptions for Online Threat Prevention

    Have you also followed the instructions sent above? (clear the cache & cookies, remove any unused/unknown extensions and reset your browser)

    Cheers

    Premium Security & Bitdefender Endpoint Security Tools user

  • morfeas1000
    edited August 2022

    Hi. No i havent cleared the cache and cookies and i dont want to reset my browser. I have many work related entries and many sites require a two factor authentication so i dont have the time to do that all over. In order to compensate for that, i have tried using another clean browser ( firefox ) and same thing happened, so i dont believe its browser related.

    I found threads that are two years old that request the same thing. To be able to completely turn off notifications and still no update has fixed this.

  • Hi @morfeas1000,

    Do you have the latest update 26.0.23.80 installed?

    This situation is caused by the fact that the website in the notification has an unmatching certificate. You may add the URL as an exception and the notification will no longer be displayed for this.

    Go to Protection - Online Threat Prevention - Manage Exceptions and enter the link there.

    If the antivirus detects an expired or unmatching certification or a possible vulnerability, it will continue to display notifications in this manner. Try to add exceptions for the most visited websites that trigger this type of notification, if you are absolutely certain they do not possess a threat. This should stop such notifications or reduce them considerably.

    With the latest update, our developers streamlined the pop-up messages and warnings, especially the ones that were stealing focus, to further improve the manner in which the product communicates with the user. But disabling the notifications related to the security of the device completely is not something I encourage.

    Regards

    Premium Security & Bitdefender Endpoint Security Tools user