File Shredder: Unable to delete file

edited November 2022 in Utilities


Running: Windows 10 ver 21H2 Os build 19044.2130

Previously I tried deleting this file using file shredder and it stated that file was either in use or that I didnt have permission to delete it.

Im not sure why or how but this file cannot be deleted using file shredder. I ran the computer in safe mode to get it into the recycling bin. Then hit the File shredder option and it gives me this error:

Thanks for helping me.



  • Hello @Thurgood and welcome to the Community!

    Try to run the command using the Bitdefender interface, instead of the contextual menu. Make sure to use admin rights, that's the key.

    Let us know if this works for you.


    Premium Security & Bitdefender Endpoint Security Tools user

  • How do you "make sure to use admin rights" when using this feature?

    I've tried shredded certain folders multiple times using the context menu option ("File Shredder") as well as the link under "Data Protection" in the main Bitdefender interface. The attempts always seem to result in a great number of files and folders failing to be shredded. The reason being, "Unable to delete" or "Unable to delete file: file not found".

    Affected files and folders are owned by the account I'm logged into and they are not flagged as read-only. The files are accessible via File Explorer. This situation occurs even after a fresh reboot. There appear to be no locks of said files/folders.

    What's going on here? Is there something I can do to specify admin rights should be enabled? These files and folders are just data files (images, source code, etc.) on a secondary partition. There are no files/folders flagged as system files. They aren't located on the system drive.

  • Actually, it appears the issue I'm experiencing has to do with hierarchy depth relative to

    Let's say I have folder paths of:


    When I add the following folder to File Shredder, it should shred everything under that folder recursively.


    Unfortunately, it seems like if the recursion depth it too high, the entirely folder seems to fail.

    The same goes for


    When I try shredding this, though, it then works and shreds all files under it:


    I can then shred:


    and ...


    and so on. So it seems like it only succeeds when the recursion is only a few levels deeper than what's added to the list using the "Add Items" button or drag-and-drop.

  • Hi @solus and thanks for providing more details regarding this.

    I will tag @camarie for an opinion here. If we cannot sort this out on the forum, it will be necessary to get in touch with the Support teams for further troubleshooting and advice. So you are using an admin account, yes?



    Premium Security & Bitdefender Endpoint Security Tools user