Virtual Machine Compatibility With Bitdefender

Ok, so I seem to have a major problem with Bitdefender atm that I'm hoping someone can create a solution for.


I'm trying to run an android virtual system (called Andyroid) using VirtualBox that requires VT-x to be available for usage. My system is VT-x enabled by default but, for some reason, the virtual machine would not work. Instead, I receive the following error:


25265e696392771a7a648dbf7149a918.png


At first, I had no idea what was causing this despite a lot of researching and I had eventually given up trying to use virtual machines on my system. This was back in mid 2014. Just recently, I decided to give it another try only to receive the same error message again. After having a bit of an epiphany as to the possible causes, I decided to see if Bitdefender uses VT-x or acts as a hypervisor in any way and, sure enough, it does.


I found some posts about adding VirtualBox's folder & the exe file as an excluded file in Bitdefender's Anti-virus but it had no affect. The error persisted. I contacted the team who's manages the android virtual system that I was trying to run and they gave me their take on the matter:


"Bitdefender antivirus uses Virtualization so other programs cannot, they also refuse to stop using it or add an exception if there is VM software installed or a toggle to temporarily stop using Virtualization."


"They prevent you from using virtualization entirely... We have tried to reach out to them, as we do every other company. They want to determine your security profile for you, versus you deciding what you want to use. There is NO workaround, and it really isn't andy. They stop virtualbox from running altogether, and that is what andy needs to boot."


Thinking about it as I type this, I have a feeling that this is also the reason why Bluestacks tells you that it will not install on a computer that has Bitdefender installed. I never knew why and the development team for Bluestacks has been forever mum about the matter but now I think that this is the reason.


Is there someway that I can still use Bitdefender 2015 (or any year's version for that matter) and still be able to use Virtual Machines again? I would rather not have to downgrade to a different company product since Bitdefender is still the most powerful consumer security suite on the market but it seems rather ridiculous that it should prevent me from being able to use any kind of virtualization software simply because it wants to use that system resource for itself.

Comments

  • I can't edit my previous post (not sure why that function is disabled for users) but I forgot to mention that I was using Bitdefender 2013 last year when I first tried it, 2014 when I came back to it earlier today, and then 2015 when I took that screenshot. The problem has persistent through 3 generations of Bitdefender software thus far. @[email protected]


    Everything is running on an Acer Aspire 7741G-6426 with Windows 7 Home Edition 64-bit.

  • I agree this is a pain. Oh, and a thumbs up to the original poster on the detail and clarity of reading for his post; has useful information for both tech and non-tech people and is readable by both.


    As Active Virus Control uses the hypervisor the only workaround is to disable Active Virus Control thus freeing the hypervisor.


    It's a shame that there isn't an option to disable Active Virus Control on start-up of specific applications/processes.


    A sticky for this would be good, as there are far too many posts about adding process exclusions to fix this issue... which does nothing.

  • I have this problem too, however it's with AMI DuOS. I had a work around before (http://amiduos.com/support/topic/duos-is-not-launched-after-installed-bitdefender-and-avast-antivirus-software), I wrote the last comment on the page (elfreakoxs) and it worked for a while. But since updating, it hasn't.


    I would really like it if Bitdefender could exclude folders or ignore applications, like mentioned above. I'm quite surprised that no one from Bitdefender has responded to this too.