Cant disable SLI because of BDagent


I have bitdefender total security 2017 running on my computer.  My computer has two Nvidia graphics cards connected by an SLI bridge. For some games, it is beneficial to disable SLI for better performance. This is done through the Nvidia control panel, but the control panel requires that bdagent.exe be turned off in order to reconfigure SLI. Because bdagent.exe is a protected process, the only way to terminate it and configure SLI is to log off, log back on, and configure SLI before the 150 second delay in Windows Task Scheduler expires and bdagent.exe starts again. 


Is there anyway to temporarily disable bdagent.exe and enable/disable SLI that doesn't involve the inconvenience of logging out then logging back in?

Tagged:

Comments


  • Amen.  Having the same problem.  Any resolution?

  • garioch7
    garioch7 Defender of the month ✭✭✭✭


    I have two GTX 580s in SLI and have been using Bitdefender for years.  I have no issues with BD interfering with setting up the SLI, which NVidia often turns off, for some reason, when installing an updated driver.  I just turn it back on.


    Where is the message originating that instructs you to turn off BDAgent?  More details would assist BD to determine if their software is the real issue.


    I have a January 2017 NVidia driver installed currently: 378.49.  I know that there is a more recent one, but I only update the video drivers every few months.


    Have a great day.


    Regards,

    -Phil

    Former Bleeping Computer Malware Response Instructor


  • @garioch7 - The message requesting that BDAgent.exe be turned off is coming directly from Nvidia Control Panel.  If programs are running that interfere with enabling/disabling SLI, Nvidia Control Panel will deploy a popup stating which applications are interfering with the switch-over and will wait until these applications are closed before enabling/disabling SLI.  Because BDAgent.exe cannot be terminated through the Task Manager like most other applications, the only solution I've found is to logoff and log back on before BDAgent.exe starts.  This solutions works, but is inconvenient.


    In my mind, the simple solution would be to allow a computer Admin (me in this case) disable or pause the BDAgent.exe front end.  I think this should leave all other BD background processes untouched.


    @redtide72 -  The only "solution" I've found is to logoff/logon and then toggle SLI.  You can also change the BDAgent.exe startup delay in Task Scheduler, but once the new delay time is crossed, you'd be in the same situation.


    For reference, I'm running two GTX 1080s in SLI (w/ EVGA HB SLI bridge--I don't know if this matters, but Nvidia Control Panel can tell the difference between bridge bandwidths) and powering a dual monitor setup on Windows 10 Professional.  I'm also running the latest drivers that dropped with the release of ME:  Andromeda (378.92).


    -Matt

  • Danilushka
    edited April 2017


    Matt,


    I have the same problem on Windows 10 and I could not find any delay set for the Bitdefender Agent binary.

    However, I (thought) solved it this way:


    Start Task Scheduler.

    Select Display All Running Tasks in the Actions panel.

    Select Bitdefender Agent and click on the End Task button in the lower right area of the panel.

    That seemed to have ended the Bitdefender agent tasks that could not be killed from Task Manager.

    At least for me.


    But I have to close Chrome to try. 


    I'll update this post if it works.


    --Danilushka


    UPDATE: Although Task Scheduler indicated the task was terminated, the Nvidia Control Panel insisted it was still active even if I restarted the panel.


    So I didn't bother to check if it was still running, I just logged out and back in and hurried to enable SLI. So far, that is the only solution.


  • In the older version of bit defender this wasnt a problem. But now whenever I wish to disable sli Nvidia control panel says I need to disable bdagent. BDagent cant be disabled in task manager so I disabled bdagent in task scheduler. Nvidia control panel still says its on. I NEED to shut off sli and if I cant find a solution soon its gonna be the uninstall button for bit defender. 


  • We all know you can't close bdagent.exe via Task Manager but I NEED to close it because I can't enable SLI with my two GTX 780's otherwise. Since updating the Nvidia drivers I had to re-enable SLI but I get a prompt to close bdagent.exe before it will enable. Well I can't close bdagent.exe can I? so I'm hoping someone knows of a way to close it manually. And no, no I can't do it in Safe Mode because the Nivida control panel doesn't work in Safe Mode.


  • Hi soopytwist!


    Have you tried turning off real time protection in BD?

     

  • Sorin G.
    Sorin G.
    edited April 2017


    Hello,


     


    Please update to the latest build 21.0.25.80 and reboot the machine.


    Changes where made to the BDAgent's functionality and should no longer cause this issue.


    Let me know if everything is okay now.