facebook linkedin twitter youtube instagram trustpilot

VPN premium on Android 11 - app issues

VPN premium on (latest app) with android 11. And I can't load my feed on Twitter. Only when I disconnect VPN it loads.

Until now I had to add 7 apps to split tunneling to have them work properly.

I don't thing this could be the way to work with premium VPN.

Checked all the propositions here, tried all the "solutions" that Bitdefender sent me... Nothing works, even some solutions are obsolete, standard answers that sometimes doesn' even apply to the problem I have.

This is a deal breaker, Not happy with VPN premium at all, slow connections, many interruptions too (only on Android 11) works fine in my Windows 11.

Comments

  • Hello @Dagoke and welcome to the Community!

    Your internet connectivity or the server distance you connect to may cause a slowdown. But to be sure this is the case, some logs would be required from you. If the VPN works fine on the windows device, clearly the actual VPN service is not to blame here.

    Have you also noticed any impact on your device’s performance and battery autonomy, apart from the slowdown?

    If you haven't found an explanation nor solution to the issue you are encountering, I would recommend contacting the Technical Support Teams, as more information might be required to troubleshoot this and the engineers can take a closer look.

    In regards to interruptions, first it must be determined if these are not related to this expected behavior here:

    You can get in touch with our engineers by choosing one of the contact methods available here:

    https://www.bitdefender.com/consumer/support/

    Stay safe.

  • I agree there is a problem with Bitdefender VPN. It doesn't work with my Windows 11 Pro on my Dell laptop. I tried all the suggested solution without success. I'm in no hurry to use it so I'm waiting for someone to document and report it.

  • Hello @TedCres,

    What are the symptoms of the connection? Does the problem occur on a specific location or all locations? Have you tried multiple WI-FI connections? What is the VPN Server IP displayed? Do you get any error messages at all?

    What are the steps/suggestions you have tried so far?

    Regards