BD Mobile Security: Scam Alert And Anti-Theft Both Turned Off. Any Help?

Options
ChrisSim
ChrisSim
edited April 24 in Mobile Security

Hello everyone,

I just wanted to inform you that both Scam Alert and Anti-Theft in the BD Mobile Security App were found disabled on not just my phone but also my mother's for no reason when turning the phone off and back on (since yesterday so version 3.3.234.2411 might be the culprit I guess because that update happened about then).

Then Autopilot suggests turning them on again but Anti-Theft seems to not operate at all (no toggle is on) and cannot be enabled (no reaction when the button is pressed); I am not sure if it is working properly in that state at all. Similar with Scam Alert but here the feature appears as enabled on the Scam Alert tab itself while Autopilot complains that it is not.

Additionally, Account Privacy is seemingly not working either; the accounts added – in my case one, in my mother's three e-mail addresses – are not there anymore and no scan can be initiated or performed.

After a few minutes – I cannot pinpoint exactly when – all of the aforementioned features start working again though as if nothing had happened. Curious behaviour.

Device: Samsung Galaxy S21 Ultra 5G / Samsung Galaxy A34 5G

OS: Android 14 / One UI 6.0

BD Mobile Security: 3.3.234.2411

(My mother uses the very same OS and BDMS version.)

Thanks a lot for your attention! :)

Best regards,

Christian Simon

Comments

  • ChrisSim
    ChrisSim
    edited April 24
    Options

    In case image proof is helpful :)

    Edit 1: The last image shows App Lock which is not working either ...

    I think there is even more to unravel here so the list of issues is likely longer than what I described in my posts I presume.

    Edit 2: It took approximately half an hour for the BD Mobile Security App to go back to its error-free state; my mother measured about the same time on her device.

  • Flexx
    Flexx DEFENDER OF THE YEAR 2023 / DEFENDER OF THE MONTH ✭✭✭✭✭ mod
    edited April 24
    Options

    Try reinstalling the product. For me, the product is running without any errors.

    If the issue persists even after reinstalling the product, kindly visit the Bitdefender support website  https://www.bitdefender.com/consumer/support/help/

    Select, Activate and Install → Install → I don't know → Contact Support → You will get the option of chatcall or email.


    @Gjoksi, @garioch7 what about you guys!

    Regards

    Life happens, Coffee helps!

    Show your Attitude, when you reach that Altitude!

    Bitdefender Ultimate Security Plus (user)

  • Gjoksi
    Gjoksi DEFENDER OF THE YEAR 2022 / DEFENDER OF THE MONTH ✭✭✭✭✭
    Options

    Hello.

    My specs:

    Samsung Galaxy A34 5G (SM-A346B/DSN)
    Android 14
    One UI Core 6.0
    Android Security Patch Level April 1, 2024
    Google Play System Update April 1, 2024
    BD Mobile Security 3.3.234.2411

    I was also facing issues with Anti-Theft and App Lock modules, exactly the same issues you are having on your phones. When i wanted to enable the Anti-Theft module, there was no reaction when the button was pressed, no matter how much i tried. The same happened when i tried to set PIN for the App Lock module.

    Today the issues for the 2 modules were solved by themselves, both Anti-Theft and App Lock work without any issue.

    Regards.

  • ChrisSim
    Options

    Exactly the same here.

    It will all stay that way and work for you @Gjoksi until the next time you reboot your device; then it goes nuts again for some minutes or maybe half an hour (as on my end) until the issue resolves itself again et cetera.

    I hope it gets fixed soon; I feel weirdly unsecured during that time of malfunction.

  • Petersl
    Petersl Defender of the month ✭✭✭
    Options

    Hi,

    I have same issue on my android but only the first 30 minutes after I've boot the device. I have also tried reinstalling the app but the issue persists.

    I've made a post about this issue on this forum and I made a ticket about this issue with bitdefender support.

  • Gjoksi
    Gjoksi DEFENDER OF THE YEAR 2022 / DEFENDER OF THE MONTH ✭✭✭✭✭
    Options

    Hello.

    You could check my comment here:

    (click on "2:35 pm" on right of my username to see the comment with the screenshots i posted)

    Regards.

  • [Deleted User]
    [Deleted User] ✭✭✭✭✭
    Options

    @Flexx ,

    Confirming issue. After my Galaxy S21 starts, the two components show that they are off. After 30 minutes or so, the messages disappear. It could be a UI bug . . .

    Have a great day.

    Regards,

    Phil

  • Flexx
    Flexx DEFENDER OF THE YEAR 2023 / DEFENDER OF THE MONTH ✭✭✭✭✭ mod
    Options
  • Same issue. Pixel 7a latest android and Google updates as of today. Several hours in and still no response from anti theft or scam protection. Reinstalled. This is my kids device so I've sent commands from bitcentral on my device to fix issues. No progress and also scans not working.

  • ChrisSim
    Options

    Hello everyone again,

    I just wanted to come back here to say that the latest version of BDMS (3.3.236.2418) has seemingly fixed all the problems raised in this thread.

    So thanks for the good work, Bitdefender! ^-^

    Best regards,

    Christian Simon

  • Alexandru_BD
    Options

    Thank you @ChrisSim for your patience, appreciation and feedback! 👍️

    Premium Security & Bitdefender Endpoint Security Tools user

  • ChrisSim
    ChrisSim
    edited May 26
    Options

    Hello @Alexandru_BD,

    the Scam Alert function was found turned off on both of our devices. I cannot say when it exactly happened unfortunately but we both turned it on again now and hope that it stays as it is.

    Is there any known issue regarding that feature?

    Edit 1: It stays enabled even after a phone reboot. So far, I have not seen any other feature other than the aforementioned Scam Alert being affected.

    Edit 2: I am running BDMS version 3.3.237.2421 currently. I see though that there is supposed to be a version 3.3.237.2422 if I am not mistaken. Maybe not for me (yet) because I am on Android 14 / One UI 6.1?

    Best regards,

    Christian Simon

  • Alexandru_BD
    Options

    Hi @ChrisSim,

    Precisely, a new version has been released on Friday, and this should fix the Scam Alert issue for good:

    Regards,

    Alex

    Premium Security & Bitdefender Endpoint Security Tools user

  • ChrisSim
    Options

    Thanks for the input @Alexandru_BD, the new update was just offered to me. Great timing ^-^

    Best regards,

    Christian Simon

  • ChrisSim
    ChrisSim
    edited June 1
    Options

    Hey @Alexandru_BD,

    after the patch to 3.3.238.2425 it is off AGAIN. I do not want to pay attention to it all the time so I would be very happy if it stayed enabled for once :/

    Edit: I see in the update history @Alexandru_BD posted above that it is a Scam Alert SDK patch; maybe consider for future updates to have them carry over the adjustments one has made prior to a new patch (if that is possible). Thanks! :)

    Best regards,

    Christian Simon

  • Alexandru_BD
    Options

    Well that's odd. As far as I know, there haven't been any recent reports for this going off again, so presumably this is an isolated case. Did it turn off again lately?

    Premium Security & Bitdefender Endpoint Security Tools user

  • ChrisSim
    Options

    Not an isolated case unfortunately; my mum just received the same update and it is off on her device now too. So if you install the patch, reboot your device and go to Scam Alert, you will find it disabled. If you turn it back on, it will stay in its enabled state at least.

    Best regards,

    Christian Simon

  • Alexandru_BD
    Options

    @ChrisSim we'll have a look into this.

    Thanks!

    Premium Security & Bitdefender Endpoint Security Tools user

  • agozob
    agozob Team Lead, Cyber Threat Intelligence Lab BD Staff
    Options

    Hi @ChrisSim,

    Thanks for reporting the issue, we're on it.

    I did run a couple of tests and can confirm that Chat Protection got disabled after an update to 3.3.238.2425, followed by a device reboot. Turning the feature back on in the app does fix the problem and it doesn't seem to occur if the device is rebooted again, as you already stated, so that's a fix until we release a patch. We'll keep looking into it and come back with updates.

    In the meantime, could you provide some more details on how you managed to reproduce this issue? Did the whole Scam Alert feature get turned off for you or was it just the Chat Protection toggle? Also, device details (model, OS version, etc) and screenshots of the problem are always very useful in any problem report :)

    Your help is highly appreciated and we're sorry for the inconvenience.

  • ChrisSim
    Options

    Hi @agozob,

    thanks for the acknowledgement! :)

    So to answer your questions: I personally check my BDMS app after (almost) every patch out of curiosity just to see if anything has changed so that is how I got aware of that Chat toggle being off. My mother received the patch days later – probably due to the fact that she has a different phone model – and we could observe the same behaviour there. As far as how much of the Scam Alert feature set was really affected, I cannot say for sure but I am quite certain it was just the Chat Protection toggle being disabled; my mother agrees with me there. Footage or any other proof we unfortunately cannot serve you with.

    Device: Samsung Galaxy S21 Ultra 5G / Samsung Galaxy A34 5G

    OS: Android 14 / One UI 6.1

    BD Mobile Security: 3.3.238.2425

    (My mother uses the very same OS and BDMS version.)

    Thanks for your attention and efforts! :)

    Best regards,

    Christian Simon

  • Petersl
    Petersl Defender of the month ✭✭✭
    edited June 5
    Options

    @agozob @Alexandru_BD

    Hi,

    I just tested it on my device (HK1RBOX running android version 12), I turned the chat protection on and rebooted the device, after reboot the chat protection stays enabled on my device.

    I do however have an other issue, when I boot my android device I connect it through a vpn app (expressvpn or nordvpn), then I open bitdefender mobile app and run a malware scan, the scan finishes correctly but when I then disconnect from my vpn and open the bitdefender mobile app it shows as a scan is running and it shows only the last app being scanned.

    It does this scan indefinitely until I either press the stop scan button (which does not always works) or reboot the device.

    However if I after I boot my android device and connect to the my vpn then open bitdefender mobile and run a malware scan, after the scan finishes I run a second scan and then when disconnecting from my vpn and open the bitdefender mobile app the scan is not running then and it shows as normal.

    So to get around this issue I always scan 2 times.

    Also when the first scan is running after boot of my device it shows the wrong animation. It shows the little cloud update animation and not the scanner animation. This corrects itself on the second scan, the correct scan animation is shown ending with the "checking threat database" little cloud update animation.

  • ChrisSim
    Options

    Hey @Alexandru_BD and @agozob,

    the latest patch I received today (3.3.241.2432) caused the following …

    It disables the Web Protection feature; even a reboot does not fix it. And after turning it on and a following device reboot, it is off again!

    The Scam Alert feature is shown as enabled but Chat Protection is disabled after the patch; when turning the feature back on, a subsequent device reboot does not disable it again.

    I do not know what to say; please do some more testing before releasing patches. I just renewed my BDMS license for another 18 months and would prefer a more reliable performance in the future.

    Thanks for your attention!

    Best regards,

    Christian Simon

  • ChrisSim
    Options

    PS: The very same problems do occur on my mum's phone. We experimented a little bit and could reproduce the error pattern(s) mentioned above on both of our devices. I forgot to mention that before; I am sorry.

  • Nunzio77
    Nunzio77 Defender of the month mod
    edited June 12
    Options

    After the last update when the phone is turned on or restarted, web protection remains deactivated even on subsequent restarts. You have to reactivate it every time you turn it on.

    Fix the bug.

    Nunzio ·

    Bitdefender Plus, Windows 10 Pro-32 Bit, CPU Intel Core2 Duo T7500, RAM 4 Gb - Bitdefender Mobile Security

  • Nunzio77
    Nunzio77 Defender of the month mod
    Options

    @Alexandru_BD and @agozob can you have the latest released version checked?
    There is a bug that does not keep web protection active after each restart of the smartphone.

    Thanks!

    Nunzio ·

    Bitdefender Plus, Windows 10 Pro-32 Bit, CPU Intel Core2 Duo T7500, RAM 4 Gb - Bitdefender Mobile Security

  • Alexandru_BD
    Options

    Hello @Nunzio77,

    Yes, help is on the way. I've discussed this with @agozob and the development team is actively looking into it. This will be fixed asap,

    Thank you very much for the heads-up! 🤜🤛

    Premium Security & Bitdefender Endpoint Security Tools user

  • Petersl
    Petersl Defender of the month ✭✭✭
    Options

    Hi,

    I have the same issue on my android box since updating to version 3.3.241.2432, the "web protection" turns itself of after every boot and I have to turn it on manually.

  • ChrisSim
    Options

    @Alexandru_BD and @agozob,

    I installed BDMS version 3.3.241.2437 just now and it fixed the aforementioned bug with Web Protection and it all looked fine at first but after a phone reboot Chat Protection got disabled again:

    If you turn it on, it stays on even after a phone restart so the same behaviour as I described in my comment below:

    My mum has exactly the same erroneous behaviour so it is reproducible.

    Thanks for your attention and work! :)

    Best regards,

    Christian Simon

  • Nunzio77
    Nunzio77 Defender of the month mod
    Options

    Nunzio ·

    Bitdefender Plus, Windows 10 Pro-32 Bit, CPU Intel Core2 Duo T7500, RAM 4 Gb - Bitdefender Mobile Security

  • Alexandru_BD
    Options

    Hello @ChrisSim & @Nunzio77,

    On Saturday, the latest BMS version 3.3.241.2437 was released and this strictly fixes the issue related to Web Protection.
    The Chat Protection issue is still being investigated and another hotfix for that will soon follow, so there will be a minor 'follow up update' that will specifically address this.

    Thank you for your patience and feedback! 🤜🤛

    Premium Security & Bitdefender Endpoint Security Tools user

  • Gjoksi
    Gjoksi DEFENDER OF THE YEAR 2022 / DEFENDER OF THE MONTH ✭✭✭✭✭
    Options

    @Alexandru_BD

    Hello.

    I just restarted my phone and it seems that with version 3.3.241.2437 the problem with the Web Protection module has been fixed.

    But, as you already said the problem with the Chat Protection turning off by itself after device restart hasn't been fixed yet.

    Regards.

  • ranger
    ranger ✭✭✭
    Options

    Hello,

    To those experiencing problems with features turning off, has anyone gone into the settings and checked whether the option to 'scan storage' is also disabled? I am surprised that nobody has mentioned it, because whenever I find that the other features are turned off, the option for scanning storage is usually also disabled. Am I the only one who has been experiencing that?

    Best regards,

    -ranger

  • ranger
    ranger ✭✭✭
    Options

    Hello again,

    Just in case I wasn't clear in my previous message, I've attached a screenshot to show the 'scan storage' option I was talking about. On my device, this often turns off at the same time as the other features that have been mentioned in this thread. Just curious if others experience this as well.

    Best regards,

    -ranger

  • ChrisSim
    ChrisSim
    edited June 17
    Options

    I do not think that specific problem ever occurred on my device/our devices but I will keep an eye on it! :)

    PS: The German translation of Scan Storage (the explanation text below) is quite bad; it should be reworked.

    Edit: What does the English text even mean either? "Include device storage in manual scans and on-mount" is no proper English either or am I just too bad at English/the technological vocab? ^^

  • Petersl
    Petersl Defender of the month ✭✭✭
    Options

    Hi,

    I can confirm that version 3.3.241.2437 fixed the "web protection" issue for me, it now stays enabled after boot. I did have the"chat protection" turned off as well when I rebooted my device after the update but only one time.

  • Petersl
    Petersl Defender of the month ✭✭✭
    Options

    Hi @ranger

    On my device "storage scan" is on and stays on.

  • ChrisSim
    Options

    Could it be that your device handles permissions a little too strictly and that is why it is off at times? :)

  • Nunzio77
    Nunzio77 Defender of the month mod
    Options

    HI,
    I updated to version 3.3.241.2437 and for now it seems to work well, after the first restart of the smartphone and subsequent restarts everything remains active as previously set.

    RealMe 8 smartphone
    Android 13

    Nunzio ·

    Bitdefender Plus, Windows 10 Pro-32 Bit, CPU Intel Core2 Duo T7500, RAM 4 Gb - Bitdefender Mobile Security

  • ranger
    ranger ✭✭✭
    Options

    Hello,

    'Thank you' to everyone for checking if their 'scan storage' option was also being turned off. I am surprised I was the only one. I assumed it had been related to the other issues in this thread, because they all started happening at the same time on my device, and they all continued recurring across multiple uninstalls/re-installs over some weeks. However, I haven't seen any of them turn off since re-installing again yesterday, so as long as I was the only one with that particular issue, I'll quietly pretend it never happened as long as it doesn't come up again. 😅 If it does, I'll make a separate thread. 😁

    Best regards,

    -ranger