Automatic Game Mode Is Not Working?

Options

I have set "Automatic game mode" to "OFF" in Settings|General|Game Mode.


However, when I run a game, the Game mode still starts automatically.


It generates an "Autoscan settings changed|Autoscan is off|Action: Autoscan was disabled" red alert in Events|Antivirus|Virus Scan.


(And another event reenabling Autoscan after exiting the game.)


The file C:\ProgramData\Bitdefender\Desktop\Events\history.xml shows a series of 3 entries for that single event:


- Silent Mode is disabled


- Autoscan was disabled


- Game Mode is enabled


(And the 3 opposite entries after exiting the game.)


I tried with and without Auto Pilot enabled, and got the same results regardless.


Isn't disabling the "Automatic game mode" setting supposed to prevent Bitdefender from entering the game mode automatically when a game or full screen app is launched by the user, or did I misread the product documentation?


The documentation does not actually say what "Automatic game mode" does, just how to turn it on or off, so I assume it's supposed to do just what it says.


Does it repro for other users?


I never checked the events for it before, so I am wondering if this is new, consecutive to the latest 15.0.34.1437 update, which includes a Game Mode bug fix.

Comments

  • Still no answer 9 days later. FYI, the game in question is the Doom II.


    No big deal since it's an old game, but it's worrisome that the Automatic game mode seems to be on even when it's disabled.


    See the corresponding event in history.xml:


    <event bodyLength="138" evflags="0" type="0" timeStamp="1322454634" source="PTweaks">


    <subject>Game Mode</subject>


    <action>Game Mode is enabled</action>


    <message>1|1||C:\Data\readonly\DOOM\DOOM 2\gzdoom.exe|2</message>


    </event>

  • rootkit
    Options

    Hi Chimel :)


    Please send me that history.xml file and a support tool via PM.


    Thank you.

  • Well my computer hasn't entered game mode automatically since I enabled Auto Pilot, and I haven't played a game either.


    But I could repro with Auto Pilot off today and I confirm it does not repro with Auto Pilot enabled.


    I'll send you the files by PM later today. Thanks.

  • rootkit
    Options

    Hi Chimel :)


    You can send those file and anything you find strange.


    Thank you.