Wallet "again" not working in Firefox


Firefox shows (since the last BD update) that Wallet is not verified for use in Firefox...


Thanks for fixing this!



  • pdeck
    pdeck ✭✭

    I'm having the same issue. Just started today.

  • Same here, just did the post-update reboot, but even that hasn't fixed it. <sigh> Come on, it can't be that difficult... Good thing I had the password to this site saved in the browser. ;)

  • Same here; Bitdefender Wallet 4.1.7 is disabled.

  • TonyR
    edited March 2017


    I have windows 10 installed & have Bitdefender Total 2017 version.Lot of issues with the 2017 version. Should not have purchased this product.

    I am trying sort out help with safepay freezing issue  with support team over the last few weeks and today encounter this problem.

    The Wallet extension is not accepted  by the Firefox.

    I tried to open the module under privacy tab and but even i click it the Firefox doesnt allow the extension.

    Hope someone can help.

    Screen shot attached;

    BD total.docx

  • Sorin G.
    Sorin G.
    edited March 2017



    Please go to the Bitdefender interface and click on the Update Now link. After the product finishes updating reboot the machine.

    Your Firefox Wallet should show 4.2.4 on Bitdefender 2017

  • Sorin,

    Correct, that did the trick! Thanks for the resolve!

    Kind regards,


  • As of Tuesday, 14 March 2017, Wallet is disabled for bad signature in Firefox (after an update on Monday).  A repair-reboot failed to fix.  Then an update-reboot also failed - with version 4.1.7 showing.  A regression?  Would be grateful for a quick fix.  Thanks.

  • Hello,


    I would advise contacting our support team via [email protected] with the logs from the Bitdefeder Support Tool to further investigate this occurrence.


  • I went through the same issues with Firefox and Wallet, however, when Wallet was finally reestablished the icon doesn't show up on the Firefox tools banner when the browser is opened. I have to close Firefox and open it again for the icon to appear in the banner. This is VERY annoying.

    Anyone know how fix this? 


    Another thing I just noticed:  When I open 'Add-ons' in Firefox Tools it shows Wallet installed - however - it only has a 'disable' selection.  The 'Remove' and 'Options' buttons are missing so I can't uninstall and reinstall Wallet. 

    Very strange. Waddup?

  • Hello,


    There is no need to reinstall Firefox. Ensure you reboot the machine after updating the product.

  • I got tired of Firefox disabling Wallet every time it updated. Even after updating to Firefox 53.0 and updating Wallet, reboot and reinstalled - it just kept disabling it. I went in to the Configuration Editor and disabled xpinstall.signatures by changing it to 'FALSE'.  Now the Wallet icon shows up in the toolbar and works every time.  I'm careful about the add-on and apps on my PC and don't want Firefox to keep disabling stuff every time it updates. If it continues - switching to Google Chrome.