Misleading Windows Error Message!

I have been going crazy for three days trying to figure out what the heck was wrong with my Administrative permissions in Windows. When I tried to import images in from my camera using the software I've used for years (in my case, Canon) or or tried to save images to my Pictures Folder from Photoshop, I would get a Windows error message. (See attached). 

After trying every Windows modification under heaven, for some reason, I checked my Bitdefender setup. I remembered that I had recently turned on Ransom ware protection but never put 2 and 2 together......until today. 

I turned off the protection and all the importing and saving problems went away. Now I realize that this was all due to my unfamiliarity with Bitdefender (which I have used for many years and love) but perhaps there is a way to have the Bitdefender itself generate a more definitive message rather than having it appear to be a Windows permissions problem?


I just thought I would share with everyone who might run into the same issue.


Vinny from Long Island, New York USA