Block TCP port 135


I am using BDIS 2020. It seems that Windows 10 opens TCP port 135 for legitimate reasons & if you don't want this exposed to your local network, the recommendations are to block this incoming port within Windows Firewall. I have tested this from another local device and can see that 135 reports as open on my PC. I cannot see how to block a port in the firewall rules, they only allow the designated port, there is no block option.


Is it possible to block selected incoming ports within Bitdefender's Firewall & if so how do I do it?

Comments



  • 3 hours ago, SproutingVeg said:



    I am using BDIS 2020. It seems that Windows 10 opens TCP port 135 for legitimate reasons & if you don't want this exposed to your local network, the recommendations are to block this incoming port within Windows Firewall. I have tested this from another local device and can see that 135 reports as open on my PC. I cannot see how to block a port in the firewall rules, they only allow the designated port, there is no block option.


    Is it possible to block selected incoming ports within Bitdefender's Firewall & if so how do I do it?



    Hello,


    You may create a rule in Bitdefender Firewall as it follows:


    - open Bitdefender


    - click on Protection 


    - under Firewall click on Settings


    - then click on Add Rules


    - check the option Apply this rule to all applications


    - next to Protocol set it to TCP


    - then click on Advanced tab


    - check Custom Remote Address box


    - add the port in the Port box


    Hope it helps.


     


  • Thanks for that, it was what I was doing, but I then found out that as I wanted to block the incoming port, what I was doing wrong was that I had not set the "Permission" to off. Perhaps in a future release it would be more intuitive to replace this switch will an Allow/Block dropdown box?


    One quick related question though, once I had set the rule to block the port, to prove a point I deleted it. The port still remained blocked however, until the user logged off. Is this the way it works or does it remain blocked until something in the firewall times out? This is purely a point of interest though.

  • Roxana GRoxana G
    edited September 2019


    23 hours ago, SproutingVeg said:



    Thanks for that, it was what I was doing, but I then found out that as I wanted to block the incoming port, what I was doing wrong was that I had not set the "Permission" to off. Perhaps in a future release it would be more intuitive to replace this switch will an Allow/Block dropdown box?


    One quick related question though, once I had set the rule to block the port, to prove a point I deleted it. The port still remained blocked however, until the user logged off. Is this the way it works or does it remain blocked until something in the firewall times out? This is purely a point of interest though.



    Hi,


     


    If you have deleted the rule, then the rule should no longer apply. It may be possible that in some cases a restart to be required depending on what is blocked.


  • That's what I was trying to ascertain, if I need to reboot the PC to take account of the selected rule, that is fine.

Sign In or Register to comment.