Bitdefender prevents Time Machine back up with MacOS Monterey



  • Having the same problem on Macbook Air using Big Sur 11.6.8 ------

    An unauthorized app attempted to access your backups.

    App: /System/Library/CoreServices/backupd.bundle/Contents/Resources/backupd

    We blocked the app to prevent it from altering the content of your backups.


  • Gjoksi
    Gjoksi Defender of the year 2022 ✭✭✭✭✭



    First, take screenshot(s) of the issue

    and create a log file on your MacOS device using BDProfiler, by following these steps:

    Next, contact Bitdefender Consumer Support by e-mail:

    http with short description of the issue.

    After that, you will get an automated reply by the Bitdefender Customer Care Team, with your ticket number.

    Now, in reply to that automated reply, you can send the screenshot(s) you already took and the log file you already created in the first step.

    Since you are all done, just wait for the support engineers to investigate your issue and find a solution to fix the issue.

    Remember that the screenshot(s) and the log file will help a lot to the support engineers for better and faster investigation on your issue and finding a solution.




  • After Bitdefender did update very recently, I am having same problem with MacOS 12.5.1 and Seagate external backup. Looking over discussion posts, this has been going on a long time. And I'm trusting my digital existence to such an unresponsive company?! Note to self: DO NOT RENEW subscription!

  • And I can't change settings in dashboard as a workaround.

  • Is it me, or have BitDefender and Netgear become purveyors of ransomware for Time Machine Backups?

    Perhaps it's time to light a fire under Netgear's butt. I never would've installed bit defender had it not been bundled with my Orbi. This is getting ridiculous.

  • Just updated to Mac OS 12.6 and the problem started. I turned off Time Machine protection and now its working fine other than the time machine backups are no longer protected

  • Why is this still happening? I just started having this problem this week (SEPTEMBER 2022). I even called support, was transferred three times, then gave up. Really poor offshore support! Really poor! I am a version behind on Bitdefender and can't get it to update, and can't do a backup, still. I am plenty tech-savvy, so this is just stupid. I've already given up on Netgear and Orbi after some other BS, but this is certainly the final nail in the coffin. When I'm done with this overpriced Orbi, I'm done with Netgear for good.

  • Eric Johnson
    edited September 2022

    After upgrading to Mac OS 12.6 (Mac mini) last night, it looks this issue has started now for me. Bitdefender,

    Critical Notification: Time Machine Protection

    Feature: Anti-Ransomware

    An unauthorized app attempted to access your backups.

    App: /System/Library/CoreServices/backupd.bundle/Contents/Resources/backupd

    We blocked the app to prevent it from altering the content of your backups.

    Great, now I have a recommendation from Bitdefender to turn on Time Machine, and at the same time it blocks access to the backup drive.

  • Just noticed I have the same problem. It started August 25, 2022.

  • Unbelievable. Almost a month and still no fix for the Time Machine error. Whether it's just incompetence or disdain for its customers, Bitdefender has proven unworthy for any Mac user.

  • having same issue - September 23. If I turn off the Time Machine "Protection" feature - it back-up just fine. Apple suggests to NOT USE 3rd Party AV protection.

  • Having the same problem on my M1 Pro Mac with Monterey installed...bitdefender with Netgear is blocking Time Machine back ups now...never had this issue before updating to Monterey! :-(

  • Alexandru_BD
    Alexandru_BD admin
    edited September 2022

    Hello and thank you for your patience.

    I regret this inconvenience and the teams responsible for the task also send their sincere apologies to everyone affected by this.

    A fix will be deployed with the next update. Everyone here wishes the update to be quick as well, but it involves a huge number of moving parts and the developers must ensure there are no loose ends. It might end up fixing an issue and entering another, if the update is not tested by multiple engineers, multiple times. Hence the delay, but we have to trust the process and wait, as there are no news at the moment.


  • Hi - I have followed this thread for a year now as I had this bug from when I purchased it. My renewal is now due and unfortunately I will be going elsewhere.

    I don’t really understand how Bitdefender can produce such a sophisticated product and yet not able to understand why it stops Time Machine. I can’t be in a position where I’m safe from viruses yet have no back ups.

    It’s a shame and I hope for you all the next fix does indeed fix it.


  • Hello @hydev99 and thank you for sharing your thoughts with us here. I am sorry to hear that. If you can bear with us for just a little bit longer, the devs will deliver the promised fix. We appreciate your patience and understanding.

    Over the course of the investigation, the developers were well aware of the implications and root cause, but as I've pointed out in my previous comment, more testing was required in order to ensure proper functionality and a permanent fix that would prevent the issue from resurfacing.

    The fix will arrive eventually, we are standing by for updates and we look forward to a swift deployment in the next build.


  • Well, I fixed the Time Machine bug caused by Bitdefender. I just uninstalled the software. (Obviously renewal revenue has now reached $0)

    Bitdefender has shown no interest in its customers other than from a revenue perspective. This is clearly demonstrated by their lack of interest in the Time Machine bug. From what I can ascertain it has been a periodic issue for an about a year.

  • Alexandru_BD
    Alexandru_BD admin
    edited October 2022

    The reality is quite the opposite. There are some dependencies for this issue to be fixed permanently and the developers also encountered various challenges along the way. I hope you will reconsider our products in the future, as this issue is temporary and will be resolved eventually.

  • I am running MacOS Ventura (13.0), and installed Bitdefender Anti-Virus for Mac (

    I had to disable the Time Machine protection in order for my backups to log was filled with many blocks until I disabled this function.

    Is there a resolution?

  • Flexx
    Flexx Moderator, Defender of the month mod

    Generate bitdefender BDProfiler log for macOS (

    Share the logs & your query with bitdefender support team by dropping them an email at [email protected]

    The support team will reply back to your query within next 24-48 hours excluding weekends.


    OMEN Laptop 15-en1037AX (Bitdefender Total Security) & Samsung Galaxy S22 Ultra (Bitdefender Mobile Security)

  • Hi @Kevin_CSTX,

    This indeed a known issue and currently the only available workaround would be to disable Time Machine protection, unfortunately. This behaviour is still undergoing repairs and we hope the developers can deploy a fix with the upcoming updates.

    Thank you for your patience and understanding.


  • any new info on this issue??

  • Not yet @loubendor,

    An update that solves this is scheduled for Q2, but we don't have the exact date of deployment.


  • I upgraded my 10yo iMac to an M2Pro MM and suddenly find my time machine backups won't run to a remote locationm with BitDefender installed, I tried all of the various settings recxommended, but as soon as I install BD I find the only way to resume TM backups is to de-select the drive and reselect it creating a new backup. Luckily I alspo run TM to a locally connected drive othgerwis I'd be screwed. Seriously BD, 6 months in and still no fix?

    I'm an orbi user, and this ussue is making me revisit this decison as neither BitDefender or Netgear are treating this as a priority fix. If this was a Windows bug it would have been fixed in a week.