Bitdefender IS on Windows 11: high mem usage after a couple of hours


as you can see from the picture below:

Bitdefender has reache about 1GB of memory usage after a couple of hours that my desktop PC is running (Windows 11 22621.2070 with Bitdefender IS I know that memory is used for normal operation as well as for cache mechanism that make Bitdefender absolutely light and fast...but I think that this time there's some evident memory leak.

Bdservicehost task that require 823,9MB started with less than 400MBs and then it was continuously increasing mem consumption without releasing it (even if with small increment).

Can you devs investigate a little and look for some optimization in the next builds?




  • Scott
    Scott Defender of the month mod
    edited August 5

    Hi @Spulci

    Here's where I'm at on my end.

    Kindly see if this article is helpful:

    Otherwise, for the engineers to possibly know what's going on, you should contact Support from the link below. Go through the How To's and Troubleshooting prompts until reach the black Contact Support box. You will have three options, Chat, email and phone support, which is not toll-free. They may need to have you create a log file to send to them, in which case they will provide a seperate email link for you to be able to upload it.

    Kind regards,


    All Bitdefender Home Product User Guides:

  • Scott
    Scott Defender of the month mod
    edited August 5

    Hi @Spulci

    I'm not trying to over-prove a point, but just to be sure, I've been running this notebook consistently for the last 3.5 hours, including watching a bit of a DVD movie connected to my LG portable DVD player. I also have these high-impact apps running, and here's where I'm at. If it makes a difference, I do have Windows Power and Battery/Power mode/ set to Best Performance.

    Kind regards,


    All Bitdefender Home Product User Guides:

  • Hi @Scott ,

    your experience is more than welcome :) Consider that I've got 32gb of RAM, this could make bdservicehost eventually more aggressive in terms of caching strategy. I've got a look at the troubleshooting page but there's nothing more I can do to prevent memory usage.

    BTW when starting the system, bdservicehost has a low memory impact. Opening Firefox with a few tabs makes a stable increase in memory consumption. Closing Firefox will not give back the memory previously allocated.

    I think I will open a support ticket soon.

    Thanks a lot,


  • Hey Simone,

    Sounds like you might have the same issue I am currently experiencing. I have a Win 11 laptop using BitDefender Total Security with 64 gb of RAM. Upon boot up bdservicehost.exe will start out consuming around 400 mb then steadily grow to over 25 gb. If I leave the computer running it will eventually lock up/blue screen within the day. Restarting the PC will start the process over again at around 400 mb and seems to be the only way to get the memory back. As this is happening, the available physical memory will decrease at a similar pace. This will then be reflected in bdservicehost showing it is using 40% of available memory at 16,400 mb of usage (as an example). I had tried every tip I could find online (including clean uninstall and reinstall multiple times) with no success. I finally contacted bitdefender support in July and they had me run some logs and tests. Here is the response I received on July 26th from support...


    "I have looked into the case and it seems that the situation is caused by an issue that has already been acknowledged by our development team. 

    We are currently working on a fix that will be done by means of an automatic update and won't require any additional action on your end.

    I will get back to you with an update regarding the fix as soon as we have one."


    So far I have heard crickets! I still have the issue and have to restart several times a day or just shut down and not use that pc. Unfortunately, I have already renewed my Bit Defender for this year, but it may be my last. I continue to hope for a resolution before I have to switch security suites.


  • Hey Dadna,

    I've read your post....I've never experienced a so high memory usage /you've reached 25GB of mem allocation fro bdservicehost...really????)...I've reached 800mb of ram for bdservicehost at worst.

    Support asked me to uninstall BD with a specific uninstall tool covering version 2023 and then to reinstall latest version downloading file from BD Central site.

    As you can expect nothing least since a few days where I found BD finally releasing memory with a strategy yet to be understood....but I can now see bdservicehost even 350MB after hours of activities with my desktop PC, eventually reaching 600MB or a few more.

    I think they are now testing some optimization to their's clear that they have some memory leaks or issues on some configuration that needs to be fixed.

    Let's see what happens


  • I am experiencing the same exact issue. Just reached out to support, and awaiting a response.

  • We are using the gravity zone version and have been experiencing this for over a week, it runs the PC out of memory and it grinds to a halt. It is so frustrating that it is taking this long for a resolution. I finally put in a ticket on the 22nd.

  • Can't say that I'm reaching 25GB of mem from bdservicehost....but again I start from 380MB and yesterday after a couple of hours I reached 890MB....closing Firefox and all the other apps do nothing...bitdefender do not de allocate memory (allocated for example at the first Firefox start to enable its protection).

    Hope they will investigate further. Your issue is bigger than mine (25GB allocated could be a serious issue): they should definitively fix this bug (no, we can't consider this an optimization issue at all).


  • Spulci
    edited September 2
  • cainet
    edited September 2

    Same issue started for me today. The bitdefender service starts out after bootup at 380-400 MB. Slowly but surely it creeps up to consume all available RAM. Then my system freezes up and needs a hard reset.

    Already tried clean reinstall, didn't improve the situation.

  • Hi @cainet,

    Have you already tried the steps suggested in this article?


  • Still no fix for this issue! :(

    I did just receive an update from support that they are still working on it, but no expected timeline.

    I have several PCs on Bitdefender and fortunately only one has this issue. However, rebooting that PC every couple of hours just isn't sustainable. I am currently considering other, inexpensive security solutions, so that I can uninstall Bitdefender on this computer until there is a fix available. Anyone have some suggestions?


  • Bumping. I'm experiencing the same issue, with the exact pathology. If left to its own devices, the rate of consumption of memory by bdservicehost compunds. Even as applications (Firefox, etc) are closed, there is no release of memory. I have 32GB of RAM and typically restart the computer once bdservicehost is consuming 4GB.

    I am very hopeful that a release is forthcoming to address this known and debilitating issue.

  • Hello @professor24 and thanks for joining us here and for sharing your experience.

    I think it would be best to contact the Support engineers to solve this. It's true that this behavior has been reported on several occasions in the past and for this reason, a support article containing suggestions to reduce CPU and disk usage was made available. But as @DadDna pointed above, he owns several PCs on Bitdefender and only one has this issue, so there has to be something specific that causes it, because the normal memory usage for bdservicehost is around 500 MB, as explained in this article:

    You can get in touch with the Support engineers by choosing one of the contact channels available here:

    Let us know how it goes.



  • Stamp
    edited September 12

    Joining in, pretty bad. Went to have dinner with a normally working computer, idle with no extra loads, came back with all 32 gb of ram used. 20 of them by BitDefender....

    Right now it seems to have chilled quite a bit (after a few reboots) and it's just between 4-5 gb. But on the other hand it's eating a third of my cpu by upsetting WMI Provider Host and AIDA64, so that's nice.

    Current system uptime is 1 hour 47 minutes. SFC found nothing, let's see if DSIM helps.

    Edit: DISM found nothing wrong, but I now can offer the value of 5 minutes to reach 1 gb (tested over a couple of reboots) and in less than two hours I’m back to over 18 gb.

  • Can't edit anymore, here's an update: it's now at 23.5 but that's not as bad as it looks. Yeah. C: is a dozen gb fuller than it should, so out of 32 gb of system memory it went and ate roughly 35.

    How about reverting back this absolute train wreck of an update? I'd uninstall the whole thing but I don't want to lose my lengthy list of exceptions.