Bitdefender blocking access to embedded Twitter windows in news articles.

Howdy. I just switched over to BD after more than decade with Webroot and so far I like it except for this one issue. Where there should be a Twitter window in the article there is a blank empty space.

I How do I fix this issue please?



  • Liobet
    Liobet Defender of the month ✭✭✭

    Hi Terry Summer,

    I am not sure I understand, sorry. I do not see the article and the blank empy space you talk about with Twitter.

    Do you mean you do not have access to Twitter news because of Bitdefender... VPN ?

    Lots of sites detect and block VPNs.

    If Twitter blocks Bitdefender VPN, you'd better change the address IP ( country)



    AMD Ryzen 7 5800X3D 8-Core Processor3.40 GHz 32,0 Go [ Bitdefender Internet Security + VPN] + Galaxy A13 Samsung Android.

  • Hi Liobet,

    Thanks for your response. I am not using BD's VPN. In this CBC news article there should be a Twitter box right below this paragraph, "In a social media post that tagged Trudeau, Netanyahu said Israel isn't the one "deliberately targeting civilians, but Hamas that beheaded, burned and massacred civilians in the worst horrors perpetrated on Jews since the Holocaust."

    If BD is on I get a blank space. If it is off the I see the twitter box.

  • Liobet
    Liobet Defender of the month ✭✭✭

    AMD Ryzen 7 5800X3D 8-Core Processor3.40 GHz 32,0 Go [ Bitdefender Internet Security + VPN] + Galaxy A13 Samsung Android.

  • Gjoksi
    Gjoksi DEFENDER OF THE YEAR 2022 ✭✭✭✭✭


    My specs: OS Windows 10 Pro 22H2 x64 With Latest Windows Updates Installed; Installed On 18.01.2023; OS Build 19045.3693; Experience Windows Feature Experience Pack 1000.19053.1000.0; BD Total Security; uBlock Origin 1.53.0 On Mozilla Firefox 119.0.1 x64; uBlock Origin 1.52.2 On Microsoft Edge 119.0.2151.58 x64

    Works fine for me, on both Mozilla Firefox (pic. 1) and Microsoft Edge (pic. 2):

    Do you have Bitdefender's Anti-Tracker extension installed and/or enabled on your browser?

    If so, check out this article:


  • Hi Gjoksi,

    Thanks for your reply. Anti-track was indeed on and I have tested with it off to no avail. This morning I can see the Twitter box with Firefox and with Edge but there is a blank space with Chrome. I use Firefox 99% of the time now so I guess it is what it is.

    Oh and I should take a sec to apologize for using such a fiery political pop-up as an example. I could have found something less volatile.

    Thanks again Gjoksi!

  • RedsFan
    RedsFan ✭✭✭
    edited November 19

    Maybe another extension doing this, an Adblocker or other extension.

    Also using chrome and no problem.

  • Hi RedsFan,

    I turned them all off and the same result.

    Thanks for your reply.

  • Gjoksi
    Gjoksi DEFENDER OF THE YEAR 2022 ✭✭✭✭✭

    Hello again.

    I did a fresh install of Gogle Chrome 119.0.6045.160 x64, no extensions were installed, and again it works fine for me:

    Next, i installed uBlock Origin 1.53.0 on Google Chrome, and again the website works fine:

    So, i believe that Bitdefender is NOT blocking the website.

    Anyway, you could try resetting Chrome, by following these steps:

    and see if that solved the issue.

    Or try the uninstall / reinstall process of Google Chrome: